Hello, I recently needed "conio.h" library for a C project. After coming across the internet I found out that this C library comes form MS-DOS Universe and that's why it is not preinstalled with kali. Since I was making more searches I found a thread that could led you to a SourceForge website that had this file and in the description it said that is a Linux version. I download it and I made a mistake. I ran the command "cp /root/Downloads/conio.h /usr/bin/gcc" because I didn't know the path that gcc had other " .h " libraries and I came out, breaking the symlink of gcc. Whenever I run " gcc " command it tells me:

"/usr/bin/gcc: line 1: syntax error near unexpected token `('
/usr/bin/gcc: line 1: `// Copyright (C) 2005 by Piotr Helka (piotr.helka@nd.e-wro.pl)' "

Which are the lines of conio.h library. I haven't tried much solutions since I didn't know very well about symlinks yet and I guess this is the first thread of this kind. Actually, only " gcc-8 " command seems to work but I want to fix this issue with other gcc's.

Commands that shows info about my system:
lsb_release -a:
No LSB modules are available.
Distributor ID: Kali
Description: Kali GNU/Linux Rolling
Release: 2019.4
Codename: kali-rolling
root@thecowmilk:~# cat /proc/version

cat /etc/os-release:
PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"

Any Help would be appreciated!