Results 1 to 3 of 3

Thread: GNOME GUI doesn't reckognize WiFI-Adapter.

  1. #1
    Join Date
    2019-Nov
    Posts
    1

    GNOME GUI doesn't reckognize WiFI-Adapter.

    Hey there.

    So, my problem is, that I can connect to WiFi networks, using the terminal, but my GUI (Gnome) shows me, that it can't find a Wifi-Adapter.

    Version:
    5.2.0-kali2-amd64 #1 SMP Debian 5.2.9-2kali1 (2019-08-22) x86_64 GNU/Linux
    I just installed Kali light and switched to Gnome, installing the following packages:
    Code:
    apt-get install gnome-core kali-defaults kali-root-login desktop-base
    Im using the following, to connect to WiFi:
    Code:
    sudo ip link set down
    sudo ip link set up
    wpa_supplicant -B -iwlan0 -c /etc/wpa_supplicant.conf -Dnl80211, wext
    sudo dhclient wlan0
    As stated, that works, at least until I restart the system.
    lspci show the following as network controller:
    Code:
    04:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
    I downloaded this devices drivers from the Intel site and pasted them to /lib/firmware, which also wasn't successful, after a reboot.
    I tried upgrading the system and also installing the linux firmware with apt.
    network-manager-gnome is also installed.

    Help would be appreciated.

  2. #2
    Join Date
    2017-Jan
    Posts
    11
    If You can connect usung command, try install Plasma and install plasma network manager, add it to task, and check it.
    Code:
    sudo apt-get install plasma-nm
    What about kali live ? do u see Your wifi adapter ?

  3. #3
    Join Date
    2016-Dec
    Posts
    728
    When some piece of hardware doesn't work as expected, the first reflex should ALWAYS be to look in dmesg to see if there are any error messages.

    lspci is great but it only tells the presence of a device, not if a driver is loaded or if the firmware is missing.

Similar Threads

  1. Replies: 2
    Last Post: 2017-03-28, 13:28
  2. Gnome doesn't work after upgrade to 4.8.15 kernel
    By AprilBear in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2017-01-29, 13:13
  3. Wi-Fi USB Adapter doesn't show networks
    By Void5 in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2016-11-07, 01:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •