Results 1 to 3 of 3

Thread: Alfa AWUS036ACS Not Working as Intended

  1. #1
    Join Date
    2019-Oct
    Posts
    2

    Question Alfa AWUS036ACS Not Working as Intended

    Hello, People of This Forum.

    I am quite new to the whole Linux and Pentesting Community and all my education has been self taught as of recently.

    I bought a Alfa Usb Wifi adapter (AWUS036ACS) last month that has the Realtek rtl8811au chipset, which was said to work on kali linux and any other pen testing OS's for the use of it's monitor mode and packet injection. I am running the newest version of Kali linux.

    I installed the drivers needed using sudo apt-get install dkms, sudo apt-get install realtek-rtl88xxau-dkms. I've tried using the wifi adapter with the kali linux large VM and also a dual boot install of kali linux alongside parrot os on my laptop. For my VM I have the extension package installed and have it set to usb 3.0, and when I insert the wifi adapter into the VM it doesnt show up on iwconfig.

    When I do lsusb i get,
    "Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 004: ID 0bda:0811 Realtek Semiconductor Corp. 802.11ac WLAN Adapter
    Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub".

    When I plug in the adapter into my Kali Laptop, it shows the device under wifi but doesn't connect giving me an error of "connection failed, Activation of network connection failed".
    But if I do iwconfig I get,
    "wlan1 IEEE 802.11 ESSID:"5G" Mode:Managed Frequency:5.18 GHz Access Point: BE:4D........ Tx-Power=18 dBm Retry short limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:off"

    With it being up, I thought to check airmon-ng if the adapter showed and if I could use it in anyway. So for airmon-ng I get "phy1 wlan1 88XXau Realtek Semiconductor Corp. 802.11ac Wlan Adapter" I do also have a PCI wifi card inbuilt on my laptop that shows up on airmon-ng as "phy0 wlan0 iwlwifi Intel Corporation Wireless 7265 (rev 59)"

    After this I did airmon-ng check, then airmon-ng check kill, and then airmon-ng start wlan1, and get this for iwconfig, "wlan1 IEEE 802.11 ESSID:"5G" Mode:Monitor Frequency:5.18 GHz Access Point: BE:4D........ Tx-Power=18 dBm Retry short limit:7 RTS thr:off Fragment thr:off Encryption key:off Power Management:off"

    And further can use airodump-ng wlan1 to scan networks on the laptop.

    Now I haven't tested the adapter with packet injection, and I know this is long winded but I want to know if the wlan1 not showing up as wlan1mon, after enabling monitor mode, shows a sign of any problems, also what is happening with the Activation of network connection failed, because it doesn't let me connect to the frequency I select, and why the driver isnt being shown under iwconfig in the VM, and if this adapter would pose a threat to me learning how to wifi pentest.

    I have also tried service network-manager restart to see if it helps resolve the connectivity issue but seems not.

    If there's any more information you need to help resolve this, I would be pleased to supply it.
    Thank you for taking the time in advance.

  2. #2
    Join Date
    2019-Oct
    Posts
    56
    Sorry I just glossed over that. It's like one of my posts but more confusing.
    First just use it on the live USB less hassle.
    You don't have to install the drivers just plug it in and it works so you might have broke something try a clean install see what happens.
    Your Intel card should work too mine does.
    Type airmon-ng pick the adaptor you want to use then type airmon-ng start wlan0 or wlan1 whatever the name of the adaptor you want to use is.
    Then airodump-ng and the new name wlan0mon wlan1mon whatever.
    Then try
    airodump-ng wlan0mon you know your cards name at this point, and you should see the world around you. Cntrl c stops it.
    To get your wifi back. Airmon-ng stop wlan0mon or whatever.
    systemctl restart NetworkManager.service just like it is here.
    Since your just starting theres a bit of disappointment and a lot of work ahead most things dont just work. It's not a movie nothing takes ten seconds not everything can be compromised and cracking passwords can take thousands of years and if the password isnt in the list you've wasted a few millennia.
    Most scripts arent going to work on most things they have been patched.
    Follow this guide for turning up your tx. That's the power on your adapter.
    https://miloserdov.org/?p=337
    Follow this to change your mac.
    https://null-byte.wonderhowto.com/fo...track-0149937/

    It's an old guide but good.
    Until you learn a lot more dont go messing around trying out your new skills on websites or what not, the feds will get you.
    Learn to become as invisible as possible first then branch out.
    Change your mac before you fire anything up especially if your logging into someones wifi the router keeps logs. Plus your mac gets broadcasted that's one of the ways you can get caught.
    Good luck have fun.

  3. #3
    Join Date
    2019-Oct
    Posts
    2
    Thank you for the reply, I
    recently returned the Adapter and looking to purchase the alfa awus036nha as substitute. I have yet to try using a live usb of Kali, so thanks for the pointer, also sweet links, i was searching for guides on how to increase the tx power, due to the alfa awus036nha being tx locked to gb when bought from the Canadian amazon.

    The mac address changer is a good tutorial, totally forgot about the importance of that identifier, thankfully I haven't tried experimenting with anything other than the mobile network on my phone. I hear you on the continuous disappointing trials of getting things to work and understanding what eventually caused the error xD, thankfully the internet is filled with information and there are always helpful people like you to give me advice during my journey,
    so I thank you Robert;
    May you also stay safe and come out victories through each endeavour!!

Similar Threads

  1. Alfa awus036acs
    By milestone in forum General Archive
    Replies: 2
    Last Post: 2018-05-25, 17:08
  2. Kali Usb not working as intended for me
    By DasX in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-06-19, 08:12
  3. Replies: 0
    Last Post: 2015-06-03, 14:10

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •