Results 1 to 4 of 4

Thread: Issue with installer on uefi machines that have existing partitions. Can't install Grub. Solved?

  1. #1
    Join Date
    2019-Nov
    Posts
    161

    Cool Issue with installer on uefi machines that have existing partitions. Can't install Grub. Solved?

    Hello,

    So I was installing Kali on my 2015 MacBook Pro (Model A1502), and I noticed that I was unable to install GRUB. After investigating the issue, I realized that the Kali Installer was picking up my internal HDD's EFI partition and mounting it as as /media early on. I checked this, by going to a command prompt in the installer (Ctrl+Alt+F2) and typing 'mount'. This, in turn, caused the installer to not only be unable to repartition my internal Hard Drive, but also prevented the installer from mounting my EFI partition under the /target/ tree in the installer.

    For reference, I created the Kali Installer with the 'dd' command, to raw write the contents of the ISO to a flash drive. Also, FWIW, I am using the 2019.3 release of Kali.

    When I restarted the installation, I unmounted the internal drive early on, and the installer completed successfully.

    I had the same issue on my 2007 MacBook Pro, and solved it the same way. I do not have other computers on which to test this, but I expect this issue would affect Windows Users also.

    I see several forum posts of users having issues installing GRUB. If anyone else is having this trouble, see if the above fixes the issue. Ask below if you have trouble figuring out what I mean.

    If you need exact steps, and/or aren't so familiar with command line Linux, you may want to include the output of the following commands:
    Code:
    mount
    fdisk -l
    To start, fire up the Kali installer, and before you get to the partition screen, press ctrl+alt+F2 on your keyboard. Type the above commands, and send a screenshot of the output. Either I or someone else will try to help. You can then get back to the installer with ctrl+alt+F1 .

    I was able to fix the problem by just typing
    Code:
    umount /media
    and then finishing the installer.

  2. #2
    Join Date
    2019-Nov
    Posts
    161
    Hmm, I suspect I was rather tired when I wrote all of that.

    My point was, what my experience the same as what others were seeing, and if so, does the fix I found help?

  3. #3
    Join Date
    2016-Dec
    Location
    Canada
    Posts
    326
    I needed my partition to be of gpt. uefi wont boot otherwise

  4. #4
    Join Date
    2019-Nov
    Posts
    161
    Yes, same with my Mac. The Kali installer appears to have a bug that prevents the boot loader from installing on systems that have an existing GPT partition layout prior to running the Kali Installer. In theory, the installer should work fine if you put in a new hard drive, or zero-fill an existing one.

    Regardless, if done right, you will still end up with a GPT hard drive.

    The instructions I read all say to set it up as a Windows/MBR type, and then create a Hybrid MBR/GPT table. This might have been necessary with older Kali releases, but not now that Kali has native support for UEFI/GPT drives, this is no longer needed.

Similar Threads

  1. Bootable USB drive on UEFI machines?
    By Arvandor in forum Installing Archive
    Replies: 5
    Last Post: 2018-08-22, 11:59
  2. Issue with partitions and GRUB
    By Niv3k in forum Installing Archive
    Replies: 1
    Last Post: 2015-08-29, 08:17
  3. kali installer not seeing GPT partitions
    By redhern in forum Installing Archive
    Replies: 0
    Last Post: 2015-01-02, 06:57

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •