Results 1 to 2 of 2

Thread: Wireless adapter rtl8812au doesnt show any interface

  1. #1
    Join Date
    2019-Nov
    Posts
    4

    Wireless adapter rtl8812au doesnt show any interface

    Hi

    I have my realtek rtl8812au 2.4 & 5 ghz usb wireless adapter
    (based on Realtek RTL8812AU) and i have installed drivers pack realtek-rtl88xxau-dkms. After that i rebooted kali linux and made a usb filter in virutalbox for it. When i started kali linux and typed ifconfig and iwconfig there was no wireless adapter interface and no wlan0. I tried apt-get update && apt-get upgrade then reboot but it still doesnt work. i also tried with compact wireles and it still doesnt work. I can seem to make it work and really need help on this.

    when i type lsusb the output is this :

    Bus 001 Device 003: ID 0bda:b812 Realtek Semiconductor Corp. 802.11ac NIC
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub





    Thank you in advace.

  2. #2
    Join Date
    2019-Nov
    Posts
    167
    There are several threads about this already. This is why nobody has responded. It appears to be a known issue. There is no easy fix, although there are fixes available. (They aren't so easy).

Similar Threads

  1. Replies: 2
    Last Post: 2017-08-14, 14:08
  2. Broadcom 802.11ac Wireless Adapter doesnt work
    By RayDurlok in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2016-12-01, 21:29
  3. No wireless card interface while plugging in USB wireless adapter
    By xyq96999 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-09-15, 05:31

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •