Results 1 to 6 of 6

Thread: Windows 10 kali install

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Windows 10 kali install

    I just recently got kali installed natively on my windows 10 device. Installation went smoothly, dipos are what they should be, and file path has been added to the firewall as an exclusion. My problem is that I download programs fine, but they do not run. I got wireshark to work by the following command.

    sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/

    it will also only work in xrdp. Wireshark that is. I have looked everywhere to try and find a solution to this problem. Any help would be appreciated. Thanks!

  2. #2
    Join Date
    I've got troubles after last windows update. It worked ok but after this - programs do not run, just like it is wroten above.
    I upgrade tis message because I still need help with this trouble.
    Please If anyone had such problems - help us.
    Thank you.

  3. #3
    Join Date
    wow. i thought that i must use only Linux

  4. #4
    Join Date
    I have been using Oracle VM on my Windows 8.1 for a long time, and was very satisfied.
    When I upgraded to Windows 10, I tried Windows 10's WSL2 to run Linux distributions such as Ubuntu, Kali etc, but found Oracle VM was much better.
    I then installed Oracle VM on my Windows 10 machine, and it works great.

    Downloaded and installed following two packages:

    (1) Oracle VM VirtualBox Base Packages
    (2) Oracle VM VirtualBox Extension Pack

    In Settings >> Network, change default "NAT" to "Bridge Adapter"


  5. #5
    Join Date
    I am having the same issue. Anyone know what is going on?

  6. #6
    Join Date
    Shortcomings of Kali installed on Windows10 through WSL2

    abcd-wsl@DESKTOP-1:~$ uname -a
    Linux DESKTOP-1 4.19.128-microsoft-standard #1 SMP Tue Jun 23 12:58:10 UTC 2020 x86_64 GNU/Linux
    abcd-wsl@DESKTOP-1:~$ cat /etc/os-release
    PRETTY_NAME="Kali GNU/Linux Rolling"
    NAME="Kali GNU/Linux"

    Shortcoming (1):
    USB device plugged into computer is NOT passed-through to Kali.

    $ dump1090-fa 
    Sun Sep 27 19:45:25 2020 EDT dump1090-fa 3.8.1 starting up. rtlsdr: no supported devices found.

    Shortcoming (2):
    Sytemd / service / init.d missing

    $ sudo systemctl status dump1090-fa
    System has not been booted with systemd as init system (PID 1). Can't operate.Failed to connect to bus: Host is down
    $ sudo service dump1090-fa status
    dump1090-fa: unrecognized service
    $ sudo /etc/init.d/dump1090-fa status
    sudo: /etc/init.d/dump1090-fa: command not found
    Installed systemd by following script


    Shortcoming (3):
    Both VM and WSL2 cannot coexist on same machine.

    Type in the Windows Search bar Windows Features and following window will open. Check / Uncheck features as shown to switch between WSL2 and Oracle VM

    • Containers
    • HyperV
    • Virtual Machine Platform
    • Windows Hypervisor Platform

Similar Threads

  1. Is it possible to install Kali 2.0 on a windows phone?
    By Yokai in forum Installing Archive
    Replies: 0
    Last Post: 2015-08-27, 15:53
  2. Replies: 2
    Last Post: 2014-01-27, 21:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts