This isn't about installing a tool that is just part of the details.
HP 6300 pro sff
Intel i7 3700
32 GB Corsair Vengeance Ram
Kali is installed on my SSD
SSD Seagete Barracuda 500 GB
Hybrid SSD/HDD Seagate Firecuda Gaming 2 TB
Seagate HDD 1 TB
Kali 2019.03
Intel Opencl most current
AMD GPU most current

I am trying to use my AMD with Kali Linux I have followed just about every tutI don't know if they have a version of Pyrit for Windows 10. Tried Cygwin I think it was called but that's another nightmare for another day. Kali subsystem for Windows I think that discription says enough. I don't like Ubuntu but if I have to use it I would but it I can't get t to work on there either so it's a moot point, and Windows I hate, since I can't really get it to work with anything I went back to Kali. Here is where I stand Rocm wont work no matter what I try it keeps holding packages back and saying what I'm trying to do might be impossible. I also noticed on here someone saying about the Polaris 21 being the issue. Fglrx is causing crashes if Rocm is partially installed. I'm noticing with every kernel there seems to be new instructions and on Kali Forums in one post a guy mentioned that and the reply he got was yeah, but we like that because the challenge is fun. I'm not that advanced of a user I will admit it is fun struggling for a while and researching everything but I am at the end of my capability's this is a problem for the ninja's that know what they are doing 110% at the rate I'm going me and my computer will reach end of life before I get these drivers installed. I did found a couple times here and once on the JTR site to install AMD SDK and followed the link to the developer site, the SDK doesn't exist anymore I did find a copy on Github. Sorry back to the point from what I understand I have to install the driver then the SDK I can't install the driver I have tried everything including editing the driver to get it to install and it wont. I have spoke with AMD and MSI they said it doesn't work for Linux. It does though it works for Ubuntu, but they said they don't have any Linux drivers, so I don't know on that one. I have read where people have them running on Kali but the posts are old and most instruct to install AMD driver then the SDK no hint as to how I should install the driver. The last thing I can think to mention is that on the Hashcat Wiki it has instructions neither work if I remember correctly the Kali install calls for Rocm that doesn't work for me. The Windows install calls for Crimson drivers I would rather stick needles in my eyes than try that again. The only thing I didn't mention if I lspci or lspi -v it shows the card, I don't know if that means anything, since nothing will use it I'm guessing it doesn't. The closest I have gotten is where it says Mint,Ubuntu in the AMD driver file I put in Kali after them and it started to install then failed due to packages. I hope one of you will decide to have some fun as the guy put it and help me out here, I would like to get it to work in Kali at least with JTR, would love for it to work on Pyrit but that seems like a dream to far, aside from the driver issue the tutorials say to remove Pyrit and reinstall. Part of Pyrit is in Wifite and I can't get it all, also it says to edit the script if I try on command line the files are blank if I try through text editor I can't say what happens other than if I try again from command line it's blank again bac to text editor it's there and so on, but that's a tool problem I was just using it as an example I mention the tools also because they have instructions also and don't help with installing the driver. As I have mentioned I would really like to get this to work on Kali I don't mind sweating blood to do it if someone could please lend a hand. I know about Kali but I also know there's also someone out there that knows more. Thank you and have a nice day.