Results 1 to 2 of 2

Thread: many tools are not working properly

  1. #1
    Join Date

    many tools are not working properly

    Hello. I have installed kali on my laptop. Im learning a lot about networking and kali helps a lot on this thanks to the tools provided.
    But Im finding many tools not working as expected, and Im not that skilled to know why, but definitly things are not working as I can see in the documentation or in the tutorials I found about Kali.
    For example: ettercap, if I run the scan for host, it never finds the computers on my LAN. And Im sure they are there because I can ping them from a console. If I run the MITM atack, the arp spoofing seems to be on place, but the targets loose internet conection, the packet forwarding is not working. I know that because if I manually do it usieng arspoof, I can do a MITM and it works. So basically any of the tools or plugins of ettercap seem to work. I have tried enabling the packet forwarding manually, with no success either, even knowing that acording to the docuemtnation, ettercap uses its own internat packet forwarding and this should not be necesary.

    Another tool failing: I can use the arpspoof tool and it works, but then if I want to execute the dsniff tool in another console, I can launch it, but no user/passwd is intercepted (I do the test using my pwn machines in my private lan), sslstrip is also now working. Both tools just stay there, listening, but no results are reported (packet forwarding is activated, I do it manually)

    These are the examples. Is there in KALI that need to be activated for these tools to work? I have the latest kali version (downloaded 5 days ago) and then I updated many packages using the software tool of kali.

    Any recomendations?
    Thanks in advance

  2. #2
    Join Date
    I don't know why people don't answer questions like this, it's frustrating to go through it. A lot of the tools in Kali don't work very well anymore it's not you, your computer, the tool. They are obsolete that's it nothing more or less. Your using scripts, the reason they are public is because of that a tool that would work like your expecting these to isn't going to be anywhere you'll ever hear about it, if it was it would get patched. You have two choices use these tools and get minimal results or learn to write your own scripts. Most of the tools for MITM do nothing because of the way traffic works now.
    If you put some work into it and a lot of time you can learn how to reroute some traffic and be able to do something with it. Mitmap sort of kind of works about 1% of the time sslstrip is basically dead and drifnet or whaterev it's called will give you a picture or so every once in a while.
    I hope your changing your mac and using a proxy or something doing what your doing you don't want to get caught playing around. If your in America the Mitm is kind of in a grey area, if you offer ferr wifi and I'm dumb enough to use it then you looking at my traffic isn't illegal it's what you do with it. The law basically says as long as you do no harm and do not behave maliciously it's not a crime, it's just data gathering you inferred permission since you signed onto the wifi. So your clear there, but if you start going into private accounts and using their passwords your in trouble. There's more to it than that which is why you still need to be careful there's ablurred line between looking and malicious you don't want to be on the wrong side of that.

Similar Threads

  1. Terminal not working properly.
    By Pankaj_m in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-07-18, 02:59
  2. mitmf is not working properly
    By aoiko in forum NetHunter General Questions
    Replies: 0
    Last Post: 2018-03-26, 19:55
  3. Apt-get is not working properly
    By Shaun Morgan in forum General Archive
    Replies: 1
    Last Post: 2014-07-19, 02:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts