Results 1 to 2 of 2

Thread: Pi Zero Fails to Raise Network Interfaces

  1. #1

    Pi Zero Fails to Raise Network Interfaces

    I recently installed Kali Linux on my Raspberry Pi Zero W and following this guideconnected it to my local WiFi network. I was able to connect just fine on the first try as well as the second try and I could update all of my packages using apt-get as well as try to download a file with wget.
    Then after shutting down the Pi for a couple of days, I got back to it and tried to change the WiFi network to another in my house, but after trying to connect it wouldn't and I realized that I was actually connecting to a 5Ghz WiFi network, one which the Pi Zero W doesn't support.
    I then changed my configuration settings back to the old WiFi SSID and password and rebooted, but my Pi wouldn't connect back to the network. I re-tried multiple times to no avail. I continued to get the following output and subsequent errors every time I boot up the Pi:

    [OK] Starting Network Manager
    Starting Hostname Service
    [OK] Started WPA Supplicant
    [OK] Started Authorization Manager
    [OK] Started Modem Manager
    Starting Raise Network Interfaces...
    [OK] Started Hostname Service
    brcmfmac: power management disabled
    [FAILED] Failed to start Raise Network Interfaces
    See "status networking.service" for more details.
    [OK] Reached Target Network
    Starting /etc/rc.local Compatibility
    Starting OpenBSD Secure Shell Server
    Starting Permit User Sessions
    I had never seen the [FAILED] Failed to start Raise Network Interfaces line until after I tried connecting to the different WiFi network.
    This is what I have set in my /etc/network/interfaces config file:

    iface lo inet loopback
    auto wlan0
    iface wlan0 inet dhcp
    wpa-ssid homewifinetwork1
    wpa-psk Password1
    I searched the internet for quite some time and tried multiple solutions, none of them working. So I have turned to asking my own question, hoping it will help me figure it out.

  2. #2
    I found the following answer on here (in the comments) and on the Raspberry Pi Forums here, but I am sharing it to be of use to anyone who might stumble upon my question above.
    First, run the command sudo rfkill list all and you should get something like this:

    0: phy0: Wireless Lan
    Soft Blocked: no
    Hard Blocked: no
    Then, run the command sudo rfkill unblock all and reboot using shutdown -r now. I am told this won't work if you have a WiFi network that uses WEP security.
    Then open /etc/rc.local in a text editor and add the following two lines before exit 0 at the bottom:

    sleep 10
    sudo iwconfig wlan0 power off
    Save the file and reboot by typing shutdown -r now and when your Pi comes back up, it should be reconnected to the WiFi network.

Similar Threads

  1. /etc/network/interfaces keeps resetting on reboot
    By lastusername in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2017-11-02, 21:21
  2. Failed to start Raise network interfaces
    By Bluuuux in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2016-12-19, 01:45
  3. Setting a static IP in /etc/network/interfaces
    By gCoreByte in forum General Archive
    Replies: 1
    Last Post: 2013-12-04, 14:08
  4. Bridging network interfaces
    By acib708 in forum General Archive
    Replies: 0
    Last Post: 2013-08-23, 03:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts