Results 1 to 5 of 5

Thread: ettercap not working (aleady looked for the problem no solution found)

  1. #1
    Join Date

    ettercap not working (aleady looked for the problem no solution found)

    Hi. I have installed kali recently, for me is a great tool to learn how networks works, thanks!
    But Im finding some problems using some tools. First one is ettercap:
    The tolls loads with no problems, I set it up following many tutorials. But when I try to do an arp poisonig and do a MITM atack to my laptop inside my lan, my laptop looses the hability to browse the internet, actually looses all conectivity. The set up is: desktop computer with kali, laptop computer and the internet router.
    Posoning seems to be ok but for some reason the laptop as I said looses conectivity, looks like no packet forwarding is being done. Another interesting thing is that the scan for hosts tool also doesnt work, it makes a scan and cant find the laptop or the router. Also all the plugins can be started but I have not been able see any results.
    I have already tried many "solutions" I found online, none of them gave me results.
    I unistalled the default ettercap instalation and did a full compilation from the latest ettercat version, it is also not working as expected.
    Can anyone give me a hint on what can be wrong? I cant see any error messages in the console or in the logs.

    another tool not working as expected for me: since attercap is not working ok, I did an arp poisoning using the arpspoof tool. This time the posisoning is working, because the laptop does not looses conectivity. I can sniff all it trafic using wireshark for example.
    But if I launch the dsniff tool, no user/passwd is captured. Also the sslstrip tool seems not be working

    Can anyone give me a hint on what can be wrong? I cant see any error messages in the console or in the logs.

    Thanks in advance

  2. #2
    Join Date
    I think something is wrong with it. It seems to work when it wants to a very limited extent. Do bang your heat against the wall look for another tool that does what you want. Dont use wifi pumpkin though unless what you want is to reinstall kali linux two installs and both times it destroyed my wifi. If you need to use a script and it for evil twin try Airgeddon for mitm theres a bunch of good ones mitmap is ok to get started it automates everything. SSLSTRIP really doesnt work so well anymore https and vpns kill that. If I'm guessing right from what you wrote it is working the bad news is this isnt a movie it's not going to work like you want it to.
    Take passwords Google search a password calculator fill in the info, at 8 or 10 charcters that's a long time with a very expensive rig and you still might not get it the word has to be in your wordlist or your out of luck. If you have access to the network try wireshark sign on and start recording set your filter for post info if theres a password that's not in encrypted traffic and that's a long shot you'll see it.
    I hate to say it but your probably going to spend a long time getting nothing even if you do everything right. Check out the book Learn Social Engineering that will get you started, the results come a bit faster.

  3. #3
    Join Date
    Thanks you for answer Robert. My intention is to learn about nwetworking from a deep point of view. I dont want to steal people's passwords. The tools provided by kali lets me see the insighs of networking in a way I can do it just reading a book. My post about teercap was because I tried to use it and It wasnt working, so I was thinking if I was doing something wrong. Then acording to your answer, definitly ettercap is the problem and not me. I have succesfully done a MITM atack using other tools, I just wanted to know what is wrong with ettercap. To resume: it is **** jajajaja

  4. #4
    thanks for your answer , Robert.

  5. #5
    Last edited by nu11secur1ty; 2020-01-08 at 09:30.

Similar Threads

  1. Replies: 0
    Last Post: 2016-05-11, 00:49
  2. Replies: 0
    Last Post: 2015-07-25, 08:28
  3. Replies: 26
    Last Post: 2015-05-10, 12:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts