Results 1 to 7 of 7

Thread: Using a different machine/VNC client to connect to Kex

  1. #1
    Join Date
    2019-Nov
    Posts
    4

    Using a different machine/VNC client to connect to Kex

    Is there a way to connect to Kex through vnc?

    I've got Nethunter running on my Nexus 6p and it runs fine. I can access Kex through the local Kex Client just fine, but whenever I try to connect using a different device on the same network, i'll get a connection refused error.
    The phone is pingable, so the connection is fine..
    Kex server has "local host only" turned off.

    Is there a way Kex is setup that prevents normal VNC clients from connecting? Are ports blocked? Am I just doing something completely wrong? Is this even possible?



    Oh, and a work around I did find was connecting the phone through USB to my PC, and using "adb forward tcp:5901 tcp:5901". After that you can connect using any vnc client to localhost.

  2. #2
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    274
    There certainly is and you did everything right but you've found a bug where the "localhost" flag is not evaluated properly. Thanks heaps for letting us know, we'll fix it straight away.
    Kudos for your "adb forward..." - that's a great piece of hacker ingenuity.

    You can allow connections from other hosts by editing "/etc/vnc.conf" and adding the following line:

    $localhost = "no";

    We'll let you know when the "localhost" checkbox is fixed so you can remove that line again.

    Many thanks

  3. #3
    Join Date
    2019-Nov
    Posts
    4
    Quote Originally Posted by re4son View Post
    You can allow connections from other hosts by editing "/etc/vnc.conf" and adding the following line:

    $localhost = "no";

    We'll let you know when the "localhost" checkbox is fixed so you can remove that line again.

    Many thanks

    Thanks for the heads up! adding the line in the /etc/vnc.conf fixed it

  4. #4
    Join Date
    2019-Nov
    Posts
    4
    Quote Originally Posted by re4son View Post

    You can allow connections from other hosts by editing "/etc/vnc.conf" and adding the following line:

    $localhost = "no";

    We'll let you know when the "localhost" checkbox is fixed so you can remove that line again.

    Many thanks
    This worked perfectly. Thank you!

  5. #5
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    274
    Fixed.
    The new version of the nethunter-app is in the staging repository for testing.
    You can add the repository in your store client:

    Just go to "Settings" -> "Repositories" and click the "+" in the top right hand corner.
    Add the repository address "https://staging.nethunter.com"
    Go back to "Updates" and pull down from the top of the screen to refresh. You should now being offered the update. Just install it and the "localhost" checkbox should work now.

    Please let us know how you go.

  6. #6
    Join Date
    2019-Nov
    Posts
    4
    The updated version works perfectly. The Localhost toggle does what it's intended as far as I can tell. Having the toggle on restricts me to local connections, and toggeling it off allows external connections.

    The only thing I noticed when the toggle Localhost is off, when starting the server it still gives a -localhost flag. Might just be a visual thing?

  7. #7
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    274
    Glad it's working, thanks for letting us know.
    We are now setting "-localhost yes" or "-localhost no" explicitly so you should see it every time.

Similar Threads

  1. Replies: 0
    Last Post: 2018-09-10, 14:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •