Results 1 to 7 of 7

Thread: Not able to use gparted as root

  1. #1
    Join Date
    2019-Nov
    Posts
    2

    Not able to use gparted as root

    Hi, I tired to use gparted to modify my Kali 2019-4 USB-drive.
    I can only see limited information about the USB. Using fdisk -l everything looks good.
    I also tried to inspect another USB drive (not the one I was booting from), but same result.

    As I am coming from windows, I prefer GUIs to determine the correct harddrive. Can this also be explaind using gparted? For me it is very intuitive and similar to the windows manager.
    I tried this way, but I have an issue with garted, as it doesn't show the drives >> screenshot 3. This is the first time I encounter this behaviour of gparted. Usually I am able to see the details of all drives. Any hint how to get full access?

    Kazam_screenshot_00003.jpgKazam_screenshot_00001.jpg
    Thanks!

  2. #2
    Join Date
    2018-Jun
    Posts
    18
    What is the host OS that you are using? It seems like it is an installed version of Kali?

  3. #3
    Join Date
    2019-Nov
    Posts
    2
    Quote Originally Posted by Gamb1t View Post
    What is the host OS that you are using? It seems like it is an installed version of Kali?
    Not sure what you mean with host OS
    I use Firefox 70.0.1 (64-Bit) on Win 10 1903 to download the Kali-2019-4 ISO. balenaEtcher-Portable-1.5.64.exe wrote the iso to my USB-drive. I boot Kali directly from USB. Therefore, there is not really a host from my understanding. There is currently no installed Kali on my PC.
    Does this info help?

  4. #4
    Join Date
    2018-Jun
    Posts
    18
    There are a couple things to keep in mind with setting up persistence. The first is that the documentation assumes that you are on a Linux system, the other is that you are unable to set up persistence if you are booted into live boot. Instead of overwriting a machine to install Kali, you could try installing a virtual machine and setting it up from there.

  5. #5
    Join Date
    2019-Dec
    Posts
    7
    Hi Gamb1t,
    sorry, it took me a while to re-login... had to wait 15 mins to be able to retry and even copy paste of pw didn't work. Anyways, that is solved, let's go back to the documentation, which users, especially newbies should follow.
    It states:
    "This guide assumes that you have already created a Kali Linux “Live” USB drive as described in the doc page for that subject. For the purposes of this article, we’ll assume you’re working on a Linux-based system.

    <<screenshot bootmenu starting persistence >>


    You’ll need to have root privileges to do this procedure, or the ability to escalate your privileges with the command sudo su. In this example, we assume

    you are running as the root user
    your USB drive is /dev/sdb
    your USB drive has a capacity of at least 8GB — the Kali Linux image takes over 3GB, and for this guide, we’ll be creating a new partition of about 4GB to store our persistent data in."

    I did exactly follow these instructions. It is not mentioned that a host OS is used. The assumtions lack of the host setup. I suggest to add: "You will need to start an host linux (e.g. installed linux or another live linux from USB-drive). On the host you will need to be root. If you run your installed linux, your USB drive is most likely /dev/sdb, if you booted from live, your kali will be most likely /dev/sdc."
    The picture should move to the top to show: it is about persistence or the end, where to boot with perstistence. The current position indicates how to start the kali to add persistence.

    The good news: I added persistence to my USB, but I am not sure if I did it the way it is intended in the docs.
    First of all: I followed your advise to boot a host OS. I used Kali 2019-1 as Host.
    I tried several times to re-create the USB using different imagers, always with the same result. balenaEtcher-Portable, win32imager and Universal-USB-Installer-1.9.8.9 all ended up with File System ISO9660 in gparted.
    fdisk -l
    Disk /dev/sdc: 28.84 GiB, 30943995904 bytes, 60437492 sectors
    Disk model: DataTraveler 3.0
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0xb5ffc0fc

    Device Boot Start End Sectors Size Id Type
    /dev/sdc1 * 64 5396159 5396096 2.6G 17 Hidden HPFS/NTFS
    /dev/sdc2 5396160 5397631 1472 736K 1 FAT12

    I tried to expand sdc1, but got the error message: not possible! Which is true, as there is this tiny 736k partiton at the end. This only leaved the option of one 26GB persistence partition.

    Then I noted that on my Kali2019-1 the file system was fat32. Here I was able to see each partition.
    Testing the 2019-1 iso on the new USB I also ended up with ISO9660.
    My Question (1) here: Does the Kali Image come with a pre-definded data format? If yes: which is it?
    If not: How did I manage to end up with ISO9660 as file system? Fact: I deleted all partitions from the USB-drive prior to imaging it on windows. Therefore I had only unallocated diskspace on my USB-drive. Is this the solution to the riddle?
    Universal-USB-Installer offerd to format the flash with FAT32 or NTFS prior imaging.
    Question (2) Which is the recommenced file-system?
    I formated the USB FAT 32 and was able to use gparted to expand my /dev/sdc1 to 18GB and created a /dev/sdc2 with ext4, confirmed and everthing was fine. Afterwards I started Kali and set up persistence as in the docs. Which worked fine

    I suggest to add additional into to section https://www.kali.org/docs/usb/kali-l...e-usb-install/ regarding the file system. Just to make sure everybody starts with at the same point.

    Hope I didn't mix up too much with the topics.


    Cheers,
    Mark

  6. #6
    Join Date
    2018-Jun
    Posts
    18
    Nice to hear you got it working. For your first question, gparted will read the imaged iso as that no matter what. It sees one large block that is the imaged Kali iso and that is all, the commands in step 2 shrink that large block down so that you can create a new partition. The way you went about it seems interesting, I will have to try that out. On question 2, there is no recommended file-system until you get to the 3rd step, which it is then ext3.

    Thanks for the ideas recommendations!

  7. #7
    Join Date
    2019-Dec
    Posts
    7
    Gamb1t, if you are a real man, you would have never gone the way I took... why? Because: Real man don't click*

    * in the early 2000s there was a website with this name, providing tricks how to avoid the mouse in Windows. Seems it is gone... I learned a lot of shortcuts that time *sigh* ;-)

Similar Threads

  1. Gparted can't detect other partitions
    By johhnry in forum Installing Archive
    Replies: 2
    Last Post: 2018-11-19, 21:10
  2. GParted Errors on RPi3
    By DesertShadow in forum ARM Archive
    Replies: 3
    Last Post: 2018-02-04, 16:27
  3. Problem creating partition, GParted - Mac OSX
    By zavaruz in forum Installing Archive
    Replies: 1
    Last Post: 2015-09-20, 22:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •