Results 1 to 5 of 5

Thread: USB Wireless Adapter not showing in iwconfig

  1. #1
    Join Date

    USB Wireless Adapter not showing in iwconfig

    Hey all,

    I'm brand new to using Kali. I bought a Linsys AC1200 USB wireless adapter. I have installed the rtl8812au drivers. But for some reason it WILL NOT show up in iwconfig. It shows up on the devices list when i use 'lsusb' command.

    Thanks in advance for your help!

  2. #2
    Join Date
    iw dev see if its there.
    apt install linux-headers-$(uname -r)
    If the second thing doesn't fix it try
    apt install --reinstall linux-headers-$(unname -r) build-essential git
    Go here
    Open a terminal type cd Downloads then on the git page click on download or clone it does a drop down theres going to be an address in the drop down click the little pic of a clipboard to the right of the address.
    Back to your terminal
    git clone paste the address hit enter.
    Go to file explorer on your desktop go to downloads theres going to be a download with a god awful long name, right click it and name it something small 1 or a charcter small make life easy.
    Back to the downloads terminal you used to clone the driver. If you closed it open another terminal
    type cd Downloads/whatever you named it. The directory is always capitalized Downloads, Documents whatever. The file you cd into is always the files name exactly. That's the reason for the name change.
    If you left it open just type.
    cd whatever you named it.
    make install
    If the adaptor ever disappears just do that again.
    If you get a build essentials error type
    apt install build-essential
    Alternatively you can just type
    get clone the link I pasted and hit enter that should work. You said you where new so I just explained the whole process.
    I did Google your dongel theres a place or two that says incompatable so you might have a problem there.
    Panda and Alfa both already have the drivers in Kali they are cheaper too jn some cases and a lot easier. After seeing what you have probably a lot better.
    If you didnt know about changing the file name you can do that with any file to save your sanity. I cant stand typing all that. It's stupid if you dont need to.
    Is this a laptop?
    If it is a laptop the wifi in it might do the job. If it is Intel that should work mine does. It will go into monitor, inject whatever.
    Open a terminal type
    iw reg set BZ
    Iw reg get
    iw dev see what your adapters name or names are.
    Let's say wlan0
    ip link set wlan0 down
    iw wlan0 set txpower fixed 30mBm press enter
    iw wlan0 set monitor control # if monitor mode needed press enter
    ip link set wlan0 up press enter.
    iw dev press enter.
    If your adapter is capable of 30 it will be set. My laptops built in maxs at 22 but my Panda and Alfa go to 30. You'll have to do that each time you restart your computer except for the built in.
    Theres a way to make it permanent but it's a pain you have to clone and edit.
    Just make a text file and type in the commands with && between each leave out iwdev so it would look like iw set && iw
    get BZ && so on. Once your done save it then whenever you want to change your TX open the file copy the string and paste it into a terminal press enter done.

  3. #3
    Join Date

    no wireless adapter showing

    So I'm pretty to new to Linux in general and I'm running Kali in VirtualBox via WIndows 10 Pro. My intention is to try airmon-ng and see if my adapter is compatible (Realtek RTL8822BE 802.11ac PCIe Adapter). No matter what I do Kali is not seeing a wireless adapter. I've tried the above to no avail. Here's a screenshot of my terminal:


    Thanks in advance...

  4. #4
    Join Date

    Unhappy Having same issue

    I am having the same issue I have tried 2 different usb adapters and tried virtual box on both mac and windows. I am running the latest version of Kali Linux, my sub adapter worked on the previous versions of kali. If you find a solution would love to know

  5. #5
    Join Date
    Hello, i have the same issue, did we have a solution?


Similar Threads

  1. Wireless adapter not showing up in terminal
    By berap in forum TroubleShooting Archive
    Replies: 5
    Last Post: 2016-07-25, 11:11
  2. Replies: 8
    Last Post: 2013-08-09, 03:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts