Hi friends,

I have the following set up:
kali linux (2019.4 x64) running on VirtualBox MacBook pro. It runs just fine except for the wifi adapter not being detected in ifconfig nor iwconfig.
I have followed the guide on here to install the drivers for my alfa AWUS036ACH wifi adapter:
Code:
https://github.com/aircrack-ng/rtl8812au
everything runs ok.


Here's the details of lsusb:
Code:
Bus 002 Device 002: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac 2T2R DB WLAN Adapter
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
running iwconfig:
Code:
root@kali:~# iwconfig
lo        no wireless extensions.


eth0      no wireless extensions.
running dmesg:
Code:
[    1.973937] usb 2-1: new SuperSpeed Gen 1 USB device number 2 using xhci_hcd
[    1.995369] usb 2-1: Int endpoint with wBytesPerInterval of 512 in config 1 interface 0 altsetting 0 ep 133: setting to 64
[    1.996075] usb 2-1: New USB device found, idVendor=0bda, idProduct=8812, bcdDevice= 0.00
[    1.996076] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.996077] usb 2-1: Product: 802.11n NIC
[    1.996078] usb 2-1: Manufacturer: Realtek
[    1.996079] usb 2-1: SerialNumber: 123456
running dams status:
Code:
root@kali:~# dkms status
realtek-rtl88xxau, 5.2.20.2~20190617, 5.3.0-kali2-amd64, x86_64: installed
virtualbox-guest, 6.0.14, 5.3.0-kali2-amd64, x86_64: installed

what could be the problem here? can anyone help?