Results 1 to 6 of 6

Thread: TL-WN7200ND "device not ready" error in Kali Linux 2019.4

  1. #1
    Join Date

    Unhappy TL-WN7200ND "device not ready" error in Kali Linux 2019.4

    Hello, I've been recently experiencing an issue with the latest version of Kali Linux (2019.4 / 64-bit) regarding a specific Wi-Fi adapter, the TP-Link TL-WN7200ND.

    Whenever I connect this device to my PC, it's shown as "device not ready" in the network applet. After a clean install, "iwconfig" shows it as wlan0, which is normal. Once I put it in monitor mode,its name changes to wlan0mon, which again, is pretty much normal.

    However, monitor mode doesn't work with this adapter, it detects no APs, no clients, zilch, zero, nothing. After I switch it back to managed mode, its name looks like gibberish, something like wl9xicn2y28. The thing is that any other adapter I connect to the PC has a similar name instead of wlan0 or wlan1.

    I can confirm that the TL-WN7200ND device is supported, or at least was, since I've been using it on another device (a laptop) running Kali Linux 2019.3 64-bit. It still works on the laptop without an issue, so it's not about the adapter being faulty, or the cable, or the USB ports (since the other adapter works just fine on the PC).

    I've tried doing everything from other threads, tried installing the headers and firmware files (which are already the latest version, so no dice), tried blacklisting the rt2800usb like some users suggested, but again, to no avail.

    I would also like to mention that using TL-WN7200ND on the laptop can be done by merely plugging it in, no additional step needs to be taken. Please help me sort this situation out, or let me know if there's nothing else I can do, so I can just let it go.

    tl;dr - TL-WN7200ND is not properly detected by desktop PC (device not ready), but works absolutely fine on my laptop. Also, other Wi-Fi adapters work fine on the desktop PC. Please help me fix it.

  2. #2
    Join Date
    When there is an issue like this, the first thing to do is to check in dmesg for errors. Installing headers, firmware will not solve it. If a firmware is missing, it is unlikely you would be able to put the card in monitor mode (with some cards, the interface won't even show up). Blacklisting the module is pointless, unless installing another driver.

    Let's start from the begining, what chipset and driver is that? Run airmon-ng and paste the output. Then, is there any error in dmesg when putting it in monitor mode or starting packet capture?

  3. #3
    Join Date
    Thank you for taking the time to reply.

    Airmon-ng's output:

    ~# airmon-ng

    PHY Interface Driver Chipset

    phy0 wlx90f652cab57d rt2800usb Ralink Technology, Corp. RT2870/RT3070
    Here's where things are getting weird. Before plugging in the TL-WN7200ND everything was normal. Here's the dmesg output after I've plugged the device in for the first time.

    [ 71.613006] usbcore: registered new interface driver rt2800usb
    [ 71.629712] rt2800usb 2-8:1.0 wlx90f652cab57d: renamed from wlan0
    [ 71.671952] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt2870.bin'
    [ 71.688814] rt2800usb 2-8:1.0: firmware: direct-loading firmware rt2870.bin
    [ 71.688818] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.36
    [ 71.987357] ieee80211 phy0: rt2x00usb_vendor_request: Error - Vendor Request 0x06 failed for offset 0x0404 with error -71
    [ 73.209776] ieee80211 phy0: rt2800_wait_csr_ready: Error - Unstable hardware
    [ 73.209783] ieee80211 phy0: rt2800usb_set_device_state: Error - Device failed to enter state 4 (-5)
    I've put it into monitor mode, it got renamed to wlan0mon, nothing unusual there.

    dmesg output after enabling monitor mode: [ 425.707865] device wlan0mon entered promiscuous mode

    Now it doesn't even pick up any target, let alone perform additional, more complex action

  4. #4
    Join Date
    I'm getting exactly the same errors that you are gettings. Have you found a fix for this? I'm using the Alfa AWUS036NH.

  5. #5
    Join Date
    Have you found a fix to this? I am getting exactly the same errors that you're getting.

  6. #6
    Join Date
    Absolutely none. My guess is that the new kernel doesn't support that device any longer.

    I've upgraded to an Alfa AWUS036NHA in the meantime and I'm not experiencing any similar issues with this device. Yet.

Similar Threads

  1. "Boot-Device Not Found" after Installing Kali Linux.
    By KALIX2 in forum Installing Archive
    Replies: 1
    Last Post: 2022-04-14, 02:30
  2. Replies: 0
    Last Post: 2019-12-26, 17:07
  3. Replies: 0
    Last Post: 2016-01-28, 16:48

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts