Macbook Pro late 2018, Mac OS Catalina
Kali Live USB with encrypted persistence. ( 3 partitions: 1 dd image of ISO-file, 2 luks encrypted persistence, 3 Regular Storage fat32)
Kernal 5.3 -Newest/updated version of kali

My Macbook Pro keyboard/trackpad is responding and working perfectly all the time except when I get prompted for the luks encryption key to open unlock the persistence.



I have made a Kali Live USB flashdrive with luks encrypted persistence. The first time i booted it I had the regular issue of not having any mouse/keyboard on the macbook pro. I then connected a physical USB mouse and keyboard to navigate and complete the setup until I fixed the keyboard/mouse issue by following these instructions https://gist.github.com/roadrunner2/...errides-quirks and after some time I got the keyboard and trackpad on the mac to work again, solving the problem I thought. I then restarted the mac and booted it up from the USB. When I got to the startup mode selection menu I could use the mac internal keyboard and was very pleased the keyboard now worked. But after choosing the Live, encrypted persistance option I got prompted with the persistance login window where I tried entering the password, but now the internal keyboard didnt work anymore. I then had to plug in the external USB keyboard again to write the password and that worked. Well inside kali the mac trackpad and keyboard worked again. I have restarted several times with the same result.

Q: How do I get the persistence boot to load the keyboard modules before prompting me for the password?

It seems if the persistence boot is a separate booting process than the kali boot and that the modules I have fixed for the kali boot does not apply to the persistance boot. What do I need to do?

Im all new to kali and have just used google as my friend to get this far, so please explain in depth if you have a solution.