So, I got a Raspberry Pi recently and decided to put Kali on it. Installation went well, selected all English and American options during installation, everything's cool. Except I've discovered that my language, date, and time settings are all whack. I was able to fix my language problems, but my date and time both reset after every single restart. For some reason, it resets to 'Fri 29 Nov 2019 10:33:00 AM CST' every time I restart the device. I've tried many different things I found online with the 'date' command and the 'timedatectl' command, but neither seem to make permanent changes. I suspect it has something to do with my Hardware Clock, but I have no access to it. I've tried using 'hwclock' commands with sudo, but I get the same error (in the title) every time, no matter what I try.

After trying
sudo hwclock --verbose
I get an output of
hwclock from util-linux 2.34
System Time: 1575045809.932463
Trying to open: /dev/rtc0
Trying to open: /dev/rtc
Trying to open: /dev/misc/rtc
No usable clock interface found.
hwclock: Cannot access the Hardware Clock vis any known method.
Anyone know what I can do to fix this? I will warn you that I'm very new to Linux, especially Debian, but I like to think I catch on faster than most people. Thanks in advance.