Results 1 to 8 of 8

Thread: Cannot access the Hardware Clcok via any known method. - Raspberry Pi

  1. #1
    Join Date
    2018-Aug
    Posts
    1

    Cannot access the Hardware Clcok via any known method. - Raspberry Pi

    So, I got a Raspberry Pi recently and decided to put Kali on it. Installation went well, selected all English and American options during installation, everything's cool. Except I've discovered that my language, date, and time settings are all whack. I was able to fix my language problems, but my date and time both reset after every single restart. For some reason, it resets to 'Fri 29 Nov 2019 10:33:00 AM CST' every time I restart the device. I've tried many different things I found online with the 'date' command and the 'timedatectl' command, but neither seem to make permanent changes. I suspect it has something to do with my Hardware Clock, but I have no access to it. I've tried using 'hwclock' commands with sudo, but I get the same error (in the title) every time, no matter what I try.

    After trying
    Code:
    sudo hwclock --verbose
    I get an output of
    Code:
    hwclock from util-linux 2.34
    System Time: 1575045809.932463
    Trying to open: /dev/rtc0
    Trying to open: /dev/rtc
    Trying to open: /dev/misc/rtc
    No usable clock interface found.
    hwclock: Cannot access the Hardware Clock vis any known method.
    Anyone know what I can do to fix this? I will warn you that I'm very new to Linux, especially Debian, but I like to think I catch on faster than most people. Thanks in advance.

  2. #2
    Join Date
    2020-Jan
    Posts
    2
    Same problem here. Looking forward any solution

  3. #3
    Join Date
    2020-Feb
    Posts
    3
    I have just installed Kali on my Raspberry Pi and sort of having same problem but new zealand time now is 04.34 pm and kali clock says 03.34 am and the same
    sudo hwclock --verbose as you so I am looking forward to any solution as well.

    my Raspberry Pi is Pi B+

    Thank you

  4. #4
    Join Date
    2014-Feb
    Posts
    299
    The raspberrypi does not have a hardware clock, unless you purchase some sort of rtc/rtc hat for it. I would suggest installing the package "chrony" and enabling the service.

  5. #5
    Join Date
    2020-Feb
    Posts
    3
    Quote Originally Posted by steev View Post
    The raspberrypi does not have a hardware clock, unless you purchase some sort of rtc/rtc hat for it. I would suggest installing the package "chrony" and enabling the service.
    Hi ARM guy

    I tried this in ternamal and got this


    root@kali:~# apt install chrony
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package chrony

    is there Another way of doing it

    Thank you
    Ian

  6. #6
    Join Date
    2014-Feb
    Posts
    299
    Try need to run apt update first, so that it updates the repos to what are latest.

    Code:
    root@kali:~# apt updateHit:1 http://http.kali.org/kali kali-rolling InRelease
    Hit:2 http://http.re4son-kernel.com/re4son kali-pi InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
    root@kali:~# apt install chrony
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libopts25 sntp
    Use 'apt autoremove' to remove them.
    Suggested packages:
      networkd-dispatcher
    The following packages will be REMOVED:
      ntp
    The following NEW packages will be installed:
      chrony
    0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
    Need to get 229 kB of archives.
    After this operation, 1,604 kB disk space will be freed.
    Do you want to continue? [Y/n]

  7. #7
    Join Date
    2020-Feb
    Posts
    3
    Quote Originally Posted by steev View Post
    Try need to run apt update first, so that it updates the repos to what are latest.

    Code:
    root@kali:~# apt updateHit:1 http://http.kali.org/kali kali-rolling InRelease
    Hit:2 http://http.re4son-kernel.com/re4son kali-pi InRelease
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    All packages are up to date.
    root@kali:~# apt install chrony
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libopts25 sntp
    Use 'apt autoremove' to remove them.
    Suggested packages:
      networkd-dispatcher
    The following packages will be REMOVED:
      ntp
    The following NEW packages will be installed:
      chrony
    0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
    Need to get 229 kB of archives.
    After this operation, 1,604 kB disk space will be freed.
    Do you want to continue? [Y/n]
    Hi steev

    This is what I got after apt upgrade
    oot@kali:~# apt install chrony
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Suggested packages:
    networkd-dispatcher
    The following NEW packages will be installed:
    chrony
    0 upgraded, 1 newly installed, 0 to remove and 326 not upgraded.
    Need to get 218 kB of archives.
    After this operation, 406 kB of additional disk space will be used.
    Get:1 http://wlglam.fsmg.org.nz/kali kali-rolling/main armhf chrony armhf 3.5-5 [218 kB]
    Fetched 218 kB in 1s (265 kB/s)
    Selecting previously unselected package chrony.
    (Reading database ... 241575 files and directories currently installed.)
    Preparing to unpack .../chrony_3.5-5_armhf.deb ...
    Unpacking chrony (3.5-5) ...
    Setting up chrony (3.5-5) ...
    Creating '_chrony' system user/group for the chronyd daemon?


    Creating config file /etc/chrony/chrony.conf with new version


    Creating config file /etc/chrony/chrony.keys with new version
    update-rc.d: We have no instructions for the chrony init script.
    update-rc.d: It looks like a network service, we disable it.
    chrony.service is a disabled or a static unit, not starting it.
    Processing triggers for man-db (2.9.0-2) ...
    Processing triggers for kali-menu (2020.1.7) ...
    Processing triggers for systemd (244-3) ..

    Just unsure to what to do from here had a look at chrony.conf chrony.keys
    but don't now what yo do with them to get chrony to work and get my
    network active again connected but no internet.

    Thank you
    Ian

  8. #8
    Join Date
    2014-Feb
    Posts
    299
    You need to enable the service with systemctl enable chrony - then either reboot, or start it manually with systemctl start chrony.

Similar Threads

  1. Raspberry Pi 3 - Kali Linux - Remote Access over 3G
    By markojic in forum ARM Archive
    Replies: 3
    Last Post: 2017-07-06, 15:27
  2. Replies: 0
    Last Post: 2015-12-31, 20:27

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •