Results 1 to 2 of 2

Thread: Cannot put my Wifi Adapter into Monitor Mode using the new 64-bit ARMv8 Kali Linux for RPi 3!

  1. #1
    Join Date
    2019-Dec
    Posts
    1

    Unhappy Cannot put my Wifi Adapter into Monitor Mode using the new 64-bit ARMv8 Kali Linux for RPi 3!

    I recently did an upgrade to the 64-bit version of Kali Linux for my Raspberry Pi 3B rev. v1.2. Everything was fine until I decided to put my Atheros AR9271 Wifi Adapter into one of the USB ports and put into monitor mode using airmon-ng:

    Code:
    sudo airmon-ng start wlan1
    I was expecting the program to return the now-in-monitor-mode message of my interface, something like wlan1mon, but instead it froze halfway:

    Code:
    Found 2 processes that could cause trouble.Kill them using 'airmon-ng check kill' before putting
    the card in monitor mode, they will interfere by changing channels
    and sometimes putting the interface back in managed mode
    
    
        PID Name
        421 NetworkManager
        489 wpa_supplicant
    
    
    PHY	Interface	Driver		Chipset
    
    
    phy0	wlan0		brcmfmac	Broadcom 43430
    phy1	wlan1		ath9k_htc	Qualcomm Atheros Communications AR9271 802.11n
    I tried a few suggestions, including bringing the interface down with ifconfig, which appeared to work at first, but when I took a round of scanning with airodump-ng, the terminal froze as well.
    I also tried all kinds of update/upgrade, switching to new ports, swapping power sources and power cables, but nothing helped.
    Here was what uname -a returned:

    Code:
    Linux kali 4.19.81-Re4son-v8+ #1 SMP PREEMPT Wed Nov 6 03:33:03 UTC 2019 aarch64 GNU/Linux
    I tried upgrading the kernel from re4son, but I suspect they might be older than what I'm currently having on my distro.
    Is this supposed to be a bug? Should I file a report to re4son?
    I remembered being able to put the same adapter into monitor mode using the 32-bit kernel from re4son.
    Comment if anyone wants additional information (e.g. logs, screenshots...) from me.

    Thank for reading and have a nice day.

  2. #2
    Join Date
    2019-Dec
    Posts
    1
    You have to stop NetworkManager

    run 'airmon-ng check kill'

    or service NetworkManager stop

Similar Threads

  1. my usb wireless adapter cant go in monitor mode
    By STNSLW in forum TroubleShooting Archive
    Replies: 8
    Last Post: 2015-10-26, 18:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •