Results 1 to 2 of 2

Thread: RTL8814AU Driver Install not working; Depmod Stalling

  1. #1
    Join Date
    2019-Dec
    Posts
    1

    RTL8814AU Driver Install not working; Depmod Stalling

    Hi all, I've looked for weeks online trying to find out how to install the RTL8814AU driver for my TP-Link Archer T9UH v1. All the solutions either just don't work or end up with depmod stalling. An example of this stalling effect is when I run:

    Code:
    apt-get install realtek-rtl88xxau-dkms
    
    OUTPUT:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      realtek-rtl88xxau-dkms
    0 upgraded, 1 newly installed, 0 to remove and 45 not upgraded.
    Need to get 0 B/1,821 kB of archives.
    After this operation, 17.1 MB of additional disk space will be used.
    Selecting previously unselected package realtek-rtl88xxau-dkms.
    (Reading database ... 275750 files and directories currently installed.)
    Preparing to unpack .../realtek-rtl88xxau-dkms_5.3.4~20191031-0kali1_all.deb ...
    Unpacking realtek-rtl88xxau-dkms (5.3.4~20191031-0kali1) ...
    Setting up realtek-rtl88xxau-dkms (5.3.4~20191031-0kali1) ...
    Loading new realtek-rtl88xxau-5.3.4~20191031 DKMS files...
    Building for 5.3.0-kali2-amd64
    Building initial module for 5.3.0-kali2-amd64
    Done.
    
    88XXau.ko:
    Running module version sanity check.
    
    Good news! Module version v5.3.4_28226.20180614_COEX20171103-6c6d for 88XXau.ko
    exactly matches what is already found in kernel 5.3.0-kali2-amd64.
    DKMS will not replace this module.
    You may override by specifying --force.
    
    depmod...
    Here are some (hopefully) useful outputs
    Code:
    root@CODE-K:~# lsusb
    Bus 003 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 002 Device 002: ID 2357:0106 TP-Link Archer T9UH v1 [Realtek RTL8814AU]
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 004: ID 046d:c040 Logitech, Inc. Corded Tilt-Wheel Mouse
    Bus 001 Device 003: ID 046d:c31d Logitech, Inc. Media Keyboard K200
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Code:
    root@CODE-K:~# iwconfig
    eth0      no wireless extensions.
    
    lo        no wireless extensions.
    Any help will be greatly appreciated!!

  2. #2
    Join Date
    2019-Dec
    Posts
    4
    To try to help I compiled a different version of the driver on a 2019.4 build.

    It compiled without any fatal errors. Might be worth a try. I do not have a 8814 to try it however.

    https://github.com/zebulon2/rtl8814au

Similar Threads

  1. WI-FI DRIVER is not working in KALI LINUX 2019.4
    By DoS@AccessDenied in forum Kali Linux TroubleShooting
    Replies: 0
    Last Post: 4 Weeks Ago, 18:31
  2. Another post about non-working graphics driver - Nvidia 8600M GT
    By aaronouthier in forum Kali Linux TroubleShooting
    Replies: 5
    Last Post: 2019-11-29, 02:15
  3. Desktop no longer working after installing nvidia driver
    By sync1211 in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2017-10-19, 18:17
  4. Replies: 0
    Last Post: 2017-08-23, 14:39
  5. Wifi driver not working
    By vipin in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2013-11-07, 14:30

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •