I thought the days of manually building xorg.conf files were long gone. (I wish)

I have a brand new kali installation (everything up to date - kali-rolling) on an old MacBook Pro (2.2). I have had a fully operational linux installed on this laptop in the recent past. However I grew disenchanted with that distro. Having recently used kali for some data forensics I thought to give it a try. I've been struggling with X ever since.

My old go-to was the 'nomodeset' kernel parameter. Sure enough that gets me further along, (at least I can use the console virtual terminals to set up ssh and whatnot). But no luck with X. The xserver pukes with:

(II) [KMS] drm report modesetting isn't supported.
(EE) Screen 0 deleted because of no matching config section.
(II) UnloadModule: "radeon"
(EE) Device(s) detected, but none match those in the config file.
(EE) Fatal server error:
(EE) no screens found(EE)

Note that modesetting isn't supported, that's expected due to the kernel parameter. Leaving that kernel parameter off it fails with the same error (No Screens Found) however then the laptop console virtual terminals are unusable (but I can ssh in).

In both cases I've tried no xorg.conf and with a `X --configure` generated xorg.conf. The only reasonable thing that I've come across while googling around for the No Screen error was to make sure the Device stanza had the correct BusID line. Yeah, lspci verifies "PCI:1:0:0" == 01:00.0

One thing I noticed was that this AMD chipset (RV530) is in the engineering family "R500" looking through /lib/fimware/radeon/ does not turn up a firmware file. R520_cp.bin is the closest match. Unfortunately I was unable to find how to determine what firmware is in use (dmesg, lspci, dmidecode).

I feel pretty confident this is a kernel / xserver / firmware collision of some type. But I wanted to run it past this forum before broaching trhe xorg gang (and heaven help me kernel support). Thank you.