Hello, so for around 2-3 weeks I have been consistently using Kali when I installed it on my SSD. Yesterday, for some reason after I left the computer on the whole night, I closed it in the morning and when I opened it back up I was always met with an infinite black screen (no cursors, just black) after i enter root & password at the log in screen (kali doesnt load the desktop basically).
SO anyways since that happened, I looked everywhere for solutions but none of them worked (including downloading nvidia drivers). As a last result, I quickly got an empty USB, plugged it in to my computer, went into the command line and copied files I didnt want to lose by first mounting the usb using " mount /media/usb " and then copying the files. After I managed to get the files out of there, I figured its time to do a clean re-install on the SSD.
And the real problem begins: I have re-installed 3-4 times so far. The first Everytime I install it, and try booting the pc into the SSD I am greeted with a black screen that says "Reboot and Select proper Boot Device or Insert boot Media in selected Boot device and press a key". I have tried many things including trying to mount the SSD(which I don't think I even managed to do it correctly). I am very lost as the SSD is just useless right now. I am pretty sure maybe the SSD is corrupted? I do not know how to fix this error. I just want to boot up into Kali and continue from where I left off. Please help guys

Results of commands in terminal (Kali run from a live usb):

# sudo fdisk -l
Screenshot 2020-01-05 20_00_48.jpg