Results 1 to 2 of 2

Thread: VM ifconfig not showing all interfaces

  1. #1
    Join Date

    Question VM ifconfig not showing all interfaces

    I am running MacOS (OSX) and have a VM running Kali Linux but when I run ifconfig, their two respective network interface lists are very different, additionally the VM instance's list is very short while the host machine shows many interfaces (10+). The VM instance is definitely connected to the internet as using the browser works fine.

    Why is the VM instance of Kali not recognizing all network interfaces?

    Note: I am using VirtualBox for the Kali VM and for networking I have the Bridged Adapter setting enabled because I read it should enable direct access to the host's network.

    VM ifconfig:

    Screen Shot 2020-01-08 at 1.06.26 AM.jpg

  2. #2
    Join Date
    It's all virtual, even the interfaces. You get one virtualized interface, and you can see that in lspci. VMware/VirtualBox choose the best interface for internet and does NAT by default.

    If you want to attach more interfaces, you'll have to go to the network editor and create more 'vmnet' interface that you bridge to real interfaces. I don't know the equivalent with VirtualBox, it hasn't worked well for my usage and always let me down when I gave it a chance.

    Bridge gets you direct access to the network. NAT is kinda like behind a firewall. Unless you want access directly to specific network interfaces, NAT is just fine.

Similar Threads

  1. ifconfig not showing ipv4
    By fccj17 in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2023-03-05, 01:01
  2. Wireless Adaptor showing in dmesg but not in ifconfig
    By Duder in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-07-14, 03:19

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts