Hello everybody! Glad to be a part of the community! I just recently got myself a Raspberry Pi with the intention of installing Kali linux on it with full disk encryption. In order to accomplish this, I followed this guide: https://www.kali.org/docs/arm/raspbe...sk-encryption/, and supplemented with this guide: https://github.com/tothi/kali-rpi-luks-crypt. Everything worked out just fine right up until the very end. At the end of the second guide, it says, "The boot process will fail and fallback into busy box. Enter the following commands:" Here is where you are supposed to use cryptsetup to open the container and then exit busybox. From there the system will boot. Once I do this, it boots and I log in to the system where the guides instructs me to run mkinitramfs again to regenerate.

# mkinitramfs -o /boot/initramfs.gz

Once this is done I reboot. Upon rebooting I'm prompted for the encryption passphrase. So far everything is going as planned, until I actually enter the encryption phrase. This is where things stop working.

Fsck fails saying:

"The filesystem size (according to the superblock) is 7561984 blocks
The physical size of the device is 7545408 blocks
Either the superblock or the partition table is likely to be corrupt!

This has happened to me twice on two different SD cards. I tried resizing the filesystem using resize2fs to no avail. I don't understand why the entire process would work and then suddenly the filesystem is corrupted on reboot. Can someone point me in the right direction? Or does the guide I'm following not work anymore.