hello all this is my first post but i am fairly familiar with kali and its installation. i have installed it as a live usb and a dual boot on a secondary hard drive on my main computer. i decided to revive one of my old gaming PCs that is just a case, mobo, AMD a10 processor and ram. the board boots to the bios just fine but when i try to load the live usb it gets to the select screen but when i try to run live i get
"amd-vi: [firmware bug]: : IOAPIC[0] not in IVRS table"
"AMD-VI: [firmware bug]: : No southbridge IOAPIC found"
"AMD-VI: Disabling interrupt remapping"

i believe i have traced this to an IOMMU error and have tried several things to fix this including changing the grub loaded to "amd_iommu=on IOMMU=pt" this looked like it worked a little bit but i just get the start up splash screen and it restarts everything without loading kali. i also tried using the live usb to install kali on a secondary usb as well as moving the hard drive i have it installed on from my main computer to the old one im working on and it all gets the same error. i went through the install i have on on the hard drive from my main and modified the grub loader in it but it still did not fix the issue. i have also run varying combinations of having the SVC on or off (my bios does not have any options for IOMMU and there are no new versions of the firmware).

if anyone knows how to fix this please let me know.