Results 1 to 3 of 3

Thread: Black screen on Live USB with persistence and LUKS

  1. #1
    Join Date

    Black screen on Live USB with persistence and LUKS

    Hello everyone, I'm stuck with a problem I cannot find a valid solutions.

    Problem: while updating && upgrading, notebook (Mac) went in power management and display turned off. When back, as usual, i thought it would just a matter of dropping in the username and pwd (was logged with root), but...didn't worked. Tried to reboot many times, I always see the boot menu, i can choose Live USB with Persistence and Encryption, then I can put the decryption pass and i can see the dragon logo, but after that, a black screen with a flickering mouse pointers that alternates its blink with the cursor on top left corner of the screen. Definitely, the interrupted updated have broke something.

    What I did: tried various combination of keys to enter a rescue mode (never had to previously) and reach a shell. Also, I tried to reboot with Persistence but without encryptions and updated && upgrade from there, nothing changed.

    What I suspect: i could see once in my tries, there was an error message with the bfmac on the black screen, but it never appeared again. I could also, when rebooted with grub, see that he seems to not be able to install drivers that are not free. But if I setup up wifi, it works.

    I'd like to ask for some help. I cannot loose that USB as I worked too much to set everything up in it and I am still studying a lot. What would you do? Please start from the black screen, step by step...

    Infinite thank you.

  2. #2
    Join Date
    Any idea, guys?

  3. #3
    Join Date
    I'm experiencing something similar, although I'm not using LUKS.

    Using 2020.1 live on virtualbox, setup a small virtual disk for persistence. Boot live, see a link on desktop for the vdi, format it ext3 and create the persistence.conf file, reboot works fine to xfce desktop and now that link to the vdi is gone, so far so good. At this point, I gather that behind the scenes, the vdi is being modified. Reboot again, and just get a dark gray screen with a mouse pointer. If I wait long enough, it auto logs out, I get the login screen, and that takes me back to blank desktop. Clicking where I know there should be something to click, like upper left corner for start menu, causes some flashing. Reboot live without persistence, click the link to the vdi, and I see that now a directory structure has been created including home/kali with all the usual like documents and downloads.

    Suspecting a problem with graphics, I disabled 3d acceleration in vbox settings and rebooted, got my desktop back.

Similar Threads

  1. Replies: 0
    Last Post: 2020-04-30, 18:05
  2. Replies: 0
    Last Post: 2016-08-29, 16:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts