Results 1 to 9 of 9

Thread: Kali 2020.1 VMWARE installing Alfa AWUS036ACM

  1. #1
    Join Date

    Kali 2020.1 VMWARE installing Alfa AWUS036ACM


    I'm trying to install ALFA AWUS036ACM on Kali linux 2020.1 , I tried both vmware version of offensive security and the regular installation (running both in VMware) but I keep getting the same error when trying to do "make all / make" of any driver that I download.

    The error that I can see in both installation is this:

    "sh: 0: Can't open /usr/src/linux-headers-5.4.0-kali3-common/scripts/mkmakefile"

    I've tried Mediatek drivers from here:

    I tried the instructions from here:

    sudo apt-get install build-essential linux-headers-`uname -r`
    cd Downloads/rtl8187L_linux_1041.0209.2012
    sudo make install

    and the following:

  2. #2
    Join Date
    I have the same issue. Did you find a solution to this yet?

    Following the error message and navigating to the location - /usr/src/linux-headers-5.4.0-kali3-common/scripts I do not see any entry for "mkmakefile". This is the file that the error is referencing
    I have performed and update and an upgrade and also, installed the latest headers but no luck.

  3. #3
    Join Date
    There have been changes in Linux kernel 5.4.0 (from previous kernels, such as 5.3.0 or below). If the Makefile file you are using to run the make command is using the "SUBDIRS=" option, for example to compile an external kernel module, replace it by the "M=" option.


    all: $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules

    $(MAKE) -C $(KDIR) M=$(PWD) modules


    ================= WARNING ================
    'SUBDIRS' will be removed after Linux 5.3

    If you are building an individual subdirectory
    in the kernel tree, you can do like this:
    $ make path/to/dir/you/want/to/build/
    (Do not forget the trailing slash)

    If you are building an external module,
    Please use 'M=' or 'KBUILD_EXTMOD' instead

  4. #4
    Join Date
    You got the wrong driver (which is for an old 802.11g device), this is a mediatek chipset, and the driver is built in the kernel; you may just be missing the firmware, which would be indicated in dmesg (which is where any error would be logged).

  5. #5
    Join Date
    I have the same issue. Did you find a solution to this yet?

    a1 @ kali: ~ / RT3070 $ makemake -C tools
    make [1]: enter the directory ?/ home / a1 / RT3070 / tools?
    gcc -g bin2h.c -o bin2h
    make [1]: exit the directory ?/ home / a1 / RT3070 / tools?
    / home / a1 / RT3070 / tools / bin2h
    cp -f os / linux / Makefile.6 / home / a1 / RT3070 / os / linux / Makefile
    make -C /lib/modules/5.4.0-kali4-686-pae/build SUBDIRS = / home / a1 / RT3070 / os / linux modules
    make [1]: enter the directory ?/usr/src/linux-headers-5.4.0-kali4-686-pae?
    ln: could not create symbolic link 'source': Access denied
    make [3]: *** [/usr/src/linux-headers-5.4.0-kali4-common/MakefilePE12: outputmakefile] Error 1
    /usr/src/linux-headers-5.4.0-kali4-common/Makefile:659: include / config / auto.conf.cmd: There is no such file or directory
    make [2]: *** [/usr/src/linux-headers-5.4.0-kali4-common/Makefile:677: include / config / auto.conf.cmd] Error 2
    make [1]: *** [/usr/src/linux-headers-5.4.0-kali4-common/Makefile:179: sub-make] Error 2
    make [1]: exit the directory ?/usr/src/linux-headers-5.4.0-kali4-686-pae?
    make: *** [Makefile: 276: LINUX] Error 2

  6. #6
    Join Date
    I am not abele to edit the makefile. getting permission denied.

  7. #7
    Join Date

  8. #8
    Join Date
    I have the same issue. The make won't compile. Alfa says this is a plug and play after Kali 2018+, i tried on 2020.2 and it doesn't work.
    does anyone have clear instructions on how to build the driver for AWUS036ACM?

  9. #9
    Join Date

    Awus036acm don't buy it - garbage on linux

    update: Tried kali 2021.2 using ISO install image with VMware player and device was seen by OS. however i could not get a stable connection to my wifi and keeps on disconnecting. Monitor mode does work on 5 Ghz and packet injection also works with this AWUS036ACM.

    I had thought the issue was with Virtual Box, but today i re-launched the VM (Kali 2021.2), and it worked??? So this device is not stable at all, i don't recommend it. The firmware/driver from what i can tell is using mt7662, but its registered as "mt76x2u" ???

    [ 67.435968] mt76x2u 1-1:1.0: ASIC revision: 76120044
    [ 68.232048] mt76x2u 1-1:1.0: firmware: direct-loading firmware mt7662_rom_patch.bin
    [ 68.232057] mt76x2u 1-1:1.0: ROM patch build: 20141115060606a
    [ 68.786603] mt76x2u 1-1:1.0: firmware: direct-loading firmware mt7662.bin
    [ 68.786610] mt76x2u 1-1:1.0: Firmware Version: 0.0.00
    [ 68.786611] mt76x2u 1-1:1.0: Build: 1
    [ 68.786612] mt76x2u 1-1:1.0: Build Time: 201507311614____
    [ 73.034439] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
    [ 73.037895] usbcore: registered new interface driver mt76x2u

    One thing i am noticing is that the device is super slow when connected to my Wifi. Normally i get a 30Mps and with this Alfa its 1-2 Mps. Its so slow that doesn't even work at times and times out. Not stable. There is a posting about using this in Linux and its "slowness", if i find it i'll share it.

    DO NOT BUY THIS ALFA AWUS036ACM for Pentesting in Kali Linux (Parrot still doesn't work) ITS GARBAGE!!! My $15 TP-LINK (TL-WN722N) is 1000x better and 1/4 the price.
    Last edited by Darkforce16; 2021-08-04 at 14:44.

Similar Threads

  1. Replies: 5
    Last Post: 2015-08-15, 05:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts