Results 1 to 27 of 27

Thread: VirtualBox Bidirectional Copy/Paste not working

  1. #1
    Join Date
    2020-Feb
    Posts
    10

    VirtualBox Bidirectional Copy/Paste not working

    I am running kali-linux-2020-1-vbox-amd64-ova in VirtualBox 6.0.16 on OS X 10.14.6. I have set both "Shared Clipboard" and "Drag and Drop" to "Bidirectional", but neither clipboard sharing nor drag and drop are working in either direction.

    I found this kali forums question from 2016 and followed the instructions about purging virtualbox-guest-x11 and reinstalling. The problem remains.

    VBoxClient is definitely installed and running:

    Code:
    kali@kali ~ % systemctl status -l virtualbox-guest-utils.service
    ● virtualbox-guest-utils.service - Virtualbox guest utils
         Loaded: loaded (/lib/systemd/system/virtualbox-guest-utils.service; enabled; vendor preset: enabled)
         Active: active (running) since Mon 2020-02-17 12:22:23 EST; 5min ago
        Process: 492 ExecStart=/etc/init.d/virtualbox-guest-utils start (code=exited, status=0/SUCCESS)
          Tasks: 11 (limit: 2320)
         Memory: 8.9M
         CGroup: /system.slice/virtualbox-guest-utils.service
                 ├─534 /usr/bin/VBoxClient --vmsvga
                 ├─535 /usr/bin/VBoxClient --vmsvga
                 └─539 /usr/sbin/VBoxService
    Here is what `ps` looks like:

    Code:
    kali@kali ~ % ps -ef | grep VBoxClient
    root         534       1  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         535     534  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         797       1  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         799     797  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         806       1  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         813     806  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         815       1  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         820     815  0 12:22 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1244    1194  0 12:28 pts/0    00:00:00 grep VBoxClient
    I also found a post on StackExchange which suggested that I try `VBoxClient --clipboard`. While that didn't end in an error, it also didn't work. And `VBoxClient --clipboard` doesn't show up in `ps -ef` either.

    I even tried modifying /etc/init.d/virtualbox-guest-utils to add this as line 63:

    Code:
    /usr/bin/VBoxClient --clipboard
    But on reboot, the clipboard still didn't show in ps -ef—and of course the clipboard still isn't being shared.


    As for drag and drop, when I try this in either direction I get an error like this:


    Code:
    Drag and drop operation from guest to host failed.
    Drag and drop error from guest (VERR_INVALID_PARAMETER).
    Result Code:
    VBOX_E_IPRT_ERROR (0x80BB0005)
    Component:
    GuestWrap
    Interface:
    IGuest {13a11514-402e-022e-6180-c3944de3f9c8}
    I don't know if the shared folder is managed by virtualbox-guest-x11 and friends, but that IS working.

    I'm out of ideas at this point, so I thought I would ask here. Thanks in advance for any ideas!
    Last edited by buglab; 2020-02-17 at 21:08. Reason: incorrectly used code blocks made it hard to read

  2. #2
    Join Date
    2020-Feb
    Posts
    1
    I'm having the same problem with the same VM. My host system is Windows 10.

  3. #3
    Join Date
    2020-Feb
    Posts
    3
    I'm having the same problem too on MacOS 10.14.3 really annoying

  4. #4
    Join Date
    2020-Feb
    Posts
    2
    I had the same problem running kali-linux-2020 over VirtualBox in Ubuntu 18.04. I simply solved it by upgrading VirtualBox to the latest version (6.1.4).

    After upgrading, copy/paste works as expected and the clipboard VBoxClient daemon appears as running:

    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         531       1  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         532     531  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         798       1  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         802       1  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         804     802  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         808       1  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         810     808  0 13:22 ?        00:00:02 /usr/bin/VBoxClient --draganddrop
    kali         812       1  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         813     798  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         817     812  0 13:22 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    As I was using the vagrant version of kali linux, I also had to update vagrant to the latest version (2.2.7).

    Best regards,
    David

  5. #5
    Join Date
    2020-Feb
    Posts
    2
    Hi buglab - thanks for your detailed research and presentation to your problem. You made me realize that it had to be much simpler than I'm making it out to be. Update everything. Kali & VirtualBox. As soon as I updated VirtualBox to 6.1 it worked. I created an account just to give you this.
    Cheers.

  6. #6
    Join Date
    2020-Feb
    Posts
    3
    Thank you. It's always the simple things that get me!

  7. #7
    Join Date
    2020-Jan
    Posts
    28
    Install Guest Additions.

  8. #8
    Join Date
    2020-Mar
    Posts
    1
    I was happy when I found this thread, because it describes my exact problem as well. I am using a Kali Rolling (2019.4) x64 image on Oracle VirtualBox Version 6.1.4 r136177 (Qt5.6.2) with host machine being Windows 10 Enterprise 64bit. As you see I updated the VirtualBoxClient but my Copy&Paste problem (as described above) persists. My `ps -ef | grep VBoxClient` output is:
    ```

    (I cannot copy paste obviously hehe)

    I turned on all the bidirectional VBox settings. Havent tried the guest additions though - dont know what this is about. I just wanted to add this here to show that the update did not solve the issue for me.

  9. #9
    Join Date
    2020-Mar
    Posts
    1
    Hi guys,
    The same issue Windows 10 / VBox 6.0.16 / Kali 2020.1 / Guest Additions 6.0.16 - clipboard sharing works fine.
    After upgrade: Windows 10 / VBox 6.1.4 / Kali 2020.1 / Guest Additions 6.0.16 - clipboard sharing works fine either.
    After upgrade (via both apt or VBoxAdditions.iso): Windows 10 / VBox 6.1.4 / Kali 2020.1 / Guest Additions 6.1.4 - clipboard sharing stops working, while the sharing folder is still available.
    Tried to remove and install Guest Additions many times in various ways - clipboard sharing does not work.
    I've tried fresh install of Kali Linux VirtualBox 64-bit 2020.1 - it worked with pre-installed Guest Additions, but after update stopped working either. I assume, something is wrong with the Guest Addition 6.1.4 in my case.
    Very annoying.
    Could anyone help?

  10. #10
    Join Date
    2020-Mar
    Posts
    2

    Solved the clipboard on Macos Catalina 10.15.3 VBox 6.0.18 r136238 Kali Linux GNOME 3.34.2 64-bit

    Quote Originally Posted by Kalikaze View Post
    Hi guys,
    The same issue Windows 10 / VBox 6.0.16 / Kali 2020.1 / Guest Additions 6.0.16 - clipboard sharing works fine.
    After upgrade: Windows 10 / VBox 6.1.4 / Kali 2020.1 / Guest Additions 6.0.16 - clipboard sharing works fine either.
    After upgrade (via both apt or VBoxAdditions.iso): Windows 10 / VBox 6.1.4 / Kali 2020.1 / Guest Additions 6.1.4 - clipboard sharing stops working, while the sharing folder is still available.
    Tried to remove and install Guest Additions many times in various ways - clipboard sharing does not work.
    I've tried fresh install of Kali Linux VirtualBox 64-bit 2020.1 - it worked with pre-installed Guest Additions, but after update stopped working either. I assume, something is wrong with the Guest Addition 6.1.4 in my case.
    Very annoying.
    Could anyone help?
    My solution was to revert back to VBox 6.0.18 r136238. Load the Guest Additions in the optical drive then run the following commands as root.

    1) Copy all the cd rom files to the home directory.
    ------------------------------
    Code:
    cp -r /media/cdrom0/* ~/ 
    2) Run this exe to perform re-installation of necessary files.
    ----------------------------------------------------------------
    Code:
    ./VBoxLinuxAdditions.run
    3) Then reboot the machine.
    -----------------------------
    Code:
    reboot
    One liner
    -----------
    Code:
    cp -r /media/cdrom0/* ~/; ./VBoxLinuxAdditions.run; reboot;
    I've spent hours and days trying to solve this issue ever since I upgraded Kali 2019.3. Hope this helps someone save time. I'm glad this is over for now! kaliService.jpg

    KaliStatus.jpg

  11. #11
    Join Date
    2020-Mar
    Posts
    1
    I'm having this problem as well. Shared clipboard isn't working, but I can't find anything that seems to be wrong. Everything is new and current and seemingly correctly installed. When I attempt to manually launch VBoxClient --clipboard it runs for a few seconds, and then seemingly just quits.

    Here are my details:
    Host OS: Windows 10 Pro 1909 18363.657
    VirtualBox version: 64bit 6.1.4r136177 (Qt5.6.2)
    VirtualBox extension: Oracle VM VirtualBox Extension Pack Version: 6.1.4r136177

    When I try File -> Check for Updates... it says I have the latest version (You are already running the most recent version of VirtualBox)
    When I check Devices -> Shared Clipboard in the running VM, it is set to Bidirectional

    I have tried updating Kali as instructed here: https://www.kali.org/docs/general-use/updating-kali/

    Code:
    # https://www.kali.org/docs/general-use/updating-kali/
    kali@kali:~$ sudo apt update && sudo apt full-upgrade -y
    No errors and everything seems up-to-date.

    Output of uname:
    Code:
    kali@kali:~$ uname -a
    Linux kali 5.4.0-kali4-amd64 #1 SMP Debian 5.4.19-1kali1(2020-02-17) x86_64 GNU/Linux
    VirtualBox guest utils service is running:
    Code:
    kali@kali:~$ systemctl status -l virtualbox-guest-utils.service
    ● virtualbox-guest-utils.service - VirtualBox guest utils
         Loaded: loaded (/lib/systemd/system/virtualbox-guest-utils.service; enabled; vendor preset: enabled)
    	 Active: active (running) since Fri 2020-03-06 09:58:59 EST; 4min 45s ago
    	Process: 417 ExecStart=/etc/init.d/virtualbox-guest-utils start (code=exited, status=0/SUCCESS)
    	  Tasks: 11 (limit: 2320)
    	 Memory: 8.3M
    	 CGroup: /system.slice/virtualbox-guest-utils.service
    	           470 /usr/bin/VBoxClient --vmsvga
    	           471 /usr/bin/VBoxClient --vmsvga
    			   475 /usr/sbin/VBoxService
    
    Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
    Process listing shows that VBoxClient --clipboard is not running:
    Code:
    kali@kali:~$ ps -ef | grep VBox
    root         352       2  0 09:58 ?        00:00:00 [iprt-VBoxWQueue]
    root         470       1  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         471     470  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         475       1  0 09:58 ?        00:00:00 /usr/sbin/VBoxService
    kali         763       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         767       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         771     767  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         772     763  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         777       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         779     777  1 09:59 ?        00:00:08 /usr/bin/VBoxClient --draganddrop
    kali        1271    1063  0 10:09 pts/0    00:00:00 grep VBox
    Launching it manually seems to work, no errors and no other output:
    Code:
    kali@kali:~$ VBoxClient --clipboard
    Immediatly after this VBoxClient --clipboard can also be seen in the process view:
    Code:
    kali@kali:~$ ps -ef | grep VBox
    root         352       2  0 09:58 ?        00:00:00 [iprt-VBoxWQueue]
    root         470       1  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         471     470  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         475       1  0 09:58 ?        00:00:00 /usr/sbin/VBoxService
    kali         763       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         767       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         771     767  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         772     763  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         777       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         779     777  1 09:59 ?        00:00:13 /usr/bin/VBoxClient --draganddrop
    kali        1285       1  0 10:15 ?        00:00:00 VBoxClient --clipboard
    kali        1286    1285  0 10:15 ?        00:00:00 VBoxClient --clipboard
    kali        1288    1063  0 10:15 pts/0    00:00:00 grep VBox
    However after some time, those processes simply disappear:
    Code:
    kali@kali:~$ sleep 60; ps -ef | grep VBox
    root         352       2  0 09:58 ?        00:00:00 [iprt-VBoxWQueue]
    root         470       1  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         471     470  0 09:58 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         475       1  0 09:58 ?        00:00:00 /usr/sbin/VBoxService
    kali         763       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         767       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         771     767  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         772     763  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         777       1  0 09:59 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         779     777  1 09:59 ?        00:00:14 /usr/bin/VBoxClient --draganddrop
    kali        1292    1063  0 10:16 pts/0    00:00:00 grep VBox
    Manually updating/installing virtualbox-guest-x11 says I already have the most current version:
    Code:
    kali@kali:~$ sudo apt install virtualbox-guest-x11
    [sudo] password for kali:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    virtualbox-guest-x11 is alreadythe newest version (6.1.4-dfsg-1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I'm out of ideas. I also tried the following earlier today, with no effect (I forgot to save output):
    Code:
    apt purge virtualbox-guest-x11
    apt autoremove --purge
    # reboot
    apt update && apt dist-upgrade
    # reboot
    apt install virtualbox-guest-x11
    # reboot
    Attached Files Attached Files

  12. #12
    Join Date
    2020-Feb
    Posts
    10
    Quote Originally Posted by david.fdez View Post
    I had the same problem running kali-linux-2020 over VirtualBox in Ubuntu 18.04. I simply solved it by upgrading VirtualBox to the latest version (6.1.4).
    Wow, I had no idea there was a newer version of VirtualBox. I had downloaded and installed multiple updates over the past few months after in-app alerts. "Check for Updates…" also said I was at the newest version. But as soon as I installed the ACTUAL newest version and rebooted the kali instance, everything worked as expected. Talk about a misleading bug!

    Anyway, thank you David and gofigure!

  13. #13
    Join Date
    2019-Mar
    Posts
    9
    I am having the exact same issue, but I am already on version 6.1.4. Host is Windows 10 and Guest is Kali. I am update to date on all software.

  14. #14
    Join Date
    2020-Mar
    Posts
    2
    I have the same problem as well. I have latest version of "Virtual Box Version 6.1.4 r136177" with "Extension Pack" and "kali-linux-2020.1-vbox-amd64.ova" and installed all guest additions.What I noticed is when I create VM and run it for the first time, everything works flawlessly (Drag 'n Drop and Copy/paste) without installing any guest additions. However, after I ran sudo apt-get update && sudo apt-get upgrade and restarted my virtual machine. drag n drop and copy/paste stopped working completely, even after installing guest additions.

  15. #15
    Join Date
    2020-Mar
    Posts
    2
    I have the same problem as well. I am running latest version of " VirtualBox Version 6.1.4 r136177" with Extension Packs on kali-linux-2020-1-vbox-amd64-ova with guest additions installed.What I noticed is when I install/export and run fresh Kali VM for the first time , all features (drag n drop and copy/past...) work flawlessly, without installing guest additions. However, after I ran sudo apt-get update && sudo apt-get upgrade and restarted my VM, it stopped working completely, even after installing all guest additions.

  16. #16
    Join Date
    2020-Mar
    Posts
    6
    I'd like to provide an update to Kalikaze's post.

    For me, everything works using a fresh VirtualBox install of Kali 2020.1 (on a Windows 10 host). This comes with virtualbox-guest-x11 version 6.1.2-dfsg-1 installed. After an apt upgrade, this is replaced with version 6.1.4-dfsg-1, which breaks shared clipboard functionality after a reboot. I'm running VirtualBox 6.1.4r136177, the most recent version at this time.

    I have not tested drag-and-drop functions as they relate to this issue.

  17. #17
    Same problem came from upgrading Kali. Upgrade to 6.1.4 didn't fix it for me either. You can copy your ps output to a shared folder (since that still works for some reason) to get data off the machine.

  18. #18
    Quote Originally Posted by clintonm9 View Post
    I am having the exact same issue, but I am already on version 6.1.4. Host is Windows 10 and Guest is Kali. I am update to date on all software.
    Made an account to say the same thing.
    Stopped working once I upgraded to Kali 2020.
    I can drag and drop files over but shared clipboard is a no go.

  19. #19
    An additional data point is that I forgot to add is that I am able to share from my host OSX to a windows virtual box VM no problem.I am not able to share clipboard data in or out of Kali 2020.

  20. #20
    Join Date
    2020-Mar
    Posts
    1
    Hi Guys, You can upgrade the virtualbox package with the version 6.1.4-dfsg-2, it's working for me : https://packages.debian.org/fr/sid/v...guest-utilsYou just need to add source list : cat /etc/apt/sources.list.d/vbox.list deb http://deb.debian.org/debian/ sid main contrib non-freeAdd preference to avoid an full system update to sid : cat /etc/apt/preferences.d/virtualbox Package: virtualbox*Pin: release n=sidPin-Priority: 100make an apt update and apt install virtualbox-guest-utils=6.1.4-dfsg-2, apt install virtualbox-guest-x11=6.1.4-dfsg-2 and apt install virtualbox-guest-dkms=6.1.4-dfsg-2have a good day

  21. #21
    Join Date
    2020-Mar
    Posts
    4
    Quote Originally Posted by clintonm9 View Post
    I am having the exact same issue, but I am already on version 6.1.4. Host is Windows 10 and Guest is Kali. I am update to date on all software.
    I have the same problem with the same environment
    But I notice the following:
    When I first start Kali and checked the running VBox processes I got the following:
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         889       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         891     889  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1514    1506  0 09:53 pts/0    00:00:00 grep VBoxClient
    When I start using clipboard by copy simple text, the VBoxClient clipboard processes stopped
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1520    1506  0 09:54 pts/0    00:00:00 grep VBoxClient
    Is there any log file contains the reason why the process terminated ?

  22. #22
    Join Date
    2020-Mar
    Posts
    4

    Same Here

    Quote Originally Posted by clintonm9 View Post
    I am having the exact same issue, but I am already on version 6.1.4. Host is Windows 10 and Guest is Kali. I am update to date on all software.
    I have the same problem in the same environment.

    But I noticed when I restart Kali and checked the running VBox processes I got the following:
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         889       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         891     889  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1514    1506  0 09:53 pts/0    00:00:00 grep VBoxClient
    When I start using clipboard, the "VBoxClient --clipboard" process disappeared!!
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1520    1506  0 09:54 pts/0    00:00:00 grep VBoxClient
    Is there any log file contains details about the error occurred that caused "VBoxClient --clipboard" process to stop?

  23. #23
    Join Date
    2020-Mar
    Posts
    4
    Quote Originally Posted by clintonm9 View Post
    I am having the exact same issue, but I am already on version 6.1.4. Host is Windows 10 and Guest is Kali. I am update to date on all software.
    I have the same problem in the same environment.

    But I noticed when I restart Kali and checked the running VBox processes I got the following:
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         889       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         891     889  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --clipboard
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1514    1506  0 09:53 pts/0    00:00:00 grep VBoxClient
    When I start using clipboard, the "VBoxClient --clipboard" process disappeared!!
    Code:
    kali@kali:~$ ps -ef | grep VBoxClient
    root         538       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    root         540     538  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --vmsvga
    kali         896       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         898     896  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --display
    kali         903       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         905     903  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --seamless
    kali         912       1  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali         917     912  0 09:53 ?        00:00:00 /usr/bin/VBoxClient --draganddrop
    kali        1520    1506  0 09:54 pts/0    00:00:00 grep VBoxClient
    Is there any log file contains details about the error occurred that caused "VBoxClient --clipboard" process to stop?

  24. #24
    Join Date
    2020-Mar
    Posts
    4
    The steps in the following link work for me:
    https://www.ceos3c.com/hacking/kali-...working-fixed/

  25. #25
    Join Date
    2016-Jan
    Posts
    2
    This is a known bug in the 6.1.4 VirtualBox Guest Additions, which explains why some users didn't report an issue even after upgrading their host to VirtualBox 6.1.4; they didn't upgrade the Guest Additions to 6.1.4 in their VMs. Upgrading the Guest Editions to a test build of 6.1.5 on the VM resolves the issue without needing to install an unsigned test VirtualBox build of 6.1.5 on the host system.

    Test builds can be downloaded from https://www.virtualbox.org/wiki/Testbuilds

  26. #26
    Join Date
    2020-Feb
    Posts
    3
    Hi - I'm having this issue again since upgrading my kali (apt-get upgrade) and now bidirectional copy and paste isn't working. I have the latest version of virtual box and my I'm running MacOS 10.15.4. Anyone else able to replicate?

  27. #27
    Join Date
    2020-Apr
    Posts
    3
    Mine wasnt working either... I had a virtual drive mounted. I copied the contents to my desktop and then installed via terminal from the desktop. Everything now works

Similar Threads

  1. Replies: 0
    Last Post: 2016-11-30, 15:47

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •