Results 1 to 16 of 16

Thread: Your Kernel Headers Cannot Be Found

  1. #1
    Join Date
    2020-Feb
    Location
    NYC
    Posts
    5

    Your Kernel Headers Cannot Be Found

    Hello:

    I am trying to install my AWUS1900 on the latest build of Kali following the guide here (GitHub).

    When I run sudo ./dkms-install.sh, I get the error below.

    "Your kernel headers for kernel 5.4.0-kali2-amd64 cannot be found at/lib/modules/5.4.0-kali2-amd64/build or /lib/modules/5.4.0-kali2-amd64/source."

    I have conducted a search of related topics on this forum but couldn't find anything beneficial. Any help you can provide is appreciated even if its a link to a relevant post.

  2. #2
    Join Date
    2014-Feb
    Posts
    299
    Did you follow the full instructions? Specifically the part where it says Package / Build dependencies (Kali) under Notes?

  3. #3
    Join Date
    2020-Feb
    Location
    NYC
    Posts
    5
    I did, yes. Received the below error


    E: Unable to locate package linux-headers-5.4.0-kali2-amd64
    E: Couldn't find any package by glob 'linux-headers-5.4.0-kali2-amd64'
    E: Couldn't find any package by regex 'linux-headers-5.4.0-kali2-amd64'

    Upon running apt-cache, I see this:

    inux-headers-5.4.0-kali3-all - All header files for Linux 5.4 (meta-package)
    linux-headers-5.4.0-kali3-all-amd64 - All header files for Linux 5.4 (meta-package)
    linux-headers-5.4.0-kali3-amd64 - Header files for Linux 5.4.0-kali3-amd64
    linux-headers-5.4.0-kali3-cloud-amd64 - Header files for Linux 5.4.0-kali3-cloud-amd64


    So I guess I need to install kali3 instead of the kali2 shown in the first error....?

  4. #4
    Join Date
    2014-Feb
    Posts
    299
    Yes, you need to be updated to the latest packages. Also, you should probably try the realtek-rtl8188eus-dkms package (which is what that GitHub provides) - but again, you'll need to be updated otherwise it will have the same complaint, that the headers are missing, because that kernel isn't used anymore.

  5. #5
    Join Date
    2020-Feb
    Location
    NYC
    Posts
    5
    I will try realtek-rtl8188eus. Appreciate the help and will comment if I am successful.

  6. #6
    Join Date
    2020-Feb
    Location
    NYC
    Posts
    5
    I have tried the alternative package you suggested but to no avail. I receive the same errors as I did before. I navigated to /lib/modules/5.4.0-kali2-amd64 and see neither /build nor /source.

    It seems both the original and suggested packages are associated with 5.4.0kali2-amd64 which does not appear to be installed based on this error: "Module build for kernel 5.4.0-kali2-amd64 was skipped since the kernel headers for this kernel does not seem to be installed."

    Not quite sure what to do now as the problem seems to be with the packages being outdated....

  7. #7
    Join Date
    2014-Feb
    Posts
    299
    You need to update and reboot. Your kernel is out dated, and we do not have headers available for that kernel anymore.

  8. #8
    Join Date
    2020-Feb
    Location
    NYC
    Posts
    5
    I updated multiple times. The issue was on my end - I was installing the wrong file. Bad searching by me.

    Correct instructions can be found here if anyone has a similar issue.

    Thanks for the help

  9. #9
    Quote Originally Posted by CrashOverride View Post
    I updated multiple times. The issue was on my end - I was installing the wrong file. Bad searching by me.

    Correct instructions can be found here if anyone has a similar issue.

    Thanks for the help
    It's so nice of you to share the resolution! This is to let you know your information helped some newbie a lot

  10. #10
    Join Date
    2020-Apr
    Posts
    1
    i have the same issue with vm player

  11. #11
    till having trouble guys!!!!!!!!!!!!!!!!!!!!!!!!!!

    root@Catbus-Kali:/home/ghibli/rtl8812au# sudo apt-get install linux-headers-$(uname -r)
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    linux-headers-5.4.0-kali4-amd64 is already the newest version (5.4.19-1kali1).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    and then on the other side of things , i install. and get ...








    root@Catbus-Kali:/home/ghibli/rtl8812au# apt-get install realtek-rtl88xxau-dkms
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following NEW packages will be installed:
    realtek-rtl88xxau-dkms
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 1,821 kB of archives.
    After this operation, 17.1 MB of additional disk space will be used.
    Get:1 http://mirrors.ocf.berkeley.edu/kali kali-last-snapshot/contrib amd64 realtek-rtl88xxau-dkms all 5.3.4~20191031-0kali1 [1,821 kB]
    Fetched 1,821 kB in 13s (137 kB/s)
    Selecting previously unselected package realtek-rtl88xxau-dkms.
    (Reading database ... 512267 files and directories currently installed.)
    Preparing to unpack .../realtek-rtl88xxau-dkms_5.3.4~20191031-0kali1_all.deb ...
    Unpacking realtek-rtl88xxau-dkms (5.3.4~20191031-0kali1) ...
    Setting up realtek-rtl88xxau-dkms (5.3.4~20191031-0kali1) ...
    Loading new realtek-rtl88xxau-5.3.4~20191031 DKMS files...
    Building for 5.4.0-kali4-amd64
    Module build for kernel 5.4.0-kali4-amd64 was skipped since the
    kernel headers for this kernel does not seem to be installed.

  12. #12
    Join Date
    2020-May
    Posts
    1
    Thanks CrashOverride the direction on the link shared worked exquisitely

  13. #13
    Join Date
    2020-May
    Posts
    2
    Before installing Vmware Workstation you need to install build-essential and linux headers:

    sudo apt-get install build-essential linux-headers-$(uname -r)

  14. #14
    Join Date
    2013-Jun
    Posts
    95
    Quote Originally Posted by yosef View Post
    Before installing Vmware Workstation you need to install build-essential and linux headers:

    sudo apt-get install build-essential linux-headers-$(uname -r)
    And if you are using a usb live persistence, re-do your stick with the latest weekly image...unless someone knows an easier quicker way...

  15. #15
    Join Date
    2020-Oct
    Posts
    1
    I have come from 1 step and all coke okay, just restarted the installation process and then do step-by-step everythin

  16. #16
    Join Date
    2021-Apr
    Posts
    1

    amigo, estou com o mesmo problema, estou tentando instalar o drive rtl8188eus da erro no make

    Quote Originally Posted by CrashOverride View Post
    I updated multiple times. The issue was on my end - I was installing the wrong file. Bad searching by me.

    Correct instructions can be found here if anyone has a similar issue.

    Thanks for the help
    poderia me ajudar por favor?

Similar Threads

  1. Kali 2.0 VMplayer c headers files not found
    By eof in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-12-25, 18:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •