Results 1 to 3 of 3

Thread: problems while upgrading kali

  1. #1
    Join Date
    2020-Feb
    Posts
    1

    problems while upgrading kali

    Hello,
    I tried to update my kali linux system using apt update and apt upgrade commands and an error occurred during the upgrade. I really tried a lot to solve the problem but to no avail. right now i'm just going to present what happens when i run apt update, apt upgrade and apt --fix-broken install commands

    when i run apt update
    Code:
     Atteint :1 http://kali.download/kali kali-rolling InRelease
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    264 paquets peuvent être mis ?* jour. Exécutez « apt list --upgradable » pour les voir.
    when i run apt upgrade
    Code:
     Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
    Les paquets suivants contiennent des dépendances non satisfaites :
     ruby-cms-scanner : Dépend: ruby-progressbar (>= 1.9.0) mais il n'est pas installé
    E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
       (ou indiquez une solution).
    when i run apt --fix-broken install
    Code:
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances       
    Lecture des informations d'état... Fait
    Correction des dépendances... Fait
    Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
      atftpd axel couchdb erlang17-asn1 erlang17-base erlang17-crypto
      erlang17-eunit erlang17-inets erlang17-mnesia erlang17-os-mon
      erlang17-public-key erlang17-runtime-tools erlang17-snmp erlang17-ssl
      erlang17-syntax-tools erlang17-tools erlang17-webtool erlang17-xmerl
      exe2hexbat expect gir1.2-clutter-gst-3.0 gir1.2-gtkclutter-1.0 gparted
      gparted-common libacl1-dev libattr1-dev libavahi-gobject0
      libayatana-ido3-0.4-0 libbind9-160 libboost-atomic1.62.0
      libboost-chrono1.62.0 libboost-date-time1.62.0 libboost-filesystem1.62.0
      libbrlapi0.6 libcodec2-0.8.1 libcrystalhd3 libcupsfilters1 libcupsimage2
      libdee-1.0-4 libdns1102 libdrm-dev libenca0 libevent-core-2.1-6
      libevent-openssl-2.1-6 libevent-pthreads-2.1-6 libexiv2-14
      libfolks-telepathy25 libgeos-3.6.2 libgfortran4 libglade2-0
      libglvnd-core-dev libgmime-3.0-0 libgssglue1 libgtk2-perl libgtkmm-2.4-1v5
      libhttp-parser2.8 libhunspell-1.6-0 libipt1 libirs160 libisc169 libisccc160
      libisccfg160 libisl19 libjaxp1.3-java libjim0.77 libjs-jquery-form
      liblinear3 liblirc-client0 liblouis16 liblvm2app2.2 liblvm2cmd2.02
      liblwres160 libmission-control-plugins0 libmozjs185-1.0 libmysofa0
      libntfs-3g88 libopencv-core3.2 libopencv-imgproc3.2 libopengl0 libpango-perl
      libpotrace0 libprotobuf-lite10 libprotobuf10 libradare2-2.7 libsctp1
      libtagc0 libtbb2 libtelepathy-glib0 libtexlua52 libunbound2 libusbmuxd4
      libwhisker2-perl libx11-xcb-dev libxapian30 libxcb-dri2-0-dev
      libxcb-dri3-dev libxcb-glx0-dev libxcb-present-dev libxcb-randr0-dev
      libxcb-render0-dev libxcb-shape0-dev libxcb-sync-dev libxcb-xf86dri0
      libxcb-xfixes0-dev libxdamage-dev libxdot4 libxext-dev libxfixes-dev
      libxshmfence-dev libxxf86vm-dev libzeitgeist-2.0-0 mesa-common-dev
      openjdk-10-jdk openjdk-10-jdk-headless openjdk-10-jre php php-mysql php7.2
      php7.2-mysql php7.3 php7.3-mysql python-anyjson python-asn1crypto
      python-capstone python-couchdbkit python-dicttoxml python-dnslib
      python-geoip python-gtkspellcheck python-http-parser python-jsonrpclib
      python-jwt python-magic python-mako python-mockito python-nassl python-pam
      python-prettytable python-pypdf2 python-qrcode python-restkit
      python-secretstorage python-slowaes python-socketpool python-whoosh
      python-xlsxwriter python-xmlbuilder python3-iso8601 python3.6
      python3.6-minimal rdesktop ruby-dataobjects ruby-dataobjects-mysql
      ruby-dataobjects-postgres ruby-dataobjects-sqlite3 ruby-dm-core
      ruby-dm-do-adapter ruby-dm-migrations ruby-dm-serializer
      ruby-dm-sqlite-adapter ruby-faraday ruby-geoip ruby-librex ruby-libv8
      ruby-ref ruby-ruby-progressbar ruby-terminal-table ruby-therubyracer
      ruby-unicode-display-width snmpd tcl-expect telepathy-mission-control-5
      x11proto-damage-dev x11proto-dri2-dev x11proto-fixes-dev x11proto-gl-dev
      x11proto-xext-dev x11proto-xf86vidmode-dev zeitgeist-core
    Veuillez utiliser « apt autoremove » pour les supprimer.
    Les paquets supplémentaires suivants seront installés : 
      ruby-progressbar
    Les NOUVEAUX paquets suivants seront installés :
      ruby-progressbar
    0 mis ?* jour, 1 nouvellement installés, 0 ?* enlever et 264 non mis ?* jour.
    721 partiellement installés ou enlevés.
    Il est nécessaire de prendre 0 o/23,9 ko dans les archives.
    Après cette opération, 89,1 ko d'espace disque supplémentaires seront utilisés.
    Souhaitez-vous continuer ? [O/n] o
    (Lecture de la base de données... 392735 fichiers et répertoires déj?* installés.
    )
    Préparation du dépaquetage de .../ruby-progressbar_1.10.1-1_all.deb ...
    Dépaquetage de ruby-progressbar (1.10.1-1) ...
    dpkg: erreur de traitement de l'archive /var/cache/apt/archives/ruby-progressbar
    _1.10.1-1_all.deb (--unpack) :
     tentative de remplacement de « /usr/lib/ruby/vendor_ruby/ruby-progressbar/base.
    rb », qui appartient aussi au paquet ruby-ruby-progressbar 1.6.0-0kali1
    Des erreurs ont été rencontrées pendant l'exécution :
     /var/cache/apt/archives/ruby-progressbar_1.10.1-1_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    please help me i don't know what to do!!!!

  2. #2
    Join Date
    2020-Feb
    Posts
    1
    Hi, baudouin

    try this:

    dpkg -i --force-overwrite /var/cache/apt/archives/ruby-progressbar_1.10.1-1_all.deb

    apt --fix-broken -f install

    Problem solved

  3. #3
    Join Date
    2020-Feb
    Posts
    2

    Quote Originally Posted by Tripini View Post
    Hi, baudouin

    try this:

    dpkg -i --force-overwrite /var/cache/apt/archives/ruby-progressbar_1.10.1-1_all.deb

    apt --fix-broken -f install

    Problem solved
    Thank you.

Similar Threads

  1. upgrading to 2017.3 problems with screen res and networking
    By vortex77 in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2017-12-15, 12:30
  2. Replies: 1
    Last Post: 2016-02-26, 05:43
  3. problems upgrading to 2016
    By bob79 in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-01-27, 10:56
  4. Upgrading GLIBC from 2.13 Problems
    By 2f4da24d in forum TroubleShooting Archive
    Replies: 1
    Last Post: 2015-02-13, 10:09

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •