Results 1 to 4 of 4

Thread: Realtek RTL8811AU Monitor mode issues on Kernel 5.4

  1. #1
    Join Date
    2020-Feb
    Posts
    1

    Post Realtek RTL8811AU Monitor mode issues on Kernel 5.4

    Hi, i have been having an issue since the recent upgrade to Kali 2020.1 and the new kernel 5.4. I have spent a few days trawling both this forum and the wider web for answers or resolution but have not come up with anything concrete.

    I am using the Realtek AWUS036ACS wireless adapter with the RTL8811AU chipset, which worked perfectly on the previous 4.19 kernel.

    However since the upgrade to 5.4, i have had issues with the monitor mode. The device itself is recognized when plugged in and i can use this to connect to wifi with no issues. However when putting this into monitor mode (using either airmon-ng or iwconfig) this shows as monitor mode, but will crash/error when attempting to use (such as wifite or airgeddon).

    Example below is using airmon-ng to enter monitor mode, confirmed by iwconfig, and then wifite throwing an error about no monitor mode. The same is shown when using iwconfig to put the device into monitor mode:

    Code:
    user@kali:~$ sudo airmon-ng check kill
    
    user@kali:~$ sudo airmon-ng start wlan1
    
    
    PHY     Interface       Driver          Chipset
    
    phy0    wlan0           iwlwifi         Intel Corporation Wireless 7260 (rev bb)
    phy3    wlan1           88XXau          Realtek Semiconductor Corp. 
     (monitor mode enabled)
    
    user@kali:~$ sudo iwconfig
    eth0      no wireless extensions.
    
    wlan1     IEEE 802.11b  ESSID:""  Nickname:"<WIFI@REALTEK>"
              Mode:Monitor  Frequency:2.457 GHz  Access Point: Not-Associated   
              Sensitivity:0/0  
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=0/100  Signal level=-100 dBm  Noise level=0 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    lo        no wireless extensions.
    
    wlan0     IEEE 802.11  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=22 dBm   
              Retry short limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on
    
    user@kali:~$ sudo wifite --kill
       .               .    
     .  ?  .     .  ?  `.  wifite2 2.5.0
     :  :  :  (?)  :  :  :  an automated wireless auditor forked from @derv82
     `.  ?  ` /?\   ?  .  https://github.com/kimocoder/wifite2
       `     /???\         
    
     [+] option: kill conflicting processes enabled
    
        Interface   PHY   Driver              Chipset                                                                                                                     
    -----------------------------------------------------------------------
     1. wlan0       phy0  iwlwifi             Intel Corporation Wireless 7260 (rev bb)
     2. wlan1       phy3  88XXau              Realtek Semiconductor Corp.   
    
     [+] Select wireless interface (1-2): 2
     [+] enabling monitor mode on wlan1... failed
    failed
    
     [!] Error: Cannot find any interfaces in monitor mode
    
     [!] Full stack trace below
    
     [!]    Traceback (most recent call last):
     [!]    File "/usr/lib/python3/dist-packages/wifite/__main__.py", line 98, in entry_point
     [!]        wifite.start()
     [!]    File "/usr/lib/python3/dist-packages/wifite/__main__.py", line 51, in start
     [!]        Configuration.get_monitor_mode_interface()
     [!]    File "/usr/lib/python3/dist-packages/wifite/config.py", line 152, in get_monitor_mode_interface
     [!]        cls.interface = Airmon.ask()
     [!]    File "/usr/lib/python3/dist-packages/wifite/tools/airmon.py", line 332, in ask                                                                                
     [!]        iface.interface = Airmon.start(iface)
     [!]    File "/usr/lib/python3/dist-packages/wifite/tools/airmon.py", line 203, in start                                                                              
     [!]        raise Exception('Cannot find any interfaces in monitor mode')
     [!]  Exception: Cannot find any interfaces in monitor mode                                                                                                           
                                                                                                                                                                          
     [!] Exiting
    So it would appear that although iwconfig shows this is in monitor mode, it actually is not changing this. I have been able to change my internal PCI wifi to monitor mode and back in the same way which works in wifite (although not very strong).

    My initial thought was the drivers, so have removed and reinstalled both the "firmware-realtek" and "realtek-rtl88xxau-dkms" drivers (auto installed at upgrade), which has had no effect. I have also searched for alternative drivers and installed to see if this has any impact, but again none.

    When checking dmesg after the device has been plugged in, no (obvious) errors are shown.

    Code:
    user@kali:~$ sudo dmesg
    [ 7077.001882] usb 1-2.3: new high-speed USB device number 16 using xhci_hcd
    [ 7077.026451] usb 1-2.3: New USB device found, idVendor=0bda, idProduct=0811, bcdDevice= 2.00
    [ 7077.026467] usb 1-2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 7077.026477] usb 1-2.3: Product: 802.11ac WLAN Adapter 
    [ 7077.026486] usb 1-2.3: Manufacturer: Realtek 
    [ 7077.026496] usb 1-2.3: SerialNumber: 00e04c000001
    After searching this forum, it appears a lot of others are having issues with WIFI on the new kernel, but mine is specifically monitor mode. My only guess is that this is an issue with the driver, but having been able to use the Wifi i am not sure.

    Anyone have any guidance here? My thoughts are to find a driver which works with both the Wifi and monitor mode for this device, or downgrade the kernel to 4.19. Or do i just stick with the current driver&kernel and hope that is something bigger and out of my control that will be fixed down the line?

    Thanks

    Ovi

  2. #2
    Join Date
    2018-Jul
    Posts
    21
    Drivers and such are worth a shot, I have tried myself and haven't had anything fix it. However mine is giving issues in dmesg, it was fine until 2019.4 with my AWUS036NEH. Seems like it's a kernel issue for everyone, I wonder if they plan on fixing it with a future update, since the non-root and XFCE4 stuff was more important for 2020.1..

  3. #3
    Join Date
    2020-Jun
    Posts
    1
    I am also having the same problem with RTL8811AU chipset. It does not work in Monitor mode.

  4. #4
    Dear friends, go and catch them all if (you have a problem with using monitoring mode){
    https://github.com/nu11secur1ty/w1f1t3kAl1} else {print "Have fun "}

Similar Threads

  1. Replies: 11
    Last Post: 2019-01-15, 14:47
  2. I made Kernel for Monitor Mode
    By darobbe in forum NetHunter General Questions
    Replies: 2
    Last Post: 2018-10-01, 17:16
  3. Unable to get the realtek 8191su in Monitor Mode
    By flyinghaggis in forum TroubleShooting Archive
    Replies: 12
    Last Post: 2014-01-31, 08:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •