Results 1 to 4 of 4

Thread: Installing Kali on a Bay Trail device with 32 bit EFI

  1. #1
    Join Date
    2014-Mar
    Posts
    36

    Installing Kali on a Bay Trail device with 32 bit EFI

    I originally hoped this would be a how-to post, but I'm still trying to figure out how to. There are a number of threads going back 5 years, and there's even a few websites with step by step directions. Unfortunately, they all failed on my hardware (Winbook TW801). The advice usually takes one of two paths. Either you install Linux, let grub install fail, and fix grub later, or you fix the install so it will install properly. I can install Kali, but it fails at installing grub-dummy (I've wiped the drive many times, no dual boot here), and everything I've tried failed at some point. Using the other method, I put bootia32.efi on the install USB drive, but still fails. Isorespin.sh didn't work on Kali, and seems to be only for Ubuntu flavors.

    I came up with a third way, but it also didn't work. First, I installed Fedora 31, which installs nicely without issue. Then, I booted to a live CD image, and wiped all partitions except the EFI, and then installed Kali, specifying using the empty space instead of the entire disk (I hoped this would leave grub alone). I can access a grub prompt, but that's it.

    I'm running out of steam, so I figured I'd ask for help, at least to share information and ideas so someone might find an answer.

    Has anyone got Isorespin.sh to work on Kali?
    IS EFI just a fat32 partition with some files? Or is there other magic involved? Can I simply copy the files from a working Fedora install, install Kali, copy over the EFI files, and tweak config?
    When Kali installs grub, does it actually run a grub install? Or does it simply copy files to the EFI partition? If I take Fedora's grub files and put them on Kali install media, would that work?


    If it helps, here's some of the links I've been collecting:


    https://www.howtogeek.com/114884/how...ntu-wont-boot/ - Tried this, didn?t work. 64 Bit version wouldn?t boot, and 32 bit version said the 64 bit version was required.

    http://www.ubuntubuzz.com/2016/03/bo...ub-prompt.html - More instructions on fixing Grub.

    https://forums.kali.org/showthread.p...y-failed/page2 - My post. Not fruitful so far.

    https://forums.kali.org/showthread.p...ndows-10/page2 - a sister thread to the above one.

    http://www.rodsbooks.com/refind/getting.html - The rEFInd boot manager.

    https://www.reddit.com/r/linux4noobs...to_boot_linux/ - Not Kali, but about a Winbook tablet.

    http://linuxiumcomau.blogspot.com/20...trail-and.html - Ubuntu on Bay Trail and Cherry Trail devices.

    http://linuxiumcomau.blogspot.com/20...mentation.html - Part 2 of above, using isorespin, which doesn?t work for Kali

    https://medium.com/@realzedgoat/a-so...s-d39b1d1961ec - ?Beginner?s Guide'. Also says Fedora has the change built in. However, the guide seems to be based heavily on Ubuntu.

    https://www.studioteabag.com/science...nue-pro-linux/ - Focuses on Linux on Dell Venue 8 Pro

    https://wiki.debian.org/UEFI#Support...th_32-bit_UEFI - Official Debian docs, mentions it.

    https://forums.kali.org/showthread.p...ight=bay+trail - A Kali thread about the Asus Transformer t100. No real answers.

    https://forums.kali.org/showthread.p...-One-Asus-T100 - Another Kali thread, referenced by the above link. Old, and not terribly helpful.

    http://www.jfwhome.com/2016/01/04/la...e-asus-t100ta/ - Another, older one for the Asus T100a

    https://unix.stackexchange.com/quest...64-bit-machine - Fixing Grub on 32 UEFI. some detail, but I didn?t find helpful.

  2. #2
    Join Date
    2014-Mar
    Posts
    36
    As an update, after installing Kali while trying to leave the EFI partition, I got a grub prompt. I entered this:
    set root=(hd0,gpt2)
    linux /boot/vmlinuz-5.4.0-kali4-amd64 root=dev/mmcblk1p1
    initrd /boot/initrd.img-5.4.0-kali4-amd64
    boot

    It simply resets, never starting Kali.

    Also, I tried creating a fresh USB Kali install, and then deleted the bootx64.efi file in /EFI/boot, and copied there everything from Fedora's install EFI/BOOT directory, but I only got another grub prompt when trying to boot the modified USB.

  3. #3
    Join Date
    2014-Mar
    Posts
    36
    Another update...
    I downloaded BackBox, ran Isorespin.sh on it, and installed it. This didn't work completely, leaving me at a grub prompt. I entered these commands in, and got Backbox to boot.

    grub> set root=(hd0,gpt2)
    grub> linux /vmlinuz root=/dev/mmcblk1p2
    grub> initrd /initrd.img
    grub> boot

    After booting into BackBox, I ran these commands in a terminal:
    sudo update-grub
    sudo grub-install /dev/mmcblk1

    The second line gave errors, but rebooting brought me into BackBox fine. I'm tempted to just stop here, as I've never even heard of BackBox before this.

  4. #4
    Join Date
    2014-Mar
    Posts
    36
    Just as an update, I've given up installing Kali on an Atom tablet. Hopefully someone creates a multi-arch install. Otherwise, Backbox works fine.

Similar Threads

  1. Replies: 51
    Last Post: 2017-11-29, 16:35
  2. Replies: 1
    Last Post: 2016-03-08, 20:40
  3. Guleek i8 - Bay Trail minipc
    By burton666 in forum Installing Archive
    Replies: 0
    Last Post: 2015-01-08, 09:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •