Results 1 to 3 of 3

Thread: Metasploit / Searchsploit and ExploitDB module not loaded

  1. #1
    Join Date
    2020-Jan
    Posts
    7

    Metasploit / Searchsploit and ExploitDB module not loaded

    Hi Forum,

    Im doing some studying for my Pentest+ exam and am having trouble with ExploitDB exploits in metasploit.

    Every time I locate an exploit that I want to use in Exploit DB I am never able to load the **** thing.

    There is this exploit that I want to run on my lab called CuteNews 1.4.1 - Shell Injection / Remote Command Execution which is stored in exploits/php/webapps/1289.php.

    I have:
    - copied 1289.php to .msf4/modules/exploits/php/webapps
    - run updated db
    - restarted postgresql
    - run apt update && apt dist-upgrade
    - run apt-get upgrade

    But nothing works. Is this because its a php file that I am importing and something needs to be done differently?
    I have also tried exactly the same with .rb and .py files and had exactly the same result.

    I am running metasploit v5.0.80-dev. Is it a version / compatitibility issue between metasploit and the exploits in ExploitDB?
    My Kali build is a recent one. Latest version only about a month ago.

    Really appreciate any help with this.

    Thanks

  2. #2
    ~Dupe~

    See below

  3. #3
    Metasploit is written in Ruby. php != Ruby

    You should spend a bit more time getting comfortable with searchsploit. Understand the flags.

    Also, you might as well go through the Metasploit Unleashed free course.

    https://www.offensive-security.com/m...oit-unleashed/

Similar Threads

  1. cannot download "metasploit-framework" and "exploitdb" packages
    By fsasse in forum TroubleShooting Archive
    Replies: 4
    Last Post: 2016-08-01, 11:24
  2. Replies: 4
    Last Post: 2013-05-27, 08:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •