Results 1 to 7 of 7

Thread: [HELP] Upgrade from 2016.2 to 2020.1

  1. #1
    Join Date
    2016-Nov
    Posts
    8

    Question [HELP] Upgrade from 2016.2 to 2020.1

    UPDATE: I just did a fresh install from a new iso 2020.1b it went well but there was some firmwares that didn't install, so for people who are encountering this issue here's a workaround:

    Code:
    # git clone git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
    # cp -r linux-firmware/rtl_nic/ /lib/firmware/
    # cp -r linux-firmware/i915/ /lib/firmware/
    # update-initramfs -u
    That should solve the problem, only one thing, check the directories in linux-firmware prior to copy in /lib/firmware. I had a wifi firmware issue i don't know if it's the same for all cases.

    Now, last problem for me is, I can't get linux to upgrade correctly to the latest packages, ie:
    these three packages (initramfs-tools, linux-image-amd64, linux-image-5.4.0-kali4-amd64) won't configure correctly and I don't understand why ?
    When i do a :
    Code:
    # dpkg --configure -a
    I got a No space left on device error, so if someone has a solution for this issue i'd appreciate the help.

    Thnx in advance.



    Hello everyone,

    I just installed an old version (2016.2) of Kali Linux that i got on a DVD, everthing went well until it tried to install the new packages i got these dependencies errors :
    Code:
    # apt update && apt full-upgrade
    Hit:1 http://kali.download/kali kali-rolling InRelease
    Traceback (most recent call last):
      File "/usr/bin/debtags", line 25, in <module>
        import apt
      File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
        import apt_pkg
    ModuleNotFoundError: No module named 'apt_pkg'
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    1936 packages can be upgraded. Run 'apt list --upgradable' to see them.
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.133-1 is installed
     gir1.2-gtk-3.0 : Depends: libgtk-3-0 (>= 3.24.7) but 3.20.9-1 is installed
     libgail-3-0 : Depends: libgtk-3-0 (= 3.24.14-1) but 3.20.9-1 is installed
     libwayland-egl1-mesa : Depends: libegl1 but it is not installed
     postgresql-common : Depends: postgresql-client-common (= 214) but 175 is installed
     python-cairo : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python-gi : Depends: python2 (< 2.8) but it is not installed
                 Depends: python2 (>= 2.7~) but it is not installed
                 Depends: python2:any (< 2.8)
                 Depends: python2:any (>= 2.7~)
     python-gi-cairo : Depends: python2 (< 2.8) but it is not installed
                       Depends: python2 (>= 2.7~) but it is not installed
                       Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
     python-httplib2 : Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
                       Breaks: python-pysimplesoap (< 1.16-2.1) but 1.16-1 is installed
     python-lxml : Depends: python2 (< 2.8) but it is not installed
                   Depends: python2 (>= 2.7~) but it is not installed
                   Depends: python2:any (< 2.8)
                   Depends: python2:any (>= 2.7~)
     python-numpy : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python3 : PreDepends: python3-minimal (= 3.5.1-4) but 3.7.5-3 is installed
               Depends: libpython3-stdlib (= 3.5.1-4) but 3.7.5-3 is installed
     python3-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-tk : Depends: python3 (>= 3.7.5-1~) but 3.5.1-4 is installed
     sysv-rc : Depends: startpar (>= 0.62-1~) but 0.59-3.1 is installed
    E: Unmet dependencies. Try using -f.
    I'm stuck here i can't proceed further.
    I tried, nothing!!
    Code:
    # apt -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.133-1 is installed
     gir1.2-gtk-3.0 : Depends: libgtk-3-0 (>= 3.24.7) but 3.20.9-1 is installed
     libgail-3-0 : Depends: libgtk-3-0 (= 3.24.14-1) but 3.20.9-1 is installed
     libwayland-egl1-mesa : Depends: libegl1 but it is not installed
     postgresql-common : Depends: postgresql-client-common (= 214) but 175 is installed
     python-cairo : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python-gi : Depends: python2 (< 2.8) but it is not installed
                 Depends: python2 (>= 2.7~) but it is not installed
                 Depends: python2:any (< 2.8)
                 Depends: python2:any (>= 2.7~)
     python-gi-cairo : Depends: python2 (< 2.8) but it is not installed
                       Depends: python2 (>= 2.7~) but it is not installed
                       Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
     python-httplib2 : Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
                       Breaks: python-pysimplesoap (< 1.16-2.1) but 1.16-1 is installed
     python-lxml : Depends: python2 (< 2.8) but it is not installed
                   Depends: python2 (>= 2.7~) but it is not installed
                   Depends: python2:any (< 2.8)
                   Depends: python2:any (>= 2.7~)
     python-numpy : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python3 : PreDepends: python3-minimal (= 3.5.1-4) but 3.7.5-3 is installed
               Depends: libpython3-stdlib (= 3.5.1-4) but 3.7.5-3 is installed
     python3-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-tk : Depends: python3 (>= 3.7.5-1~) but 3.5.1-4 is installed
     sysv-rc : Depends: startpar (>= 0.62-1~) but 0.59-3.1 is installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    Code:
    dpkg --configure -a
    dpkg: dependency problems prevent configuration of python-gi-cairo:
     python-gi-cairo depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-gi-cairo depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-gi-cairo depends on python2:any (<< 2.8); however:
     python-gi-cairo depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-gi-cairo (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gir1.2-gtk-3.0:amd64:
     gir1.2-gtk-3.0:amd64 depends on libgtk-3-0 (>= 3.24.7); however:
      Version of libgtk-3-0:amd64 on system is 3.20.9-1.
    
    dpkg: error processing package gir1.2-gtk-3.0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-gi-cairo:
     python3-gi-cairo depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-gi-cairo (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-gi:
     python3-gi depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-gi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-numpy:
     python-numpy depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-numpy depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-numpy depends on python2:any (<< 2.8); however:
     python-numpy depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-numpy (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-httplib2:
     python-httplib2 depends on python2:any (<< 2.8).
     python-httplib2 depends on python2:any (>= 2.7~).
    
    dpkg: error processing package python-httplib2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-gi:
     python-gi depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-gi depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-gi depends on python2:any (<< 2.8); however:
     python-gi depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-gi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libwayland-egl1-mesa:amd64:
     libwayland-egl1-mesa:amd64 depends on libegl1; however:
      Package libegl1:amd64 is not installed.
    
    dpkg: error processing package libwayland-egl1-mesa:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of postgresql-common:
     postgresql-common depends on postgresql-client-common (= 214); however:
      Version of postgresql-client-common on system is 175.
    
    dpkg: error processing package postgresql-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-lxml:amd64:
     python-lxml:amd64 depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-lxml:amd64 depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-lxml:amd64 depends on python2:any (<< 2.8); however:
     python-lxml:amd64 depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-lxml:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-cairo:amd64:
     python-cairo:amd64 depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-cairo:amd64 depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-cairo:amd64 depends on python2:any (<< 2.8); however:
     python-cairo:amd64 depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-cairo:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of sysv-rc:
     sysv-rc depends on startpar (>= 0.62-1~); however:
      Version of startpar on system is 0.59-3.1.
    
    dpkg: error processing package sysv-rc (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgail-3-0:amd64:
     libgail-3-0:amd64 depends on libgtk-3-0 (= 3.24.14-1); however:
      Version of libgtk-3-0:amd64 on system is 3.20.9-1.
    
    dpkg: error processing package libgail-3-0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of dmsetup:
     dmsetup depends on libdevmapper1.02.1 (>= 2:1.02.138); however:
      Version of libdevmapper1.02.1:amd64 on system is 2:1.02.133-1.
    
    dpkg: error processing package dmsetup (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-cairo:amd64:
     python3-cairo:amd64 depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-cairo:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-tk:amd64:
     python3-tk:amd64 depends on python3 (>= 3.7.5-1~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-tk:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-pyatspi:
     python3-pyatspi depends on python3-gi (>= 2.90.1); however:
      Package python3-gi is not configured yet.
    
    dpkg: error processing package python3-pyatspi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-pysimplesoap:
     python-pysimplesoap depends on python-httplib2; however:
      Package python-httplib2 is not configured yet.
     python-httplib2 (0.14.0-1) breaks python-pysimplesoap (<< 1.16-2.1) and is unpacked but not configured.
      Version of python-pysimplesoap to be configured is 1.16-1.
    
    dpkg: error processing package python-pysimplesoap (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     python-gi-cairo
     gir1.2-gtk-3.0:amd64
     python3-gi-cairo
     python3-gi
     python-numpy
     python-httplib2
     python-gi
     libwayland-egl1-mesa:amd64
     postgresql-common
     python-lxml:amd64
     python-cairo:amd64
     sysv-rc
     libgail-3-0:amd64
     dmsetup
     python3-cairo:amd64
     python3-tk:amd64
     python3-pyatspi
     python-pysimplesoap
    Can someone help me ?

    Thank you in advance.
    Last edited by dunCan; 2020-04-08 at 16:05. Reason: [SOLVED]

  2. #2
    Quote Originally Posted by dunCan View Post
    Hello everyone,

    I just installed an old version (2016.2) of Kali Linux that i got on a DVD, everthing went well until it tried to install the new packages i got these dependencies errors :
    Code:
    # apt update && apt full-upgrade
    Hit:1 http://kali.download/kali kali-rolling InRelease
    Traceback (most recent call last):
      File "/usr/bin/debtags", line 25, in <module>
        import apt
      File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
        import apt_pkg
    ModuleNotFoundError: No module named 'apt_pkg'
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    1936 packages can be upgraded. Run 'apt list --upgradable' to see them.
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.133-1 is installed
     gir1.2-gtk-3.0 : Depends: libgtk-3-0 (>= 3.24.7) but 3.20.9-1 is installed
     libgail-3-0 : Depends: libgtk-3-0 (= 3.24.14-1) but 3.20.9-1 is installed
     libwayland-egl1-mesa : Depends: libegl1 but it is not installed
     postgresql-common : Depends: postgresql-client-common (= 214) but 175 is installed
     python-cairo : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python-gi : Depends: python2 (< 2.8) but it is not installed
                 Depends: python2 (>= 2.7~) but it is not installed
                 Depends: python2:any (< 2.8)
                 Depends: python2:any (>= 2.7~)
     python-gi-cairo : Depends: python2 (< 2.8) but it is not installed
                       Depends: python2 (>= 2.7~) but it is not installed
                       Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
     python-httplib2 : Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
                       Breaks: python-pysimplesoap (< 1.16-2.1) but 1.16-1 is installed
     python-lxml : Depends: python2 (< 2.8) but it is not installed
                   Depends: python2 (>= 2.7~) but it is not installed
                   Depends: python2:any (< 2.8)
                   Depends: python2:any (>= 2.7~)
     python-numpy : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python3 : PreDepends: python3-minimal (= 3.5.1-4) but 3.7.5-3 is installed
               Depends: libpython3-stdlib (= 3.5.1-4) but 3.7.5-3 is installed
     python3-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-tk : Depends: python3 (>= 3.7.5-1~) but 3.5.1-4 is installed
     sysv-rc : Depends: startpar (>= 0.62-1~) but 0.59-3.1 is installed
    E: Unmet dependencies. Try using -f.
    I'm stuck here i can't proceed further.
    I tried, nothing!!
    Code:
    # apt -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     dmsetup : Depends: libdevmapper1.02.1 (>= 2:1.02.138) but 2:1.02.133-1 is installed
     gir1.2-gtk-3.0 : Depends: libgtk-3-0 (>= 3.24.7) but 3.20.9-1 is installed
     libgail-3-0 : Depends: libgtk-3-0 (= 3.24.14-1) but 3.20.9-1 is installed
     libwayland-egl1-mesa : Depends: libegl1 but it is not installed
     postgresql-common : Depends: postgresql-client-common (= 214) but 175 is installed
     python-cairo : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python-gi : Depends: python2 (< 2.8) but it is not installed
                 Depends: python2 (>= 2.7~) but it is not installed
                 Depends: python2:any (< 2.8)
                 Depends: python2:any (>= 2.7~)
     python-gi-cairo : Depends: python2 (< 2.8) but it is not installed
                       Depends: python2 (>= 2.7~) but it is not installed
                       Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
     python-httplib2 : Depends: python2:any (< 2.8)
                       Depends: python2:any (>= 2.7~)
                       Breaks: python-pysimplesoap (< 1.16-2.1) but 1.16-1 is installed
     python-lxml : Depends: python2 (< 2.8) but it is not installed
                   Depends: python2 (>= 2.7~) but it is not installed
                   Depends: python2:any (< 2.8)
                   Depends: python2:any (>= 2.7~)
     python-numpy : Depends: python2 (< 2.8) but it is not installed
                    Depends: python2 (>= 2.7~) but it is not installed
                    Depends: python2:any (< 2.8)
                    Depends: python2:any (>= 2.7~)
     python3 : PreDepends: python3-minimal (= 3.5.1-4) but 3.7.5-3 is installed
               Depends: libpython3-stdlib (= 3.5.1-4) but 3.7.5-3 is installed
     python3-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-gi-cairo : Depends: python3 (>= 3.7~) but 3.5.1-4 is installed
     python3-tk : Depends: python3 (>= 3.7.5-1~) but 3.5.1-4 is installed
     sysv-rc : Depends: startpar (>= 0.62-1~) but 0.59-3.1 is installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    Code:
    dpkg --configure -a
    dpkg: dependency problems prevent configuration of python-gi-cairo:
     python-gi-cairo depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-gi-cairo depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-gi-cairo depends on python2:any (<< 2.8); however:
     python-gi-cairo depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-gi-cairo (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of gir1.2-gtk-3.0:amd64:
     gir1.2-gtk-3.0:amd64 depends on libgtk-3-0 (>= 3.24.7); however:
      Version of libgtk-3-0:amd64 on system is 3.20.9-1.
    
    dpkg: error processing package gir1.2-gtk-3.0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-gi-cairo:
     python3-gi-cairo depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-gi-cairo (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-gi:
     python3-gi depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-gi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-numpy:
     python-numpy depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-numpy depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-numpy depends on python2:any (<< 2.8); however:
     python-numpy depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-numpy (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-httplib2:
     python-httplib2 depends on python2:any (<< 2.8).
     python-httplib2 depends on python2:any (>= 2.7~).
    
    dpkg: error processing package python-httplib2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-gi:
     python-gi depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-gi depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-gi depends on python2:any (<< 2.8); however:
     python-gi depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-gi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libwayland-egl1-mesa:amd64:
     libwayland-egl1-mesa:amd64 depends on libegl1; however:
      Package libegl1:amd64 is not installed.
    
    dpkg: error processing package libwayland-egl1-mesa:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of postgresql-common:
     postgresql-common depends on postgresql-client-common (= 214); however:
      Version of postgresql-client-common on system is 175.
    
    dpkg: error processing package postgresql-common (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-lxml:amd64:
     python-lxml:amd64 depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-lxml:amd64 depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-lxml:amd64 depends on python2:any (<< 2.8); however:
     python-lxml:amd64 depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-lxml:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-cairo:amd64:
     python-cairo:amd64 depends on python2 (<< 2.8); however:
      Package python2 is not installed.
     python-cairo:amd64 depends on python2 (>= 2.7~); however:
      Package python2 is not installed.
     python-cairo:amd64 depends on python2:any (<< 2.8); however:
     python-cairo:amd64 depends on python2:any (>= 2.7~); however:
    
    dpkg: error processing package python-cairo:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of sysv-rc:
     sysv-rc depends on startpar (>= 0.62-1~); however:
      Version of startpar on system is 0.59-3.1.
    
    dpkg: error processing package sysv-rc (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgail-3-0:amd64:
     libgail-3-0:amd64 depends on libgtk-3-0 (= 3.24.14-1); however:
      Version of libgtk-3-0:amd64 on system is 3.20.9-1.
    
    dpkg: error processing package libgail-3-0:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of dmsetup:
     dmsetup depends on libdevmapper1.02.1 (>= 2:1.02.138); however:
      Version of libdevmapper1.02.1:amd64 on system is 2:1.02.133-1.
    
    dpkg: error processing package dmsetup (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-cairo:amd64:
     python3-cairo:amd64 depends on python3 (>= 3.7~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-cairo:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-tk:amd64:
     python3-tk:amd64 depends on python3 (>= 3.7.5-1~); however:
      Version of python3 on system is 3.5.1-4.
    
    dpkg: error processing package python3-tk:amd64 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python3-pyatspi:
     python3-pyatspi depends on python3-gi (>= 2.90.1); however:
      Package python3-gi is not configured yet.
    
    dpkg: error processing package python3-pyatspi (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-pysimplesoap:
     python-pysimplesoap depends on python-httplib2; however:
      Package python-httplib2 is not configured yet.
     python-httplib2 (0.14.0-1) breaks python-pysimplesoap (<< 1.16-2.1) and is unpacked but not configured.
      Version of python-pysimplesoap to be configured is 1.16-1.
    
    dpkg: error processing package python-pysimplesoap (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     python-gi-cairo
     gir1.2-gtk-3.0:amd64
     python3-gi-cairo
     python3-gi
     python-numpy
     python-httplib2
     python-gi
     libwayland-egl1-mesa:amd64
     postgresql-common
     python-lxml:amd64
     python-cairo:amd64
     sysv-rc
     libgail-3-0:amd64
     dmsetup
     python3-cairo:amd64
     python3-tk:amd64
     python3-pyatspi
     python-pysimplesoap
    Can someone help me ?


    Thank you in advance.

    I'm pretty sure that python2 is no longer supported. My best advice is download Kali 2019.1 or 2019.2 and install it, then update from there. The reason I suggest an older version is because it is before they updated the kernel and there is a lot of issues with internal wireless card on laptop on the newest kernel.

  3. #3
    It would probably be easier to just install with a new iso.

    https://cdimage.kali.org/kali-2020.1...ller-amd64.iso

  4. #4
    Join Date
    2014-May
    Posts
    25
    apt update && apt -y full-upgrade

  5. #5
    Join Date
    2016-Nov
    Posts
    8
    Quote Originally Posted by Rasalom View Post
    It would probably be easier to just install with a new iso.

    https://cdimage.kali.org/kali-2020.1...ller-amd64.iso
    This is what i did now i couldn't find a solution otherwise, and even with a new iso i think i've a problem initramfs-update it lacks some firmwares (Realtek i think!!), anyways i'm gonna post an update this evening maybe.

    Quote Originally Posted by aetos View Post
    apt update && apt -y full-upgrade
    This is exactly what i did in the first place!

  6. #6
    Join Date
    2014-May
    Posts
    25
    # apt update && apt full-upgrade
    #apt update && apt -y full-upgrade

    ?????????????????????????????

  7. #7
    Join Date
    2016-Nov
    Posts
    8
    LAST UPDATE: for the last three packages :
    initramfs-tools
    linux-image-amd64
    linux-image-5.4.0-kali4-amd64

    I just purged them, rebooted, i did a last update && full-upgrade and everything went well.

    Let's get to work, shall we!

Similar Threads

  1. Kali upgrade to 2020.1 - New tools not being installed
    By sphereict in forum Installing Kali Linux
    Replies: 2
    Last Post: 2020-02-04, 17:55
  2. Upgrade to 2020.1
    By snaggle in forum Kali Linux General Questions
    Replies: 0
    Last Post: 2020-01-30, 16:16
  3. Kali 2016.2 messed up Desktop after after upgrade/dist-upgrade
    By SpectrE_Fth in forum TroubleShooting Archive
    Replies: 9
    Last Post: 2017-02-13, 10:26
  4. 2016.1 upgrade failure
    By Dark Eagle in forum Installing Archive
    Replies: 6
    Last Post: 2017-01-24, 10:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •