Results 1 to 2 of 2

Thread: V3D Driver Issue on arm64 2020.2 4.19.93-Re4son-v8l+ kernel

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    2020-Apr
    Posts
    2

    Unhappy V3D Driver Issue on arm64 2020.2 4.19.93-Re4son-v8l+ kernel

    Hardware and Software info:
    Device: Raspberry Pi 4 Model B 2GB
    Kernel: 4.19.93-Re4son-v8l+ aarch64(arm64)
    Needed kernel Modules Installed:
    Code:
    root@kali:~ # lsmod
    Module                  Size  Used by
    aes_neon_blk           28672  3
    crypto_simd            16384  1 aes_neon_blk
    cryptd                 32768  1 crypto_simd
    aes_arm64              16384  1 aes_neon_blk
    ccm                    20480  1
    hci_uart               45056  1
    btbcm                  16384  1 hci_uart
    serdev                 20480  1 hci_uart
    bluetooth             438272  3 hci_uart,btbcm
    ecdh_generic           28672  1 bluetooth
    binfmt_misc            20480  1
    arc4                   16384  2
    rtl8187                49152  0
    eeprom_93cx6           16384  1 rtl8187
    mac80211              925696  1 rtl8187
    bcm2835_codec          40960  0
    sg                     36864  0
    bcm2835_v4l2           49152  0
    v4l2_mem2mem           28672  1 bcm2835_codec
    v4l2_common            16384  1 bcm2835_v4l2
    bcm2835_mmal_vchiq     32768  2 bcm2835_codec,bcm2835_v4l2
    videobuf2_vmalloc      16384  1 bcm2835_v4l2
    videobuf2_dma_contig    20480  1 bcm2835_codec
    joydev                 24576  0
    videobuf2_memops       16384  2 videobuf2_vmalloc,videobuf2_dma_contig
    videobuf2_v4l2         28672  3 bcm2835_codec,bcm2835_v4l2,v4l2_mem2mem
    videobuf2_common       49152  4 bcm2835_codec,videobuf2_v4l2,bcm2835_v4l2,v4l2_mem2mem
    videodev              249856  6 bcm2835_codec,v4l2_common,videobuf2_v4l2,bcm2835_v4l2,videobuf2_common,v4l2_mem2mem
    brcmfmac              319488  0
    media                  40960  3 videodev,bcm2835_codec,v4l2_mem2mem
    vc_sm_cma              36864  1 bcm2835_mmal_vchiq
    rpivid_mem             16384  0
    vc4                   200704  1
    brcmutil               20480  1 brcmfmac
    v3d                    73728  0
    drm_kms_helper        200704  2 vc4
    gpu_sched              28672  1 v3d
    cfg80211              757760  3 brcmfmac,mac80211,rtl8187
    drm                   512000  6 gpu_sched,drm_kms_helper,v3d,vc4
    snd_soc_core          217088  1 vc4
    drm_panel_orientation_quirks    20480  1 drm
    rfkill                 32768  7 bluetooth,cfg80211
    snd_compress           20480  1 snd_soc_core
    snd_pcm_dmaengine      16384  1 snd_soc_core
    syscopyarea            16384  1 drm_kms_helper
    snd_bcm2835            32768  1
    sysfillrect            16384  1 drm_kms_helper
    sysimgblt              16384  1 drm_kms_helper
    fb_sys_fops            16384  1 drm_kms_helper
    evdev                  24576  8
    snd_pcm               126976  4 vc4,snd_bcm2835,snd_soc_core,snd_pcm_dmaengine
    raspberrypi_hwmon      16384  0
    hwmon                  20480  1 raspberrypi_hwmon
    snd_timer              40960  1 snd_pcm
    snd                    86016  7 snd_bcm2835,snd_timer,snd_compress,snd_soc_core,snd_pcm
    uio_pdrv_genirq        16384  0
    uio                    20480  1 uio_pdrv_genirq
    fixed                  16384  0
    ip_tables              28672  0
    x_tables               40960  1 ip_tables
    ipv6                  503808  56
    I installed Kali Linux 64bit ARM for Raspberry Pi 4 image a couple days ago and there seems to be some problems about the V3D driver on my setup. Just as shown above, i have v3d and vc4 drivers (fkms). But in this position, even i have installed mesa-utils, libdrm-dev and that graphics stuff for system (just as i did for my another raspbian system which works with v3d 4.2 drivers), glxinfo gives that output:
    Code:
    root@kali:~ # glxinfo -B
    name of display: :0.0
    display: :0  screen: 0
    direct rendering: Yes
    Extended renderer info (GLX_MESA_query_renderer):
        Vendor: VMware, Inc. (0xffffffff)
        Device: llvmpipe (LLVM 9.0.1, 128 bits) (0xffffffff)
        Version: 19.3.3
        Accelerated: no
        Video memory: 1858MB
        Unified memory: no
        Preferred profile: core (0x1)
        Max core profile version: 3.3
        Max compat profile version: 3.1
        Max GLES1 profile version: 1.1
        Max GLES[23] profile version: 3.1
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: llvmpipe (LLVM 9.0.1, 128 bits)
    OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.3.3
    OpenGL core profile shading language version string: 3.30
    OpenGL core profile context flags: (none)
    OpenGL core profile profile mask: core profile
    
    OpenGL version string: 3.1 Mesa 19.3.3
    OpenGL shading language version string: 1.40
    OpenGL context flags: (none)
    
    OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.3.3
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
    I tried to apply Eric Anholt's Tutorial here: https://github.com/anholt/mesa/wiki/...spbian-upgrade (not armhf, i compiled the gpu driver for arm64 it seemed ok while building but in the end it is still llvmpipe drivers.)
    And here is the weird inxi -G output: (It says it is vc4_drm driver which seems normal but it says its opengl driver is not v3d, it's llvm?)
    Code:
    root@kali:~ # inxi -G
    Graphics:
      Device-1: bcm2835-vc4 driver: vc4_drm v: N/A 
      Device-2: bcm2835-hdmi driver: N/A 
      Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev 
      resolution: 1280x1024~60Hz 
      OpenGL: renderer: llvmpipe (LLVM 9.0.1 128 bits) v: 3.3 Mesa 19.3.3
    When i try glxgears command, i get 330+ FPS while it supposed to V-Sync and lock 60FPS. What can i do to enable v3d driver? (In my config.txt file, the line with fkms-vc4-v3d stuff under section [pi4] is commented out already)

  2. #2
    Join Date
    2020-Apr
    Posts
    1
    Same here. When IO check service status I get:

    Agd 16 23:30:46 kali systemd[1]: Starting Bluetooth service...
    Agd 16 23:30:46 kali bluetoothd[1400]: Bluetooth daemon 5.50
    Agd 16 23:30:46 kali systemd[1]: Started Bluetooth service.
    Agd 16 23:30:46 kali bluetoothd[1400]: Starting SDP server
    Agd 16 23:30:46 kali bluetoothd[1400]: Bluetooth management interface 1.14>
    Agd 16 23:30:46 kali bluetoothd[1400]: Sap driver initialization failed.
    Agd 16 23:30:46 kali bluetoothd[1400]: sap-server: Operation not permitted>

    Agd 16 23:30:46 kali bluetoothd[1400]: Endpoint registered: sender=:1.28 p>
    Agd 16 23:30:46 kali bluetoothd[1400]: Endpoint registered: sender=:1.28 p>

Similar Threads

  1. Kali and raspi-gpio for arm64
    By krogstad in forum ARM Archive
    Replies: 3
    Last Post: 2020-08-26, 17:11
  2. Kali Linux 2020.1 nvidia driver problem
    By linuksfan in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2020-02-17, 16:24
  3. Replies: 11
    Last Post: 2019-01-15, 14:47
  4. Kali on SCB ARM64
    By monmoonmooonmoooon in forum ARM Archive
    Replies: 0
    Last Post: 2015-12-17, 10:21

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •