Hi guys

I hope you're all well, and safe.

As you can see in my profile I'm new user in the forum, and also in Linux.
I bought an AWUS1900 to start a new journey by exploring Kali linux, the WI-Fi vulnerabilities and everything related to Pentest, but I'm having a few issues.

I'm listing some point below as a result of my own research trying to find the solution. I hope it will give you details enough to support me to move forward. I hope you can also spend some time sharing the "why's" behind your comments. I really appreciate if you can spend that time sharing your knowledge and helping me to develop my own.

1 - If I run LSUSB, I can see the below

Bus 001 Device 003: ID 0bda:8813 Realtek Semiconductor Corp. RTL8814AU 802.11a/b/g/n/ac Wireless Adapter

2 - If I run AIRMON-NG, it's not listing the driver

PHY Interface Driver Chipset

3 - I tried to follow the instructions from this video - https://www.***********************aXagM9G_nFE, and I could see something differnt listed after running the AIRMON-NG. However, the blue light wasn't flashing in the modem. and it's still the same - Not flashing at all... it seems the modem is not connected.
I've plugged the antenna on Windows to use Kali via virtual machine, the lights were there... flashing like a carnival in Rio de Janeiro or a party in Venice!

I'm very confident the procedure I run to install the driver from the youtube video I mentioned above did something, but the computer is not keeping the configuration when I restart it.

4 - The computer I want to use Kali is a bit old, and I'm not running it via virtual machine. It's actually installed as a official and single S.O in this machine. I just wanted to share this information as I think we may have different ways to resolve it if I'm not working in a VM.

5 - If I run the IFCONFIG, this is what I can see, and there's no WI-FI listed below.

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::eeb1:d7ff:fe65:6c14 prefixlen 64 scopeid 0x20<link>
ether ec:b1:d7:65:6c:14 txqueuelen 1000 (Ethernet)
RX packets 28038 bytes 24826507 (23.6 MiB)
RX errors 0 dropped 1 overruns 0 frame 0
TX packets 19569 bytes 2764899 (2.6 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 20 memory 0xf7c00000-f7c20000

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

6 - It's a very strange feeling... I'm trying not to compare, but it's impossible. It's far more complex than installing an .exe for windows... I looked up into Alfa website, and also Realtek website looking for the drivers, but I couldn't manage to find the version for Linux, and its very weird. The Chipset is realtek RLT8814AU. I also tried to install the CD driver, but no success.

As I said in the beggining. I'd appreciate a lot if you can share the "why's" behind your answer. It will help me a lot.

Thanks for reading and I looking forward to hearing back from you.