Page 2 of 3 FirstFirst 123 LastLast
Results 51 to 100 of 101

Thread: 2020.2 nexmon

  1. #51
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Would be better for you to take over now. Use the kernel-builder and apply kernel features and patches one at a time, build and test until you found the change that caused the bootloop.

  2. #52
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Please raise a merge request once you've built one that boots.
    Many thanks

  3. #53
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    but sir i dont have pc enviroment you know
    please just one time try

  4. #54
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    the problem is Image.gz-dtb . can you try build with example scripts because i tried with these scripts and it worked.

  5. #55
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Please compare those scripts to the kernel-builder and point out the difference that could cause a bootloop. Thanks

  6. #56
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    okey sir i using nethunter kex for build procces thanks for all.

  7. #57
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    sir remove suzuran from devices.

  8. #58
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    or just remove kernel image sir.
    if i can build image succesfully, i will send merge request .

  9. #59
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    @re4son sir can we apply this patch to sony xperia z5 compact ? https://github.com/kimocoder/qualcom...tor_mode.patch
    its cooler than nexmon
    also thanks sir, libs are worked enjections works
    but when i . monstart-nh
    then
    nexutil, it says libdl.so not found

  10. #60
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    sir also Nethunter pre4 version has Kex issues.
    When i enable Kex, device freezes.
    pre3 version is good.

  11. #61
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    sir i think the problem is, using angler device's hid patch.
    you patched hid using angler's patch please write patch and apply for z5 compact.
    i tried but in chroot, it fails.. out of ram (

  12. #62
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by rootboy01 View Post
    sir i think the problem is, using angler device's hid patch.
    you patched hid using angler's patch please write patch and apply for z5 compact.
    i tried but in chroot, it fails.. out of ram (
    @re4son https://github.com/Re4son/android_ke...d9f8daded1404f

    this cause bootloop .

  13. #63
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Quote Originally Posted by rootboy01 View Post
    sir also Nethunter pre4 version has Kex issues.
    When i enable Kex, device freezes.
    pre3 version is good.
    Placebo effect. Pre4 is identical to pre3. The reason we have pre4 is so that Android 10 users can upgrade after flashing, which is a requirement to get around the scoped storage issue

  14. #64
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    please sir, try with correct hid patch
    also what about https://github.com/kimocoder/qualcom...tor_mode.patch

  15. #65
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Quote Originally Posted by rootboy01 View Post
    please sir, try with correct hid patch
    also what about https://github.com/kimocoder/qualcom...tor_mode.patch
    Working on it:

    https://forum.xda-developers.com/z5-...ernel-t4094295

  16. #66
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    thanks sir good idea
    why you patched z5c's hid using angler's patch?
    its %99 bootloop causing i think
    can you just undo hid patch and try again ?
    after your compile procces, i will change my Image.gz-dtb to your new (without hid patch) Image.gz-dtb. (in installer zip)

  17. #67
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    also can you add help for how to patch:https://github.com/kimocoder/qualcom...tor_mode.patch

  18. #68
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Quote Originally Posted by rootboy01 View Post
    thanks sir good idea
    why you patched z5c's hid using angler's patch?
    Why not? Angler is the name I gave it after I made it apply succesfully on Angler. It's just a name.

    Quote Originally Posted by rootboy01 View Post
    its %99 bootloop causing i think
    can you just undo hid patch and try again ?
    I thought you had done that already. Didn't you say that was the cause of the bootloop? Didn't you test it?
    Last edited by re4son; 4 Weeks Ago at 08:46.

  19. #69
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    when i . monstart-nh
    then
    nexutil, it says libdl.so.2 not found
    what cause this errors sir ?

  20. #70
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    when i first try to build image, i used only mac80211 patch and after install there isnt any bootloops sir.

  21. #71
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    why not? because angler and suzuran different devices you know. Sony and Huawei..

  22. #72
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Quote Originally Posted by rootboy01 View Post
    why not? because angler and suzuran different devices you know. Sony and Huawei..
    Device drivers and kernel patches do not discriminate. Neither should we when we write low level software.

    Just open the actual files I patched and learn what those changes do.

  23. #73
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    Device drivers and kernel patches do not discriminate. Neither should we when we write low level software.

    Just open the actual files I patched and learn what those changes do.
    ok sir regards sorry for noob
    can i ask a question.
    when you build for suzuran, are you.get any errors ?

  24. #74
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Nope. That's why I am 99% certain that the bootloop is not caused by the HID patch but another change I did.
    Fits the pattern

  25. #75
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    why i get after . monstart-nh and nexutil: libdl.so.2 not found

  26. #76
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Not sure. What have you done so far to troubleshoot it?

  27. #77
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    Not sure. What have you done so far to troubleshoot it?
    i take an ss:
    https://cdn-08.anonfile.com/B8J3h3w0...8642012487.png

  28. #78
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    By troubleshooting i meant what have you done to find the cause of the error?

  29. #79
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    i cant do nothing cause idk about C language
    i think issue is nexutil library.

  30. #80
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102

  31. #81
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Great opportunity to learn about C and to "Try Harder"

  32. #82
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    Great opportunity to learn about C and to "Try Harder"
    good advertisement sirr
    i know the basics of the C
    but idk where to start "android kernel hacking"
    if you succesfully buid new nexutil library, i promise to you i will be C master

  33. #83
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    I don't have to build a new library. You will understand that when you continue with your troubleshooting.

  34. #84
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    okey sir i will try thanks
    i understand what you mean.
    you did your best, now it's mine

  35. #85
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    @re4son sir i fixed missing lib file errors, thanks
    so just copied not found libs in /usr/lib/aarch64-linux-gnu to /system/lib64 and done.

    but after ' . monstart-nh ' and ' nexutil ',
    i got;

    nexutil: Segmentation fault

    help mehh

  36. #86
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Quote Originally Posted by rootboy01 View Post
    help mehh
    What have you done so far to troubleshoot this message?

  37. #87
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    What have you done so far to troubleshoot this message?
    searched in google, but no luck..
    If i ask you, then there is luck

  38. #88
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    also i press:

    cd /system/xbin
    gdb ./nexutil
    run
    (no any errors)
    bt
    (no stack)

    and tried for kalilibnexmon.so but there isnt any errors.

  39. #89
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    why did you copy files from "/usr/lib/aarch64-linux-gnu" to "/system/lib64"?

  40. #90
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    cause missing lib files (e.g libdl.so.2 not found) in usr lib aarc64- folder.
    i copied to kalilibnexmon's directory and it worked but now there is segfault

  41. #91
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    I see. What is the purpose of "/usr/lib/aarch64-linux-gnu"? And what is the purpose of "/system/lib64"?

  42. #92
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    sir really is it neccesary for fixing this error ?

  43. #93
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    Yes. If you want to fix the error then I suppose it is.

  44. #94
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    what am i must do sir, say it regularly please

  45. #95
    Join Date
    2015-Nov
    Location
    Australia
    Posts
    433
    I think you just have to try harder

  46. #96
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    ooww here we go again..
    please sir

  47. #97
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    Quote Originally Posted by re4son View Post
    I think you just have to try harder
    oww i think i found.
    i must move libnexmon files to /usr/lib right ?

  48. #98
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    sir i am not developer . you are project owner of nethunter, so why you dont want help ? its crazy

  49. #99
    Join Date
    2020-Mar
    Location
    Turkey, İstanbul
    Posts
    102
    dear @re4son please remove suzuran image in devices list.
    if some suzuran users build nh installer zip for suzuran, users will shock for bricked device. in this world, i am not alone of using suzuran device.
    remove kernel image sir..

  50. #100
    Join Date
    2020-May
    Posts
    1
    master @rootboy01 how is the nexmon z5 compact project going? I really hope to use it

Similar Threads

  1. Need Guide For NexMon Patch
    By rootboy01 in forum NetHunter General Questions
    Replies: 0
    Last Post: 2020-04-17, 20:45
  2. NexMon WRONG ELFCLASS32 !
    By rootboy01 in forum NetHunter Suggestions
    Replies: 0
    Last Post: 2020-04-16, 23:36
  3. adding nexmon to nethunter
    By rootboy01 in forum NetHunter General Questions
    Replies: 0
    Last Post: 2020-03-29, 22:14
  4. Error building rpi3-nexmon.sh
    By ajlennon in forum ARM Archive
    Replies: 1
    Last Post: 2019-01-17, 18:17
  5. Replies: 5
    Last Post: 2017-10-08, 15:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •