Hi everyone,

OS version: Linux Kali 5.4.0-kali4-amd64 #1 SMP Debian 5.4.19-1kali1 (2020-02-17) x86_64 GNU/Linux

I have an issue with SSH on my Kali machine.

when i press: # ssh Y@X.X.X.X , nothing happens. for exmaple:
root@Kali:~# ssh roi@

root@Kali:~# service sshd status

root@Kali:# ssh -i id_rsa webadmin@

When i check the service if it is up or down i see the following:
root@Kali:~# service --status-all
[ + ] ssh
[ + ] sshguard
[ - ] sslh
[ + ] stunnel4

i also tried to edit the /etc/ssh/sshd_config:
#LoginGraceTime 2m
#PermitRootLogin yes
# StrictModes yes
#MaxAuthTries 6
#MaxSession 10

i checked in the /var/log/auth.log:
sshd[6447]: Server listening on port 22.
sshd[6447]: Server listening on :: port 22
sshd[6447]: Received signal 15; terminating

so the services are up, the root can run SSH, everything seems to be ok but when i run the #ssh command, as you can see.. nothing happens.
i am not sure if the "signal 15" is the issue, but something make the SSH command to not work properly.

i tried to uninstall and install again, tried update, upgrade as well.. nothing help to resolve the issue, so i am not sure what am i missing here.

any ideas?
please assist me, i am desperate