Results 1 to 4 of 4

Thread: Trouble with dependancies: libpango1.0-0 and WingIDE

  1. #1
    Join Date
    2020-Apr
    Posts
    1

    Trouble with dependancies: libpango1.0-0 and WingIDE

    (New to linux, so please educate me where needed)

    Ultimately trying to get Wing IDE 6.x installed. After grabbing the package and attempting to install, I get the following:

    Code:
    user@kali:~/Downloads$ sudo dpkg -i wingide6_6.1.5-1_amd64.deb 
    (Reading database ... 287811 files and directories currently installed.)
    Preparing to unpack wingide6_6.1.5-1_amd64.deb ...
    Unpacking wingide6 (6.1.5-1) over (6.1.5-1) ...
    dpkg: dependency problems prevent configuration of wingide6:
     wingide6 depends on libpango1.0-0 (>= 1.18.0); however:
      Package libpango1.0-0 is not installed.
    
    dpkg: error processing package wingide6 (--install):
     dependency problems - leaving unconfigured
    Processing triggers for kali-menu (2020.2.0) ...
    Errors were encountered while processing:
     wingide6
    So I see its telling me that libpango1.0-0 isn't installed. Got it. So I try to install it with the following:
    Code:
    user@kali:~/Downloads$ sudo apt-get install libpango-1.0-0
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libpango-1.0-0 is already the newest version (1.44.7-3).
    libpango-1.0-0 set to manually installed.
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     wingide6 : Depends: libpango1.0-0 (>= 1.18.0) but it is not installable
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    To check if libpango is available, did the following:
    Code:
    user@kali:~/Downloads$ apt-cache policy libpango*
    libpango1.0-0:
      Installed: (none)
      Candidate: (none)
      Version table:
    Also did this, with no changes:
    Code:
    user@kali:~/Downloads$ sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following package was automatically installed and is no longer required:
      libfuse3-3
    Use 'sudo apt autoremove' to remove it.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Can someone educate me on how I would go about installing libpango1.0-0, in order to install my copy of Wing?

    Thank you for your time, Kali community!

  2. #2
    Join Date
    2020-May
    Posts
    2
    Sorry I can't help with a solution, but I am suffering from the same issue with libpango1.0-0 when trying to install ANYDESK .

    Any help would be appreciated.

  3. #3
    Join Date
    2020-May
    Posts
    1
    I faced this issue with anydesk. and got a solution.U don't have to install libpango. Just skip the dependency type "sudo dpkg -i --force-depends wingide6_6.1.5-1_amd64.deb" . Maybe it can solve ur problem. I Don't know why libpango is removed though. Noob user here

  4. #4
    Join Date
    2020-May
    Posts
    2
    Thanks for the response, sorry for the late reply had some login issues. Obviously I am more of a noob than you!!!!! .... where in the install process is this command typed please?


Similar Threads

  1. Trouble with nodejs
    By tommyy in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2015-09-23, 21:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •