Results 1 to 6 of 6

Thread: Kali 2020.1b dual boot windows 10 HP notebook rtl8188ee wifi connected no internet

  1. #1
    Join Date

    (Semi SOLVED HELP)-Kali 2020.1 dual boot windows 10 HP notebook rtl8188ee wifi connected no internet

    Edit: Im editing this post because I need some serious help from someone who actually knows what there doing because i know what ive done wrong. Im putting recent updates on last post.

    Hey guys. First off want to say glad to be apart of the community and try not to rip me to hard.

    Ive been dipping my foot in the world of internet security. Mostly as a hobby and curiosity. Ive been having an issue with my internet. After a couple days of trouble shooting to the best of my abilities and reading a bunch i think i might have found the problem but was wanting some feedback because ill be honest, kali is very hard to learn as a beginner.

    Ok so idk where to start but I try. I downloaded kali 2020.1b live on usb and played around a bit. First thing I did was use airmon-ng to go into monitor mode and detect some wifi connections in the area and a few other harmless things. I didnt know what i was doing so basically stopped there. Had no issues going back into managed mode.

    Also I didnt install with mirrors so next thing I looked into was adding repositories to update kali. I could see all wifi connections and connected to mine. This is where things fell apart. I opened browser and tried to load up kali docs but didn't have internet even though i was connected. So I tried to trouble shoot and read a lot hoping I didnt screw anything up.

    Ok let me give a little more info so you can understand why I was thinking how i was and what I did... Dont judge me. I like to play fornite but the neighbors who I share wifi with, they don't pay for it, free loaders... Are always connected running roku and 5 other things 24/7. So I used my phone and fing app to see what ip they were on and copied it using static ip to block there devices using post internet, arp spoofing/poisioning I think, I know I know, selfish me. But that quickly became a pain after they realized they could disconnect and get a new ip via dhcp protocol. And I only had so many devices for each one they had. Ok so what I noticed was that I think the dhcp logs got jackd up or something bc sometimes I noticed it would assign someone to my ip or visa versa without using static ip although not often. I didnt have access to admin PW to mac block btw. Ok so keep this in mind.

    Well ive used kali in the past same network same computer same everything but only live usb with persistence. At first everything seemed to work fine. I noticed it would assign random MAC therefor letting dhcp assign safe ip different from host ip and everyone else. But I never really used internet and would mostly stay offline learning commands on kali basics. So then I decided to try to do dual boot with my laptap. The hp notebook with rtl8188ee nic. And after careful reading managed to set it up with few hiccups with BIOS I managed to work out. Eufi btw.

    Cant remember any specific order but first I would ifconfig and noticed I was gettong assigned same ip as host. But I was using mac changer on host and kali was showing permant mac. So that confuses me as to why dhcp was giving us same ip. And it wasnt random changing MAC like before. So I then used macchanger -a wlan0 after bringing wlan0 down and then back up. Mac changed but up ip did not. Which I found odd. So then I used internet properties of GUI to setup static ip after going offline which worked. But still didnt have internet. I also noticed there were a lot of dropped RX packets. I tried to ping and then This is were I run into something I havnt read about at all anywhere.

    What was happening was i would get maybe 1 or most 2 successful pings and the rest would not work out of around 10. For both. 90-80 percent dropped packets. I would try to change mac. Use dhcp change hostname every single time my ling results would be the same. After every change the original 1 or 2 initial packets would get threw and then nothing. I thought there was a conflict in IP with dhcp not working but was really confused how that could be. Also while check cat /etc/resolv.conf I woild notice sometimes I would get a dns ip of my server or dns of google. Bc I would set up dns and not trying different things. Mostly I would not get anything though win usong that comand. I also tried to replace false with true on my interface file. That didnt seem to affect anything. I finally added and on the /etc/resolv.cong file and used (forget the command) to make it unchangeable. That didnt seem to make a difference other than I could always get that file to come up now.

    I would also go back into windows 10 1909 and my internet would work. So I figured something had to be wrong with my network setting.

    So after all that I tried to add repositories to my sources.list file and would I use apt-get update it would say 1hour to load then load after 15 seconds and say could not be reached or unable to resolve host. Which i read could be a lot of stuff. So at this point I wasn't sure if my network files were jacked or my dhcp on server was faulty. But only had issues on kali dual boot. Btw wiped my usb kali live and installed kali install to install my dual boot so couldnt use kali love from USB to try that. But what I ended up doing was wiping kali install and making kali live usb and reinstalled kali using that. Before i did though i tried connecting to internet with everything default on kali live boot from usb with same ping and internet symptoms. 1 or 2 first pings good then drop everything else. So after reinstall left everything default and same thing.

    So couple other things I did. I noticed when editing internet connection threw GUI I see that eth0 shared same MAC and wlan0 and if I changed wlan0, eth0 would still have orginal MAC so I thought somehow that was the issue and removed it using - option on edit connection. That had no effect. I also tried to do ifconfig eth0 down. No effect on connect. So I then read about changing network-manager to use up down protocol adding lines from kali docs configuring network where I would add lines to interfaces file I think where it had auto lo lines. I left the auto lo lines there and just added the ones from kali suggestion. Sry not more specific in going from memory. But I didnt know of should put my network acuatal name and wpa actually password so what but that had No effect. So I just edited everything back to orginal as not to mess up my files.

    Other thing I tried was this command

    Systemctl enable systemd-networkd
    Systemctl enable systemd-resolved
    Systemctl start systemd-networkd
    Systemctl start systemd-resolved
    ln -sf /run/systemd/resolve/resolv.conf /etc/resolv.conf

    And that last line did not work. I forget the error that came up. I also wasnt sure if that very first letter was a L but im pretty sure it was after researching this command which switched the network manager I believe. So that did not work. Idk what i did wrong.

    Other things I noticed. When running dmesg I saw a bunch of
    rtlwifi: AP off, try to reconnect now.
    Followed by 6 lines starting with wlan0 ending with authentication. I think what was happening is it was trying to connect to server and would connect then disconnect. And repeat. I notived the ip was my servers IP kt was authenticating with. I thought maybe it was connecting to IPv6 and then messing up again. Idk. I also noticed it couldnt get an ipv4 only connection looking at ifconfig. I also tryed to disable that in setting thinking spoofing my MAC wasnt good enough to get new ip threw dhcp if i had same ipv6 which i dont think was the case considering my mac was differnet but I was trying everything.

    Everything I did all came to same exact thing with internet not loading pages and ping systems the same.

    Another thing I noticed was when using
    nmcli -d
    everything looked correct except I can see
    p2p-dev-wlan0. Wi-Fi-p2p disconnected
    In red. Idk what that is. I was assuming someone connecting to me?

    Finally went into airmon-ng to look at wifi card (rtl8188ee) and noticed it said k for driver which said it was kali driver but NA for firmware. So im thinking the firmware needs to be updated maybe. I then went to
    modinfo rtl8188ee
    and it shows
    firmware. rtlwifi/rtl8188efw.bin

    So I'm.confused as to if I have good firmware or not. I did try to read about issues aboit rtl8188ee and noticed there were a lot of firmware issues. Some fixed threw writing commands/ blacklisting or just updating.

    So I thought id come here for advice. Sorry for being so long and not that detailed. I was looking how to add the files people post but couldn't find out and didnt know how to save the commands on kali and was just to much. Sorry. But what I plan on doing is going to differnet network using ethernet to connect to wifi to update my kali. Im thinking hopefully the firmware and whatever else I may need is in my updates im missing from install. And going from there maybe finding the right packages I need from git . but I figured maybe one of you more experienced guys might know whats going on and save me some time.

    Couple questions. I noticed I dont have the icon list to left that mosy people have on home page. I think this is gnome which is can get with update/install I read i believe.

    And is there a difference in install uaing kali live iso vs kali install? I read you get more options using kali install. If all else fails im going to reinstall kali conneceted to Ethernet to see if that helps.

    Once again very sorry for the long post, lack of detailed info and not posting pictures/scripts. This is my first post and ive been spending all my time reading about my issues which like I said, ive never read aboit the ping issues im getting. Please lmk of you need any other information in more detail or whatever i can do to help you help me. Yes i Will look into Ubuntu or parrot. Thanks guys!!!
    Last edited by Noobs420; 2020-05-14 at 13:07. Reason: Semi solved NEED help PLEASE

  2. #2
    Join Date
    Update: learned a lot more since last post. After reading it I can understand how it would be hard to help me. Let me go over what has happened and what I know now.

    Well after playing around with settings as mentioned above I know my setting were jacked. But I went to different network and connected to eth0. Everything worked fine. Didnt even try wifi first which I should have. But I did end up updating kali after updating sources.list. that seemed to help with drivers and firmware. Then I connected to wifi and everything worked perfectly. Although my mac address was staying the same.

    Then when I got back to home wifi still sameee thing. I could connect to wifi but no internet. So after searching I found out I had both network-manager and systemd-networkd enabled from previous post commands. I disabled networkd. Restarted computer and made sure it didnt start again.

    I checked threw all my files on kali live usb to make sure everything on kali live install was correct. It was. I notice I get a bunch of ip address connecetions. I think there might be a dns problem or router is messed up or someone may have conneceted another router on the network dropping my ping. I'm but something is weirs about this wifi here.

    I went to my friends and tried his wifi. Prefect worked. Checked the resolv.xonf file and had two dns there. My servwr ip and ipv6 address...probably server too...Tried ethernet and it worked on kail browser. So I tried to reinstall kali for 3rd time but got stuck on configuring network using eth0. I noticed it wouod load up 1pv6 and just like freeze.. I shut and reatarted like 3 times before giving up.

    I also noticed I dont think i have gnome installed for whatever reason but had XFCE lightdm by default bc i installed offline. Thats why i was trying to reinstall online.

    So at this point I delete kali from hard drive partition ezcept grub and in going to try to reinstall it on different Ethernet connection.. Then disable ipv6. Then go from there. If that dont work in going to check i have dns connections that are good. I just dont understand how 1 ping works and the rest drop. Every once in a while ill get 1 or w good pings...5 drops..and maybe 1 more comes in.

    And I dont understand why it mostly works everywhere else.

    After I reinstall it and if it don't work. Im going to change network-managers. I read about systemd-networkd and nicd I believe... It just sucks having to relearn different network manager again but it will be helpfull in understand how internet works.

    I know I need to find route to see where my pings going to maybe trouble shoot this but im just mentally exhausted right now after a week of reading and trouble shooting ... After my next online install I will be sure to take pictures of EVERYTHING including routes, drivers, firmware, dmesg, ECT.

    I know understanding and being able to troubleshoot internet connect is #1 thing to understanding internet secuity and should be something i should be able to do on my own. Im sure i could figure it out eventually but really does help being on these forums.

    Also its hard to because it seemes a lot of changed threw kali updates and I think kali docs is out of date on somethings and with there being mutliple network-manager choices complicates things nad.

    Thanks for reading. Hopefully I get this figured out soon and ill poat agian with more detailed pictures. Im going to try to post some pictures I took of me trouble shooting before I deleted kali. So keep in mind. These are in no order and I may have changed setting inbetween pictures. Morw of a test post. My next post will be highly detailed including pictures.
    Still cant see how to put pictures.. Maybe because I'm on mobile. I will use computer for next post.
    Thanks again guys.

  3. #3
    Join Date
    Hey guys. Sorry for lack of pictures. Problem is I'm on a cell phone. I click on website mode and can now clearly see the option to add files but it will not upload a picture for me. Im going to have to take pictures with my phone. Then upload them to computer and write a post from there. Ok let's get started.

    Well I deleted my kali install partition, made a new usb using kali live iso with persistence so I could play around with setting. Im pretty sure it's my wifi here. I literally tried everything with network manager. Although i will admit I don't understand everything fully but im learning a lot. I guess this is a good thing. I noticed when leaving everything to default I get MAC changer automatically which is sopossed to happen threw ifupdown protocol i believe. I can't connect to internet but still no internet. And still getting 3 ipv6 addresses. So now i was determined to get rid of ipv6.

    First I tried to disable threw GUI under edit connection and disabling ipv6 connection. Of course restarting network manager everytime and I would even delete the saved connection completely on case pre determined setting were being used by default. Did not work.

    Then I tried editing the /etc/sysctl.conf file to include the 3 lines you can find online starting with net.ipv6.conf. (All/default/lo).disable_ipv6=1. Now this seemed to work if only the very first time very breifly. But when using kali live iso boot from usb I could not add these to that file or modify the grub file which I dont even think is there the same way as an install. The files locked and could not unlock using properties or Chloe 777/a+wr (I forget exavt command), So I just installed it to my computer at this point and was able to add those commands to my /etc/sysctl.conf file. Like I said only breifly but did noy work.

    I didnt want to modify grub bc I just want to be able to keep track of all changes but thats exactly what I did. By adding the commands ipv6.disable=1 to the last 2 lines you can find by googling. Then updating grub. Now this finally did work. No more ipv6. But info think it came back once more and what i did on my own without hearing about it was add # to the bottom 3 ipv6 address on the /etc/hosts file. So after a reboot and 4 different trys editing 3 different files it finally FINALLYYYYY got ipv6 to go away.

    Here what happened. MAC address is no longer random as before. Buttttt I could get a website to load now. I was so happy to see that kali docs page come up even though it took 30 seconds. Buttt my excitement quickly faded.

    What is happening is I open my wifi connection by clicking connection information threw GUI and my speed starts at 72kbs then jumps to 1mbs and then back down to 72kbs and disconnects then comes back on and just cycles the exact same way exact same speeds. When its at 72kbs the website loads really slow and then once it goes to 1mbs it loads up then drops connection. I tried to find any time out connections but could not find any although I will admit I did not look very hard.

    So what ive noticed. Threw searching google and these very same forums ive found multi cases of the same sympt2 and infect one guy had the EXACT same symptoms including dmesg and journal errors exactly...

    These other people and I have 3 things in common. We all had rtl8*** wifi cards. My is rtl8188.
    Mostly all had dual boot. Im on hp notebook.
    And all running windows 10. Im running windows 10 1909 which I hate.

    What confuses me is ive had great connections on 2 other routers both wifi and ethernet. So maybe theres another common feature with us. No one ever mentions the router they use. So if anyone with this problem is reading this with same problems and above 3 common features let me know. In using ATT Uverse router. Maybe its these routers.

    Im going to buy a wifi adapter. I needed one anyways to connect to 5ghz ... Thanks for reading guys. I know this has big long with no real progress except I gave that ipv6 what it deserved and I felt good if only for 30 seconds. My next jab at this while I wait for my adapter to come in is to mess around with systemd-networkd and or in init.d

    One other thing, could something else be the issue like maybe cron? Man I'm way to noob to be dealing with this. Ive litterally spent about 70 hours plus reading and learning about network manager and semi related issues ... I just want my life back haha.

  4. #4
    Join Date
    i noticed my lo ip is showing at ifconfig but in a host file i saw it said it was so idk if that matters. it worked at the other wifi networks i tried so i didnt bother with it,. And i tried to add my wlan0 to my interfaces file but it didnt seem to make any difference and it worked without it in there as well. lets try these pictures.

  5. #5
    Join Date
    Ok guys. I took a breather from configuring the whole Kali network thing....and that when it hit me. straight horror. I know what i did. Ill keep it short at first and then go into detail.

    Ok i dont know exactly what is wrong but i know im on the right track for sureeeee. The problem is im screwing up DHCP protcol/logs on the router. Heres how I know and how it hit me.

    Well after giving up on configuring kali I started to just switch my focus on something other than setting up Network Manager protocol. There was nothing wrong with it. I was the problem. Soo it all started like this. I wanted to download kali but wanted to stay annoymous to ISP and anyone who might be checking the logs or spying on what porn sites im looking at or the Linux distros im downloading. I know about VPN and DNS but im broke and wasnt that worried about security because like I said before Im not breaking the law and whos looking....this was definitally an accident based on ignorance. First thing I did was learn about MAC address... Never even knew about DNS. All I knew was that when I signed on to the network, my MAC address and hostname was there with an IP. Well I couldnt change IP so I downloaded titanium MAC changer, changed my MAC address and then changed my host name, therefor changing my IP. All was good. But remember dont leave a pattern so keep doing it randomly. one a day, twice a day, whatever. Well it didnt happen that smoothly. And im sure setting up static IP to follow the "free loading" neighbors "(arp spoofing/posioning) wasnt doing any good either. Im talking like 100+ times in a day. Im laughing writing this right now...I know I shouldnt be... I know.

    Well that didnt really effect me although i did notice at the time my youtube/facebook would work but no internet. I later found out it was because those apps supported IPV6 and that was fine with me although I didnt really understand any of that. Then came along kali.

    Somehow threw playing around with kali settings and changing my HOST'S computer (windows 10 1909) MAC and changing the hostname I must have forgotten to add a hostname. But I didnt realize it because on the network I would see the computer name or NetBIOS name...wanna hear something funny. Guess what I changed it to... unknown*random_numbers/letters* such as "unknown123d4632. Why did I do this? Because i thought it would blend it with all the other unknown**** host names i was seeing on the network. HAHAHAH So then I changed my PS4 and both phones AND my kali hostname to the same thing thinking I would blend in. HAHAHAHA ***...

    So once I started playing around with kali and jacking up those setting because I didnt know about systmctl and never read/understand the policy section in the kali docs and/or configuring the network I must have jacked up Network_Manager which is why I was seeing my orginal MAC address in kali or because of fast start up/pressing shutdown instead of restart to get into kali.Then One long day of playing around with kali settings I realized my internet wasnt working when going back into Windows and I had to change my MAC address back to default to get it work. Didnt understand why, still dont completely. So there was that anddd theres more.

    So I just barely got this computer from my sister who never used it in like 4 years and I wasnt really using computers either for much other than Microsoft word for school here and there... I decided it would be a great idea to update everything And i dove right in learning about drivers and disbaling certain background apps, turning off/changing power setting, removing bloatware... Problem was I updated Windows 7 to windows 10 1909 and and then changed all the setting. I noticed right away my internet was slower but after turning off power saving and messing with the advanced setting on my wifi adapter and changing drivers a couple times... it seemed to be a little better. And since I wasnt looking at porn or downloading kali didnt even think about mac changer or hostname.

    So after getting the computer running better and reading that the new windows 10 update sucked worse than antything before and people were having the same issues, I chalked it up to that. But I did notice I was getting IPV6 address.

    it hit me when i was at my friends house trying his internet and i did cat /ect/resolv.conf i noticed i was getting an ipv6 dns from server which i never got before and I thought was the problem. And thats how I started to slowly understand what i had done. After reachering about DNS and hostname and seeing NetBios name in windows setting. I finally figured out and got on the right google searches to lead me to understand that changing MAC address while not having a hostname and then changing hostnames and trying to change MAC and then delelting Kali and reinstalling 3 different times with different hostnames while still sharing same mac address with HOST computer MUST be the problem. And another thing was in my wifi adapter advanced setting, it was put to power down when not is use mode which im sure didnt help anything. It must have changed when i reinstalled the adapter or something. So this whole time my internet was slow was probably because I jacked with all these setting and windows 10 does just suck. I also learned that I may off to turn off fast boot (which it was) and shut down instead of restart to go into kali. I read that kali has an issue sometimes with giving my adapters the drivers it needs without shutting down before going into Kali. This was another clue.

    I looked on the setting og the router. There is currently 20 IP addresses logged into the system. Most of them are not mine. I havnt really been changing MAC or hostnames much last week because ive been researching this. There is one ip address that is active that has a MAC of 00:00:00:00:00:00 that is using 0 internet. idk why its on there though im sure its something I did. Theres no data going threw it and when I turn off my computer with kali and windows its still on there. IDK if an IPV6 is using that or what. I dont understand it. SO I NEED SOME HELP PLEASSSEEEEEE

    First thing I did was change the power down mode on windows for wifi adapter and turned disenable my eth0 because i wasnt using it and i read that there could be an issue with the way they are numbered although i dont think this was my problem but just to be safe. Then I gave myself a new hostname, but ive got to change it again becasue I put unknown420247 haha and maybe put iphone or something because i see a lot of those. In the past I would put buiness name in eye sight of my house, maybe ill do that. Once I got a new hostname I made sure to erase any network setting I had and shut down my computer. I came back into windows and changed my MAC. Then I signed onto the network and BAMMMM new IP4 address and much more stable internet connection. Now I have to fix everything else which is where I need yalls help. I got an idea. kinda

    What im thinking about doing is deleting kali, changing back my IPV6 setting to default on windows, and then changing my hostname to something that fits in better and then shutting down, getting new MAC. That will leave my host computer good to go. But there are a couple things im not sure about that I would like some insight on. AND PLEASE if you dont know what your doing dont play the guessing game. Thats how I got into this mess to begin with. I should have just read the kail docs/training and did it on my own. I would have been MUCHHHH better off which is what I plan on doing this time. Im really surprised how many people dont actually understand Network-Setting nearly enough giving advice left and right on here and on youtube. Google has been the most realiable but you have to know what your doing just a little bit to understand how to follow the good instructions or youll get lost not knowing theres several different network working mangers and so many different ways of doing things. Like using systemctl to override the built in security protocols. So someone please save my ***. Almost done. Just a couple more things that im worried about.

    Im pretty sure the DHCP will clear up on it own once I stop confusing it. Im pretty sure there is a command to let me know the lease time that gets set up for each IP address so thats just a matter of waiting. But one thing that confused and kinda had me worried was even though I have my Eth0 disabled on my host windows computer it was still showing up on kali. Im thinking after probably shutting down from windows, kali was able to just assign it its own drivers and put it on the ifconfig as before when i would do restart windows, windows would hold onto it and that might be why my MAC wouldnt change sometimes. Depended on if I restarted or shut down.

    and how can i fix the devices that are holding onto IPV6 address without waiting out the DHCP lease time. Im thinking of comming off the network. Changing hostname and setting up static IP. Then hopefully once a connection is established and I can then come off the network and put it back into DHCP and get the same IP not needing IPV6. I think I got IPV6 on some things like my ps4 was because i used the same hostname as other devices like just plain unknown for multiple devices although im not 100percent on that. Or maybe some devices just grab IPV6 by default. IDK...

    So please kali forums community. This has been a big learning experience im just glad i didnt premenantly (hopefully) screw anything up and realized my and shitty *** windows errors. Please help me and ill never everrrr use arp spoof to kick off the neighbors. As always thank you NOOBS420

    ***So in conclusion if your internet connects but is unstable then you probably have to either check your power management setting in windows associated to your WiFi card found by typing device manager in search bar and then right clicking over the WiFi adapter to go into properties and look for power saving/sleep setting in there (use google to find wifi power settings, there are a couple) and if your running the new windows 10 1909 update and have to change your drivers to resolve bad internet connection make sure your power setting do not get converted back to default. And also make sure your fast boot is turned off (use google to find this). and when you switch from windows 10 to kali make sure you shut down instead of restarting.
    And I doubt anyone will do this but if for some reason you are changing your computer name in windows and spoofing MAC, make sure you are not leaving your computer name blank while changing MAC address. lol. Somehow by disabling ipv6 this seemed to help the problem buy only barely and justtt barely. im thinking by disabling ipv6 the router was able to go threw all the different IPV4 address with MAC/no host name and maybe find me MAYBE. But then got timed out eventually. With ipv6 enabled this would be harder with many many address to try...but then again its just a guess. I know tracing the route would have helped me solve this but im a complete noob and learning as I go. IF someone who knows about DHCP/DNS protocol in depth can you please bring verification/or input!
    Hopefully this might help some people.

    I have no confirmed this yet as i need to reinstall kali and clear the DHCP logs if possible just to be safe and will leave update once I do.
    Last edited by Noobs420; 2020-05-14 at 13:08.

  6. #6
    Join Date
    Ok. Well I fixed all the hostnames. I set my ps4 and phone to static ip taking each others old up address. Then put it back on dhcp. The ps4 kept its static ip address after putting ot back to dhcp but my cell phone used another ip it had already. Both devices got ipv6 addresses.

    So kali hasn't been installed since last update. I deleted the partitions to it. Then I got hotspot for my phone to connect my laptop to it while I mess with kali. Well my computer would not connect to my hotspot. So i put all my ipv6 setting on Windows back to default except I added a hkey in Windows to prefer ipv4... Still got ipv6 address.. I don't understand this but it worked after that. Im going to have to research more about ipv4 and ipv6.

    So then I installed kali again while connected to my mobile hotspot. It took a few trys and about 5 hours. During the first try I left everything default which was XFCE and it had default tools and top 10 tools checked. Went to next step which was install software... Had about 1970ish files and it got stuck at 1165. Looked at hotspot on my phone and noticed kali dropped the connection. That took about 2 hours. So I turned off my computer and deleted and reinstalled kali but unclicked top 10 tools. This time it dropped the connection after around 1250 files. But I let it go and it still loaded the rest not connected to hotspot after an hour or so. After all the files loaded it said it failed. It took me back to the kali menu and It gave me the option to install again which I tried.. This time it zoomed threw and installed all the files fine. Kali loaded up and My mobile hotspot connected to kali. It worked fine. But my MAC address for my wlan and eth was not spoofed. But websites loaded, ping came back good. Also got an ipv6 address.

    Then i tried the original problem wifi and it also worked fine. Got a ipv6 address but ping worked and websites. I did notice about 150 dropped packets right away though before even doing anything. Idk why Didn't even try to figure it out. Everything worked.

    So this has been extremely weird for me. I guess it would have helped if my host name on windows wasn't blank I guess but still.

    Only thing I noticed now besides the dropped packets was my MAC is not being randomly generated. Im going to have to really study how network manager works or just switch network managers. I thought NM was supposed to generate random MAC addresses which I've seen it do before.

    Well everything is back to default and updated and have internet access on kali. I'll update once i figure out this MAC and dropped packets.... And I know I could try macchanger and use the GUI to change MAC but I dont want to do that if it should just be working. I really want to understand how everything works and what i need to do to configure this the right way.

    Thanks for reading such a long post. Hopefully it helps some people and if you take anything from this.... Don't be a noob trying things you don't understand from youtube videos and random online post
    .. And if you change a setting better remember what you change. Lol.

Similar Threads

  1. Dual Boot Windows 10 with Kali 2020.4 Installer Issues
    By ChopShoey in forum Installing Archive
    Replies: 0
    Last Post: 2021-01-12, 19:08
  2. Windows 10 doesn't boot in dual boot with Kali Linux 2020.2
    By shadefade in forum General Archive
    Replies: 0
    Last Post: 2020-08-11, 15:02

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts