Hello everyone.

Im a noob with linux and i installed kali from the live cd and have been running a localhost webserver just to learn the commands. I tried running the sudo apt-get update so that i could install the gdebi package but i typed sudo apt-get upgrade and it updated all installed packages. I now went through a list of actions to test my knowledge and i tried starting the mysql service which worked and i was able to open the database. I tried stopping the service but it was still running. Calling systemctl stop mysql had no effect because i could still search the database. Calling systemctl status mysql.service to see what was going on showed a warning that mysql.service failed with exit code.

I am assuming this is as a result that mysql was updated and installed over the old version. I tried checking the log file in /var/log/mysql but the log was empty. Is there a recommended method of getting to the bottom of the issue or is removing the package and reinstalling it required.