Results 1 to 2 of 2

Thread: Ralink RT3070 not working with Kali in VirtualBox Fix

  1. #1
    Join Date

    Ralink RT3070 not working with Kali in VirtualBox Fix

    Hello all, I?m new to this forum. I was having a lot of issues getting my RT3070 to work in Kali Linux on a VirtualBox , MacOS. It would always say ?Not Connected ? when trying to connect via WiFi, while the ?Wired? connection worked fine. If you typed #ifconfig it wouldn?t list wlan0 at all. However, booting from a live USB I realized it worked fine, with no driver install necessary, just plug and play.

    I tried every possible fix under the sun, and in doing so it made me extremely familiar with both VirtualBox and Linux command line/O/S.
    I tried network-manager restarts, putting wlan0 up and down, trying to install drivers , etc.. everything. Still no luck.

    The solution is so easy it?s a joke. When you plug in the USB adapter, it defaults to USB 2.0 in the VirtualBox settings > Devices > Ports menu. Simply change this to USB 3.0 , and your issue will be fixed. You might need a reboot.

    You don?t have to do anything to the host (MacOS) , no need to install drivers anywhere, simply change this setting and your USB ALFA RT3070 will function in Kali Linux within the VirtualBox.

    There is a lot of confusion over this topic, i hope this helps. Pls let me know if it does by responding to this post!

  2. #2
    Join Date
    Hey there!

    I've made an account just to thank you, buddy. I've been struggling with my Alfa awus036neh for a while now, and almost had given up after trying everything just like you did, up to the most obscure tutos out there. It didn't ring a bell when I saw USB 1.1 honestly, I just assumed what mattered was the firmware of the adapter, along with the host hardware, and that everything would work fine as is. I wouldn't have imagined the origin of these constant disconnections and unreliability of the NIC came from such a basic thing. Well, I've tried your solution after installing the latest VBox extension pack (in order for it to support USB 2 and 3, as it didn't display these options for me). And dang, now it works like a charm. It's a shame my TP-Link and awus036nha are on their way, hahah. But I guess it'll give me some more freedom of choice regarding the chipsets.

    So, thanks again, buddy, I wanted you to know you really helped me out, and that for some reason, I haven't seen this fix anywhere else. It'd be worth to spread the word because I'm pretty sure we're not the only ones.

    Have a wonderful day, you beautiful thing.

Similar Threads

  1. Driver for RALINK RT3070
    By Fielding in forum Installing Archive
    Replies: 13
    Last Post: 2017-04-12, 11:26
  2. Kali Linux in Android and Ralink Rt3070
    By Hav4k in forum TroubleShooting Archive
    Replies: 2
    Last Post: 2013-12-26, 15:20
  3. Replies: 2
    Last Post: 2013-12-16, 21:36
  4. Ralink RT3070/ALFA AWUS036NEH not recognized
    By n0name in forum ARM Archive
    Replies: 0
    Last Post: 2013-08-22, 13:25

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts