Results 1 to 1 of 1

Thread: problem after installing kali 2020.2 > error disk not found - grub rescue

  1. #1
    Join Date

    problem after installing kali 2020.2 > error disk not found - grub rescue


    Made differents install of Kali since several years on differents platforms and supports without problems...but had a problem this time

    A friend gave me an old laptop (2009 manufacture date), so the idea was to install Kali, to give it a second life.

    Made a bootable usb using win32diskimager, with kali-linux-2020.2-installer-i386.iso, fine.

    Got a little problem during the install ("starting up the partitioner" step, stuck at 45%)...tried several times, using differents usb keys --> problem resolved changing an option in bios:


    Re-tried installation, was successful after the change, reboots and then, this:


    Didin't had this problem on the differents install i've made before.

    So, itried searching on this forum and someone gave a solution through this link:
    But didin't works, as when i do ls, only (hd0) appeared (as shown on previous pic) and "insmod normal" gave me an error, whan i tried with only hd0 (error: unknown filesystem).

    Tried also to boot in rescue mode with my kali usb key, to update-grub and to grub-install /dev/sda, but nothing changed.

    The laptop is a Samsung NP-NC10, the HDD is an ATA Samsung 160go, HM160HI-(S1) (fully verified using hdd regenerator, no corrupted sectors on it) and the kali install is 2020.2 x86 (, using encryption.

    Thanks !
    Attached Images Attached Images

Similar Threads

  1. grub rescue : error :disk 'lvmid
    By Dr.BL@CKDeaTH in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2021-02-01, 22:17
  2. Replies: 16
    Last Post: 2020-09-22, 11:40
  3. Grub rescue: error disk not found
    By valarys in forum Installing Archive
    Replies: 0
    Last Post: 2020-08-19, 02:02
  4. Replies: 5
    Last Post: 2017-05-22, 17:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts