Results 1 to 5 of 5

Thread: Netgear A7000 Wifi Driver - How To Install?

  1. #1
    Join Date

    Netgear A7000 Wifi Driver - How To Install?

    I am somewhat new to Linux but have been able to get around using UBUNTU. I decided to more on to Kali. I am trying to use my wireless usb adapter Netgear A7000. I am trying to install the driver. I believe the following commands will get me there:
    sudo apt-get update
    sudo apt-get install git dkms
    git clone
    sudo dkms add ./rtl8814au
    sudo dkms build -m rtl8814au -v 4.3.21
    sudo dkms install -m rtl8814au -v 4.3.21

    The problem is when I enter the second line into the terminal window, I get the following error:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package dkms

    Any ideas why I cannot locate the package dkms?

    Thanks for any help.

  2. #2
    Join Date
    Make sure you added the Kali repositories to your Software and Updates list...

    In terminal do
    sudo apt-get update && sudo apt-get upgrade
    after do a sudo apt-get dist-upgrade

    and although that command worked fine for me, I'm not to sure why it didn't for you. Could be because you're running an older version distro of Kali, sudo apt-get dist-upgrade should upgrade that for you.

    Not that this should make a difference but you can try to install dkms exclusively:

    sudo apt-get install dkms

    I didn't have your issue but it could be because of the above mentioned issues. But the package definitely exists...
    Doing an "apt search dkms" shows

    With all that said, despite all of these commands executing with success for me, my NETGEAR A7000 is still not detected. However it did install drivers for my Realtek Integrated PCIE Wireless NIC, so at least there's that.

    If i successfully manage to install the drivers I'll reply to this thread again, however if you beat me to it please let me know how you did it

    Seems the only people that posted threads about installing the NETGEAR A7000 were those using Ubuntu.

  3. #3
    Join Date
    Make sure you put all the repositories in your Software and Updates settings (You don't need source code, but that's up to you)

    Officially supported
    DFSG-compatible Software...

    Check and reload cache

    Then do a "sudo apt-get update && sudo apt-get upgrade"

    once complete, do "sudo apt-get dist-upgrade -f"

    If any of your firmware is out of date, this should upgrade it as dist upgrade ensures you're using the latest distro and kernel image. And the top commands should ensure that all of the available kali repositories are there.

    once that's complete, reboot and then do "sudo apt-get install dkms"

    Should work then, I never had that issue but I have a strong inclination that's the cause of your issue.

    Despite this working for me the installation of the driver does not seem to work as despite all of the commands working fine because the device is not being detected by the system.

    I'll keep trying to get it installed and if I figure out how I'll reply to this thread but if I don't and you manage to install this on Kali please let me know as it seems the only people who created any threads about installing drivers for this device are Ubuntu users

  4. #4
    Join Date
    So I still can't install my Netgear A7000 wireless adapter but here is some additional information that maybe can help with finding the issue.

    When I type lsusb it doesn't complete after I plug in my adapter.

    Also the following error is received when I use modprobe

    modprobe -v 8814au.ko
    modprobe: FATAL: Module 8814au.ko not found in directory /lib/modules/5.5.0-kali2-amd64

    How do I troubleshoot this?

    The driver did build and install correctly. The driver is rtl8814-4.3.21.

    Thanks for your help.

  5. #5

    New driver can be found under aircrack-ng on gh

    Here is a driver that was created within the last month or so:

    Not sure how stable it is, as I have yet to test it. I tried the rtl8812/au aircrack driver (which used to also support 8814au) with fedora a few months ago and had to uninstall due to it crashing wayland periodically. Never investigated too deeply as to the root cause as didn't have the time. Hopefully this is no longer an issue.

Similar Threads

  1. New install: No wifi access for apt install <wifi driver>
    By sunfish in forum Installing Archive
    Replies: 0
    Last Post: 2020-03-13, 14:39
  2. Replies: 1
    Last Post: 2017-06-15, 11:45

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts