Results 1 to 5 of 5

Thread: Wrong keyboard layout at login

  1. #1

    Wrong keyboard layout at login

    Although I managed to login into my newly-installed Kali Linux as a VMware virtual machine image and change the keyboard layout correctly, this layout only works AFTER login ; the login window still only accepts "kqli" instead of "kali" as input from my Belgian keyboard... How to fix this annoyance?

  2. #2

    Fixing the keyboard permanently

    Quote Originally Posted by seriewoordenaar View Post
    Although I managed to login into my newly-installed Kali Linux as a VMware virtual machine image and change the keyboard layout correctly, this layout only works AFTER login ; the login window still only accepts "kqli" instead of "kali" as input from my Belgian keyboard... How to fix this annoyance?
    Hi,
    I don't know if you still have the issue, but each time I reinstall Kali Linux, it takes me 1 hour to set the keyboard in French. So, this tuto will be usefull at least for me in a few month
    In order to set the keyboard layout of your choice everywhere (login, console, any apps ...), even after a reboot, please enter this command listed below a in terminal :

    # Example with French keyboard

    # Pass the keyboard to AZERTY :
    $ setxkbmap fr

    # to make it permanent (not sure about the utility of the two first commands) :

    $ loadkeys fr
    $ loadkeys fr-pc
    $ dpkg-reconfigure keyboard-configuration

    Just follow the instruction by choosing a keyboard model, then choose "Other/Autre", and then choose the layout of your country.
    After the final "<Ok>", the wizard disappears and it's done. At the next reboot, the keyboard will remain in AZERTY.

    Hope it helps.
    Marcello

  3. #3
    Join Date
    2021-May
    Posts
    2
    Hi, i've got the same issue, i try to change the layout to DE-CH German - Switzerland (No dead Keys), so far the only way to do that that i came a cross is to create a custom kali live build.
    There is an older post in the Developer Archive about changing the region and keyboard layout for the custom build to spanish. https://forums.kali.org/showthread.php?28151-Building-a-custom-Kali-Live-CD-with-screen-reader-and-spanish-environment&highlight=custom+live+spanish

    But i to be honest this didn't help me to do the same for a custom Kali Live build with the newest version and the keyboard layout for german - swiss.
    So i was hopping maybe there is a pro in here that would be so kind to help us out and could explain to us how to create a custom build where the standard keyboard layout is Belgian for you and German - Switzerland in my case.

  4. #4
    Join Date
    2015-Sep
    Posts
    2
    Quote Originally Posted by mtopp View Post
    Hi, i've got the same issue, i try to change the layout to DE-CH German - Switzerland (No dead Keys), so far the only way to do that that i came a cross is to create a custom kali live build.
    There is an older post in the Developer Archive about changing the region and keyboard layout for the custom build to spanish. https://forums.kali.org/showthread.php?28151-Building-a-custom-Kali-Live-CD-with-screen-reader-and-spanish-environment&highlight=custom+live+spanish

    But i to be honest this didn't help me to do the same for a custom Kali Live build with the newest version and the keyboard layout for german - swiss.
    So i was hopping maybe there is a pro in here that would be so kind to help us out and could explain to us how to create a custom build where the standard keyboard layout is Belgian for you and German - Switzerland in my case.
    Hey there, I was having the same issue, just follow this steps:

    Code:
    1
    
    To change the german keyboard in Kali Linux 2020.02 (Debian) do the following:
    
    dpkg-reconfigure locales
    
    Choose de_DE.UTF-8 UTF-8 and unselect en_US.UTF-8 UTF-8 (by pressing Space)
    
    dpkg-reconfigure keyboard-configuration
    
    Choose your keyboard hardware
    
    For Kali Linux 2020.2 (Debian) goto GUI
    
    Settings/Settings Editor
    
    To Channel Keyboard-layout
    
    Under Line XkbLayout String change the value to de (delete us)
    
    This permanently changes the layout to the german keyboard.

  5. #5
    Join Date
    2016-Oct
    Posts
    6
    Hey everyone,

    I am stuck at the same thing. I tried to configure as mentioned above, went for xfce, locales etc.

    My login screen now even says DE-German, but when I type, ****+2 still gives me an @ instead of "

    This is super annoying.

    anyone any other idea?

    PS: I am running Kali 2021.2 on a MBP

    THx

Similar Threads

  1. Keyboard layout customization
    By cobra2001 in forum Building Archive
    Replies: 0
    Last Post: 2018-05-07, 13:19
  2. Configuring keyboard layout?
    By Tod in forum General Archive
    Replies: 5
    Last Post: 2017-09-04, 13:30
  3. Problem with keyboard layout
    By rdgcatell in forum General Archive
    Replies: 0
    Last Post: 2016-04-08, 11:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •