Results 1 to 2 of 2

Thread: Wlan0 not showing up after killing it with "airmon-ng start wlan0" and then "Kill (PID)"

  1. #1
    Join Date
    2020-Jun
    Posts
    1

    Angry Wlan0 not showing up after killing it with "airmon-ng start wlan0" and then "Kill (PID)"

    So i used the command "airmong-ng start wlan0@ then killed the internet and after that wlan0 never showed up again no matter what i did.
    i tried restarting my network manager and i tried restarting Kali Linux and nothing works, and it seems that my internet works fine since since i can access the forums...
    i run Kali Linux 2020.2 on VMware 15.5 pro which i just installed yesterday so i am a complete newbie.

    Network adapter: Qualcomm Atheros QCA9377 Wireless Network Adapter

    here are some commands that would prob might help you. idk

    ifconfig:
    Code:
    root@Marwan:/home/marwan# ifconfig
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet6 fe80::20c:29ff:fe23:5f29  prefixlen 64  scopeid 0x20<link>
            ether 00:0c:29:23:5f:29  txqueuelen 1000  (Ethernet)
            RX packets 75243  bytes 92268089 (87.9 MiB)
            RX errors 2  dropped 3  overruns 0  frame 0
            TX packets 47594  bytes 4189614 (3.9 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
            device interrupt 19  base 0x2000  
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 16  bytes 796 (796.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 16  bytes 796 (796.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0




    iwconfig:
    Code:
    root@Marwan:/home/marwan# iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.



    Network connectivity "ping google.com -c 4; traceroute google.com; curl ifconfig.me"
    Code:
    root@Marwan:/home/marwan# ping google.com -c 4; traceroute google.com; curl ifconfig.me
    PING google.com (172.217.169.206) 56(84) bytes of data.
    64 bytes from sof02s34-in-f14.1e100.net (172.217.169.206): icmp_seq=1 ttl=128 time=110 ms
    64 bytes from sof02s34-in-f14.1e100.net (172.217.169.206): icmp_seq=2 ttl=128 time=108 ms
    64 bytes from sof02s34-in-f14.1e100.net (172.217.169.206): icmp_seq=3 ttl=128 time=89.9 ms
    64 bytes from sof02s34-in-f14.1e100.net (172.217.169.206): icmp_seq=4 ttl=128 time=88.6 ms
    
    --- google.com ping statistics ---
    4 packets transmitted, 4 received, 0% packet loss, time 3011ms
    rtt min/avg/max/mdev = 88.611/99.074/109.668/9.851 ms
    traceroute to google.com (172.217.169.206), 30 hops max, 60 byte packets
     1  192.168.190.2 (192.168.190.2)  0.343 ms  0.708 ms  0.341 ms




    ifconfig wlan0 up
    Code:
    root@Marwan:/home/marwan# ifconfig wlan0 up
    wlan0: ERROR while getting interface flags: No such device




    Gateaway "route -n":
    Code:
    root@Marwan:/home/marwan# route -n
    Kernel IP routing table
    Destination         Gateway              Genmask             Flags        Metric  Ref    Use Iface
    0.0.0.0               192.168.190.2       0.0.0.0                  UG           100      0        0 eth0
    192.168.190.0     0.0.0.0                 255.255.255.0        U             100      0        0 eth0
    so what i was trying to do is to hack an internet and i was following a guide and seems that i failed hard for my 1st hack ever any idea how to make wlan0 show up again after killing it

  2. #2
    Join Date
    2020-Jul
    Posts
    12
    as i know You have to kill the pid(s) first. perhaps thats what goes wrong ? only a suggestion
    I had the same wifi card as pci card before i changed over to a dual band USB adapter.
    worked pretty good.

    1)
    airmon-ng check kill

    2)
    airmon-ng start wlan0

    on my other wifi adapter (USB) it works little different: and there i don't have the wlan0mon - i have the wlan0 (but everything works fine as it should)

    ifconfig wlan0 down
    airmon-ng check kill
    iwconfig wlan0 mode monitor
    ifconfig wlan0 up
    airmon-ng start wlan0 (to check if the wlan0 is already in monitor mode), can skip this step

    what I recognized using my USB wifi adapter and ethernet adapter together, while the ethernet was in use,
    the system often shut down my USB adapter - but that should not be an issue with a pci wifi card i think.

Similar Threads

  1. Running "airmon-ng start wlan0" command
    By Cryptic-F in forum TroubleShooting Archive
    Replies: 3
    Last Post: 2016-04-15, 08:47
  2. Replies: 8
    Last Post: 2015-12-16, 18:48
  3. ifconfig shows wlan0 but airmon-ng won't start it
    By rpilover in forum General Archive
    Replies: 5
    Last Post: 2014-01-24, 02:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •