Results 1 to 2 of 2

Thread: Oneplus 3T Install Trouble: Unable to mount /system rw!

  1. #1

    Oneplus 3T Install Trouble: Unable to mount /system rw!

    With my latest try with lineageos:

    Fast boot to twrp and swipe for factory reset, then swipe to wipe/format data
    Restart and fast boot to twrp and sideload lineageos
    Restart and setup lineageos, enable to proper dev options, install magiskmanager atk
    Fast boot twrp again and sideload magisk
    Reboot and verify magisk is all set with magisk manager
    Restart and fast boot recovery twrp so twrp is now properly installed as the default recovery
    Boot into recovery and sideload the verity/force encrypt script from the site linked in the nethunter wiki (on android 9 stock 3t image this would make the os get stuck in a bootloop, with lineageos I can run the script and then reboot into lineage just fine)
    Now I reboot into twrp and try to install nethunter. Both on stock 3t android 9 and lineageos I get the same error:
    "Error: unable to mount /system as rw!"

    I'm stuck. I've bricked the phone a dozen times trying different things with the stock 3T image of android 9 from the oneplus website. The root process would work, but the verity/force encrypt script would always make the 3T get stuck in a bootloop. With lineageos I followed all the steps in order and everything worked and the phone still functions after running the verity/force encrypt script, but nethunter just won't install, either from an adb sideload or from local memory. Best case scenario with the attempts with the stock image and the current attempt with lineageos result in the same error about being unable to mount /system as rw! Please help

  2. #2
    Join Date
    2020-Sep
    Posts
    1

    Solution:

    Quote Originally Posted by Nethunterhelp View Post
    With my latest try with lineageos:

    Fast boot to twrp and swipe for factory reset, then swipe to wipe/format data
    Restart and fast boot to twrp and sideload lineageos
    Restart and setup lineageos, enable to proper dev options, install magiskmanager atk
    Fast boot twrp again and sideload magisk
    Reboot and verify magisk is all set with magisk manager
    Restart and fast boot recovery twrp so twrp is now properly installed as the default recovery
    Boot into recovery and sideload the verity/force encrypt script from the site linked in the nethunter wiki (on android 9 stock 3t image this would make the os get stuck in a bootloop, with lineageos I can run the script and then reboot into lineage just fine)
    Now I reboot into twrp and try to install nethunter. Both on stock 3t android 9 and lineageos I get the same error:
    "Error: unable to mount /system as rw!"

    I'm stuck. I've bricked the phone a dozen times trying different things with the stock 3T image of android 9 from the oneplus website. The root process would work, but the verity/force encrypt script would always make the 3T get stuck in a bootloop. With lineageos I followed all the steps in order and everything worked and the phone still functions after running the verity/force encrypt script, but nethunter just won't install, either from an adb sideload or from local memory. Best case scenario with the attempts with the stock image and the current attempt with lineageos result in the same error about being unable to mount /system as rw! Please help

    I spent the entire day trying to figure out why this happens and i finally found it! When youre in twrp recovery go to the 'mount' options and select every partition and make sure that the read 'system' tick box is not on. The just head back and flash the file onto your partition once again. This time, it should work.

Similar Threads

  1. kali nethunter not install TWRP error mount system con rw!
    By dartpc2019 in forum Installing NetHunter
    Replies: 2
    Last Post: 2020-10-11, 22:57

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •