Results 1 to 2 of 2

Thread: How to get Nethunter 2020 to work with the nexus 5 in monitor mode on wlan0

  1. #1
    Join Date

    How to get Nethunter 2020 to work with the nexus 5 in monitor mode on wlan0

    for me, this all started with a post here:
    and i was going to post this there, but figured it would help more people here
    so if i say i downloaded something from this post, its the link above

    also i just signed up to do this and im not entirely sure if i can post links so here they are in text form
    ================================================== =====

    ================================================== =====
    bear with me, ill get to it. The good stuff starts at

    1. Google Factory from Images

    so like 5 days ago i had completed my search for a new free backup solution that will work with uefi gpt and secure boot.
    i found it, rescuezilla.

    my multi boot usb needed to be changed and with windows updating their install twice a year,
    my multi boot was becoming a pain to rebuild, so i looked to see if there was something better. there was, ventoy.
    it lets you just plop iso's in a partition without rebuilding it, but i had a problem... i had 3gb left over

    and so it begins

    i figured hey a modern linux live iso might be handy. since they all pretty much have gparted and ddrescue on em
    i figured why not pick kali, (maybe ill learn something or get a job pen testing like those cool guys on darknet diaries)
    so i did, then i couldnt leave it alone and i kept seeing nethunter and it said it works on mainly the nexus stuff.
    well i had a swelled up dusty nexus in a drawer.

    now the only thing ive done in linux is boot parted magic and run ddrescue and i have a txt file for how i did that, so im pretty much clueless, but gifted at guessing

    so ive tried 47 things in forums and 15 combos of os on os
    and then i started to realize this re4son guy is not just some dude
    he's the man
    the whole build area could be reduced to 2 folders (re4son and other)
    so after 4 days of trying to just get a build that ran . monstart-nh (see i learned something
    it happened
    and i backed it up immediately
    hers what i did (or my notes rather)
    (disclaimer, i wont be fielding questions or including how to run fastboot or twrp or warning anyone, just trying to pay it forward, this may be my last and first post)

    Reset with Hardware Keys: Google Nexus 5
    BOOTLOADER: ( down Volume + Power )

    (stock) 'Recovery mode' An Android robot with a red exclamation mark will display.

    Android system recovery: ( Power button, then press and release the Volume up button)


    extract to c:\adb (you want fastboot, adb, etc in c:\adb)
    copy cmd to c:\adb

    run cmd as admin

    (to unlock the bootloader on nexus 5)
    fastboot oem unlock
    fastboot reboot-bootloader

    TWRP KEEP TWRP_3.1.0-0_multirom (any will work but this one does bug me as much)
    (to install twpr recovery)
    fastboot flash recovery TWRP_3.1.0-0_multirom_hammerhead_20170314-03.img
    fastboot reboot-bootloader

    1. Google Factory from Images (FACTORY-M4B30Z-by-hand)

    place 7 IMG files in c:\adb (in Google-factory-IMAGES_m4b30z, extrated from
    plus TWRP_3.1.0-0_multirom_hammerhead_20170314-03.img

    boot into bootloader
    run cmd as admin in c:\adb

    fastboot erase boot
    fastboot erase cache
    fastboot erase recovery
    fastboot erase system
    fastboot erase userdata
    (clears up a problem where storeage show 12gb instead of 27)

    fastboot flash bootloader C:\adb\bootloader-hammerhead-hhz20h.img
    fastboot reboot-bootloader
    fastboot flash radio C:\adb\radio-hammerhead-m8974a-
    fastboot reboot-bootloader

    fastboot flash system C:\adb\system.img
    fastboot flash userdata C:\adb\userdata.img
    fastboot flash boot C:\adb\boot.img
    fastboot flash recovery C:\adb\recovery.img
    fastboot erase cache
    fastboot flash cache C:\adb\cache.img
    boot to stock (just to use the stock recovery once, im just being cautious)

    boot to bootloader
    fastboot flash recovery C:\adb\TWRP_3.1.0-0_multirom_hammerhead_20170314-03.img
    reboot to recovery and back it up without wiping anything and checkbox everything to:

    (or whatever, but this is home base, you should never have to use fastboot again
    copy that backup (TWRP/BACKUP/????????/FACTORY-M4B30Z-by-hand so just backup the whole thing. ???? is what its looking for)
    to your computer and your backup of your computers
    now you can tranfer it back to your phone by booting to twrp and using windows file manager

    2. Nethunter-binky

    i start this where i left off in STEP 1. (or with a fresh pre nuked install of FACTORY-M4B30Z-by-hand)

    i finish google setup to desktop (one of these 2 things cures a twrp error 1 issue i had in part 3)
    did factory restore in twrp (just the swipe) (this cured an twrp error 4 is was getting in the next step)

    i installed (binkybear nethunter) on top of it
    wait for it to kind of double reboot to android 7.1

    took a picture to create google data (one of these 2 things cures a twrp error 1 issue i had in part 3)

    i dont think i installed kalifs, chroot or did anything before i backed this up

    i just backed this up without wiping anything and checkbox everything to:

    (my idea was i could get a fresh start w this several times if the next step didnt work)
    (people have this version working, so you can always play with it now, but i liked the firey dragon

    3. NETHUNTER-1
    ok, here i just started where i left off in STEP 2.
    i installed (no wiping)
    (from this page)
    (this is a beta only mentioned on this page by re4son)

    backed up all parts as is to:
    and copied all 3 to my computer (now i have a fresh start from any point that might work)

    Now, the next part is a little fuzzy because as soon as it worked,
    I jumped up and tried to explain to my family what i had done,
    which took a while and they looked bewildered.

    i deleted that picture
    installed apk's
    hackers keyboard and ran the 2 things in it that set it up

    i ran nexmon it crashed but it did get su to ask about it
    so it still crashes if i tap that main button but it has root now
    so i hit dropdown top left tapped firmware
    searched and it said nexus 5 or fw_bcmdhd.bin or 4339
    anyway, it had picked one
    i hit backup mine (it wont go on until ya do)
    and then install

    now heres where im fuzzy
    it either worked right there and i screwed it up later
    but in any case, later i was trying to fix it and
    i saw a message that it couldnt find
    in the root of storage

    so i downloaded (from this page)

    copied fw_bcmdhd.bin.nexmon to fw_bcm4339_6_37_34_43.bin
    in the root of storage and installed it again

    source monstart-nh
    wifite -i -wlan0
    (at least it shows a list of networks, not sure what else itll do)

    but i backed it up to:

    and copied all 4 to my computer and my external backup of my computers

    I want to Thank Re4son.
    without this post I'd be trying to install 2020 code in binkybear and trying to figure out what went wrong.

    I kept thinking I should post this and I thought ya know what, it is cool to be kind


  2. #2
    Join Date
    Thanks for the post, but now the problem is how to upgrade to 2020.3 Apk and save monitor mode because now show me that version is 2017...

Similar Threads

  1. Nexus 5 - Can't put wlan0 in monitor mode - Nexmon crashing
    By pispuso in forum NetHunter General Questions
    Replies: 5
    Last Post: 2023-08-31, 19:16
  2. Nexus 5 - Can't get monitor mode to work
    By pispuso in forum NetHunter General Questions
    Replies: 7
    Last Post: 2020-10-24, 00:09
  3. Lost monitor mode on Nexus 5 after installing 2020.1
    By RChadwick in forum NetHunter General Questions
    Replies: 41
    Last Post: 2020-05-04, 22:43
  4. Replies: 2
    Last Post: 2020-01-05, 17:54
  5. Nexus 5 D821 Unable to put wlan0 into monitor mode
    By dephekt_ in forum NetHunter General Questions
    Replies: 1
    Last Post: 2019-12-30, 09:40

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts