I bought a wlan adapter and tried to install it in Kali Linux that is running at VM Virtual Box. Unfortunately I have the problem, that I can't find any Accesspoints with this stick.

Using Airodump just does not show up any AP. Using 'iwlist scan' gives me 'Interface doesn't support scanning: Device or resource busy'.

I dont think it is a physical problem since the stick works on Windows 10. On the other hand I tried another stick for Kali and using this stick i can see other networks with airodump (but I cant use this stick since it doesnt support monitor mode).

I even got a cd with a driver on it. But when I try to install it i get following output:

root@kali:~/Desktop/DPO_RT5572_LinuxSTA_2.6.1.3_20121022# make
make -C tools
make[1]: Entering directory '/root/Desktop/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/root/Desktop/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
cp -f os/linux/Makefile.6 /root/Desktop/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/Makefile
make -C /lib/modules/5.5.0-kali2-amd64/build SUBDIRS=/root/Desktop/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.5.0-kali2-amd64'
sh: 0: Can't open /usr/src/linux-headers-5.5.0-kali2-common/scripts/mkmakefile
make[3]: * [/usr/src/linux-headers-5.5.0-kali2-common/Makefile:514: outputmakefile] Error 127
/usr/src/linux-headers-5.5.0-kali2-common/Makefile:659: include/config/auto.conf.cmd: No such file or directory
make[2]: * [/usr/src/linux-headers-5.5.0-kali2-common/Makefile:677: include/config/auto.conf.cmd] Error 2
make[1]: * [/usr/src/linux-headers-5.5.0-kali2-common/Makefile:179: sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.5.0-kali2-amd64'
make: * [Makefile:389: LINUX] Error 2

I've read in many forums that many ppl. got the same struggle, but no fix i found worked for me.
Hope anyone can help me. (I'm not a native speaker, sorry for english mistakes)