Results 1 to 5 of 5

Thread: external USB drive with exFAT not mounting (did anything be changed with a lately update?)

  1. #1
    Join Date
    2020-Jul
    Posts
    12

    external USB drive with exFAT not mounting (did anything be changed with a lately update?)

    Hello,
    i have a problem to mount an external USB drive with exFAT partition.
    Some weeks ago as I installed Kali 2020.2 everything was fine and I could mount my ext. HDD and
    use it.
    I think, it was after one of the last updated files during the last week, that I no longer can mount the exFAT partition of the USB HDD.
    I thought I broke something and made a complete fresh installation of Kali, but that did not help.

    The possible needed files (exfat-fuse and exfat-utils) were already installed, i tried to reinstall them, but did not help.

    Is there anything I can do?

    I wonder, because 1 or 1.5 weeks ago this problem did not exist - I used the USB drive with that exFAT pratition, plugged in - the desktop icon came up
    and i could mount it and use it.

    thanx for help!

    kind regards

  2. #2
    Join Date
    2020-Jul
    Posts
    1
    Hi there,

    same issue here, worked all fine on two installed Kalis at different machines
    since after an update exfat will not be mounted anymore.
    Other distros I use (Debian aso..) still mount, so I better dont update for a while ^^

    Anyway, if you need to mount exfat maybe it will work for you so as I do...

    Code:
    sudo mount.exfat-fuse /dev/sdc1 /mnt/myexFatFolder
    (at mine the usb was sdc1 - so adjust if necessary)

    Found that mount.exfat-fuse at /sbin, for me this solution works

    kind regards

  3. #3
    Join Date
    2020-Jul
    Posts
    2
    Hello
    I have the same problem with my USB.
    The message in /var/log/syslog is
    kali kernel: [17853.979094] exfat: disagrees about version of symbol module_layout

    uname -r is: 4.19.0-kali5-amd64
    the module directory is /lib/modules/4.19.0-kali5-amd64/kernel/fs

    so seems to be ok.
    But what?

  4. #4
    Join Date
    2020-Jul
    Posts
    12
    i found a workaround to get access to my data - could connect the external HDD to my Router and use it as a NAS.
    So i pulled the data and reformat the HDD to a format that works with my Linux installation.

  5. #5
    Join Date
    2020-Jul
    Posts
    2
    This worked also for me
    sudo mount.exfat-fuse /dev/sdc1 /mnt/myexFatFolder

    Thanks. IT'S THE SOLUTION

Similar Threads

  1. Disable mounting hard drive on boot
    By Rhesa in forum Kali Linux TroubleShooting
    Replies: 0
    Last Post: 2020-05-10, 22:57
  2. Problem with mounting drive
    By fpn in forum TroubleShooting Archive
    Replies: 0
    Last Post: 2018-09-25, 20:10
  3. Replies: 2
    Last Post: 2014-04-28, 20:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •